Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth headset mic not visible
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Thu Jan 21, 2016 8:06 pm    Post subject: Bluetooth headset mic not visible Reply with quote

Hi,

I have a Bluetooth headset which can connect to my computer and playback sounds. However, the mic does not show up. While playing back music I have tried:

Code:

arecord -l


This has only returned internal devices which at the moment do not have any inputs attached.

Installing Blueman exposes three profiles:

Headset
Handsfree
Audio Sink

Both Headset and Audio Sink output sound while Handsfree does not. None seem to offer any recording option. I've enabled every applicable input option in the kernel that I can find. The Bluetooth mic just fails to appear.

My current theory is that this isn't a audio sub-system problem due there being no evidence of the input device appearing. Please help.


Thanks.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Thu Jan 21, 2016 9:25 pm    Post subject: Reply with quote

Hi,

you cannot manage Bluetooth audio with Alsa since Bluetooth version 5. The Bluetooth stack move to Pulseaudio for audio Bluetooth support in this version. So, if you use Bluetooth 5, you can see input and output devices in Pulseaudio and use your mic.

For awhile, Pulseaudio did'nt support Headset Head Unit (HSP/HFP) so, I could not use my Bluetooth mic at all. Now this choice appear in Pavucontrol. I haven't use my Bluetooth mic yet so, I cannot say if it work or not. I use Bluetooth audio mainly for playback.

If you use Bluetooth 4, than it support Alsa. You need to configure your /etc/asound.conf and/or your ~/.asoundrc for Bluetooth. With the Bluetooth MAC address Alsa understand to direct audio data to your Bluetooth headset. For Bluetooth mic, I haven't set alsa at all. It is documented on the web.

http://www.alsa-project.org/
_________________
Paul
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Thu Jan 21, 2016 11:07 pm    Post subject: Reply with quote

Hi,

Thanks for your quick reply.

I am using Bluetooth version 5 and Pulseaudio. I have tried selecting Headset Head Unit (HSP/HFP) in the Pavucontrol. Sadly this hasn't helped. What I have noted is that sounds played back are picked up. I have recorded a few seconds of from the beginning of the Skype test call but not my own voice.


I have added these use flags to Pulseaudio (although unhelpful so far, are probably necessary).
+ - native-headset : Build with native HSP backend for bluez 5.
+ - ofono-headset : Build with oFono HFP backend for bluez 5, requires net-misc/ofono.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Fri Jan 22, 2016 11:22 am    Post subject: Reply with quote

Is your Alsa configuration redirect audio data to Pulseaudio? You must have an /etc/asound.conf and/or an ~/.asoundrc like this:
Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}

HSP/HFP may be just not usable. Ofono is an alternative.
_________________
Paul
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Sat Jan 23, 2016 12:37 am    Post subject: Reply with quote

Hi,

I can't find either file /etc/asound.conf nor ~/.asoundrc. None of my installed ebuilds claim ownership. I have tried creating a /etc/asound.conf file as described below, this had no impact.

I have attempted to affect gstreamer properties but there doesn't seem to be any ebuilds that interact with gstreamer. I am using the KDE desktop profile which might explain that in a small way at least.

Also I tried unmasking the latest version of bluez to see that would have an impact. Since then I've reverted to the stable Bluez ebuild.

When I select the Headset Head Unit (HSP/HFP) in the Pavucontrol all sound output ceases, I am unable to record anything. When I have High Fidelity Playback {A2DP Sink} selected then there is sound output,and when I try to record whatever is on the output channel is recorded but now mic input.

Thanks.
Back to top
View user's profile Send private message
zx2c4
Developer
Developer


Joined: 09 Jun 2005
Posts: 177

PostPosted: Wed Aug 17, 2016 2:06 pm    Post subject: Reply with quote

Quote:
When I select the Headset Head Unit (HSP/HFP) in the Pavucontrol all sound output ceases, I am unable to record anything. When I have High Fidelity Playback {A2DP Sink} selected then there is sound output,and when I try to record whatever is on the output channel is recorded but no mic input.


Did you ever fix this? I'm facing the same issue. A2DP mode enables only a sink, not a source. HSP/HFP just hangs for recording or playback.
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Thu Aug 18, 2016 9:31 am    Post subject: Not fixed Reply with quote

Hi,

Unfortunately, I have not managed to fix this. It has fallen on to the back burner. I'll take another look at this over the weekend.

Thanks.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Thu Aug 18, 2016 6:23 pm    Post subject: Reply with quote

Since Bluez 5, Bluetooth audio is only available through Pulseaudio. At the beginning, only output sink was available with A2DP. There was a regression compare to Bluez 4 where source and output sinks where available.

Than came back HSP/HFP for source sink in Pulseaudio but it was not working properly last time I try it. You have to turn yourself to Ofono who is suppose to support Bluetooth input microphone recording. I haven't test it yet.
_________________
Paul
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 529

PostPosted: Fri Aug 19, 2016 4:25 pm    Post subject: Reply with quote

I hope that this is relevant; to see my microphone, Ineeded to enable CONFIG_INPUT_UINPUT in my kernel configuration, and build pulseaudio with USE="native-headset ofono-headset".
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Mon Aug 22, 2016 8:28 pm    Post subject: Reply with quote

I have tested over the weekend following the logic keet and Logicien have suggested but without success.

At the moment I can not think of anything else to try, not other ways to test. I am sorry for not having anything more positive to contribute.
Back to top
View user's profile Send private message
zx2c4
Developer
Developer


Joined: 09 Jun 2005
Posts: 177

PostPosted: Wed Aug 24, 2016 2:23 am    Post subject: Reply with quote

I fixed it.

Before in dmesg I had lines like:

Code:
Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21e6.hcd failed with error -2
Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e6.hcd not found


So, I set about acquiring /lib/firmware/brcm/BCM20702A1-0a5c-21e6.hcd:

Code:
wget http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V1201650_WHQL_Win10.zip
unzip Bluetooth_V1201650_WHQL_Win10.zip
hex2hcd Bluetooth/BCM_DriverOnly/64/BCM20702A1_001.002.014.1483.1669.hex -o /lib/firmware/brcm/BCM20702A1-0a5c-21e6.hcd


Then I reloaded the bluetooth modules, and found in my dmesg:

Code:
Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
Bluetooth: hci0: BCM20702A1 (001.002.014) build 1669
Bluetooth: hci0: Broadcom Bluetooth Device


And then after that everything magically worked.

It's likely you have a different bluetooth device than me. But you still might be facing firmware loading issues. Check your dmesg, and Google for the file it complains about not having.
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Wed Aug 24, 2016 9:56 pm    Post subject: Reply with quote

Hi,

Sadly for one reason or another, this hasn't helped me. At least not much.

I do have a different bluetooth device which did post the file not found message as you have already posted.

Following your example and utilising the information provided by dmesg, I converted the appropriate file, and installed it. This cleared the file not found message but did not resolve the microphone issue.

Code:
Bluetooth: hci0: BCM20702A1 (001.002.014) build 1669
Bluetooth: hci0: BCM20702A1 (001.002.014) build 1468


I have targeted both of these builds to convert to the file needed but neither has worked, at least in the sense of recording sound.
Back to top
View user's profile Send private message
zx2c4
Developer
Developer


Joined: 09 Jun 2005
Posts: 177

PostPosted: Wed Aug 24, 2016 10:03 pm    Post subject: Reply with quote

Try compiling pulseaudio without USE=ofono-headset but with USE=native-headset.


USE="-ofono-headset native-headset"
Back to top
View user's profile Send private message
Duco Ergo Sum
Apprentice
Apprentice


Joined: 06 Dec 2005
Posts: 153
Location: Winsford

PostPosted: Sat Aug 27, 2016 9:14 pm    Post subject: Reply with quote

Hi,

I have tried both:

USE="-ofono-headset native-headset"
USE="ofono-headset -native-headset"

And

USE="ofono-headset native-headset"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum