Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade to plasma 5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 10:39 am    Post subject: upgrade to plasma 5 Reply with quote

Hi guys!
I've tried to upgrade mi KDE 4.14 to plasma5 following the wiki-guide ... but I came across a lot of trouble ....

first of all ... when i cleaned the old KDE4 packages with
Code:
for x in freespacenotifier kcheckpass kcminit kdebase-cursors kdebase-startkde kdm kephal khotkeys kinfocenter klipper kmenuedit krunner kscreensaver ksmserver ksplash kstartupconfig kstyles ksysguard ksystraycmd kwin kwrited libkgreeter libkworkspace liboxygenstyle libplasmaclock libplasmagenericshell libtaskmanager plasma-workspace powerdevil qguiplatformplugin_kde solid-actions-kcm systemsettings; do equery -q d ${x} | sed -e "s/-[0-9].*//"; done | sed -e "/kdebase-meta/g" -e "/kde-meta/g" | xargs emerge --deselect
and then
Code:
emerge --ask --changed-use --newrepo --deep world
Iupgrade to xorg-server 1.18 that is uncompatible with nvidia-drivers-355 .... so i lost X ....

somebody can help me ??? thanks in advance
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 10:51 am    Post subject: Reply with quote

Your problem is unrelated to Plasma and you haven't lost X.

Why is your system wanting to upgrade to xorg-server-1.18 while you are using an old version of nvidia-drivers? Hint: nvidia-drivers-355.11-r3 and later would merge perfectly fine with xorg-server-1.18.

Please check your entries in package.keywords.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 10:59 am    Post subject: Reply with quote

Thanks for reply
ok ! but i don't understand what's the problem

Code:
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktextwidgets-5.18.0 ~amd64
# required by kde-plasma/ksysguard-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libksysguard-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/polkit-kde-agent-5.5.4 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcrash-5.18.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/karchive-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfigwidgets-5.18.0 ~amd64
# required by kde-plasma/kmenuedit-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/sonnet-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo[sddm]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/sddm-kcm-5.5.4 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjobwidgets-5.18.0 ~amd64
# required by kde-plasma/powerdevil-5.5.4::gentoo[handbook]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdoctools-5.18.0 ~amd64
# required by kde-frameworks/krunner-5.18.0::gentoo
# required by kde-plasma/milou-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/threadweaver-5.18.0 ~amd64
# required by kde-base/kdelibs-4.14.8::gentoo[handbook]
# required by kde-base/qguiplatformplugin_kde-4.11.19::gentoo
# required by kde-plasma/plasma-desktop-5.5.4::gentoo[qt4]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khelpcenter-5.5.4 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-5.5.4 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjsembed-5.18.0 ~amd64
# required by kde-plasma/systemsettings-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcmutils-5.18.0 ~amd64
# required by kde-plasma/kscreenlocker-5.5.4::gentoo
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-5.5.4 ~amd64
# required by kde-plasma/milou-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/plasma-5.18.0 ~amd64
# required by kde-frameworks/baloo-5.18.0::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kfilemetadata-5.18.0 ~amd64
# required by kde-plasma/milou-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfig-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/baloo-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/powerdevil-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwin-5.5.4 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdeclarative-5.18.0 ~amd64
# required by kde-plasma/oxygen-fonts-5.4.3::gentoo
# required by kde-frameworks/frameworkintegration-5.18.0::gentoo
# required by kde-plasma/oxygen-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/extra-cmake-modules-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwallet-pam-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/systemsettings-5.5.4 ~amd64
# required by kde-plasma/breeze-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwidgetsaddons-5.18.0 ~amd64
# required by kde-plasma/kinfocenter-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcompletion-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksshaskpass-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kinfocenter-5.5.4 ~amd64
# required by kde-plasma/ksshaskpass-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwallet-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/bluedevil-5.5.4 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlrpcclient-5.18.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcodecs-5.18.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kbookmarks-5.18.0 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwindowsystem-5.18.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kross-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-5.5.4 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjs-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwrited-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/user-manager-5.5.4 ~amd64
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-meta-5.5.4 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdnssd-5.18.0 ~amd64
# required by kde-plasma/powerdevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kglobalaccel-5.18.0 ~amd64
# required by kde-plasma/kinfocenter-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdbusaddons-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo[geolocation]
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/networkmanager-qt-5.18.0 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdecoration-5.5.4 ~amd64
# required by kde-plasma/kscreen-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libkscreen-5.5.4 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khotkeys-5.5.4 ~amd64
# required by kde-plasma/user-manager-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcoreaddons-5.18.0 ~amd64
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kde-cli-tools-5.5.4 ~amd64
# required by kde-plasma/khelpcenter-5.5.4::gentoo
# required by kde-base/kdelibs-4.14.8::gentoo[handbook]
# required by kde-base/qguiplatformplugin_kde-4.11.19::gentoo
# required by kde-plasma/plasma-desktop-5.5.4::gentoo[qt4]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kparts-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo[gtk]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/breeze-gtk-5.5.4 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesu-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kemoticons-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/milou-5.5.4 ~amd64
# required by kde-plasma/kde-gtk-config-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo[gtk]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knewstuff-5.18.0 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlgui-5.18.0 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpackage-5.18.0 ~amd64
# required by kde-plasma/sddm-kcm-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo[sddm]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ki18n-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kmenuedit-5.5.4 ~amd64
# required by kde-plasma/breeze-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/breeze-icons-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtpaths-5.5.1-r1 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kactivities-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreen-5.5.4 ~amd64
# required by kde-plasma/khelpcenter-5.5.4::gentoo
# required by kde-base/kdelibs-4.14.8::gentoo[handbook]
# required by kde-base/qguiplatformplugin_kde-4.11.19::gentoo
# required by kde-plasma/plasma-desktop-5.5.4::gentoo[qt4]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kinit-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kservice-5.18.0 ~amd64
# required by kde-frameworks/baloo-5.18.0::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-db/lmdb-0.9.17 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/breeze-5.5.4 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/khtml-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-integration-5.5.4 ~amd64
# required by kde-plasma/kwin-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreenlocker-5.5.4 ~amd64
# required by kde-plasma/systemsettings-5.5.4::gentoo[gtk]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kde-gtk-config-5.5.4 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifications-5.18.0 ~amd64
# required by kde-plasma/bluedevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/bluez-qt-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo[wallpapers]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-wallpapers-5.5.4 ~amd64
# required by kde-frameworks/kdelibs4support-5.18.0::gentoo
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesignerplugin-5.18.0 ~amd64
# required by kde-plasma/sddm-kcm-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo[sddm]
# required by kde-plasma/plasma-meta (argument)
=x11-misc/sddm-0.13.0-r1 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-desktop-5.5.4 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpeople-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/attica-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdeplasma-addons-5.5.4 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/solid-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-apps/kio-extras-15.08.3 ~amd64
# required by kde-plasma/bluedevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kiconthemes-5.18.0 ~amd64
# required by kde-plasma/powerdevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifyconfig-5.18.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpty-5.18.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kgamma-5.5.4 ~amd64
# required by kde-plasma/oxygen-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/frameworkintegration-5.18.0 ~amd64
# required by dev-qt/qtpaths-5.5.1-r1::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtcore-5.5.1 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kunitconversion-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktexteditor-5.18.0 ~amd64
# required by kde-plasma/powerdevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kidletime-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kio-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemmodels-5.18.0 ~amd64
# required by kde-frameworks/frameworkintegration-5.18.0::gentoo
# required by kde-plasma/oxygen-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-fonts-5.4.3 ~amd64
# required by kde-plasma/powerdevil-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kauth-5.18.0 ~amd64
# required by kde-plasma/systemsettings-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemviews-5.18.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kguiaddons-5.18.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksysguard-5.5.4 ~amd64
# required by kde-plasma/libksysguard-5.5.4::gentoo
# required by kde-plasma/ksysguard-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kf-env-3 ~amd64
# required by kde-plasma/khelpcenter-5.5.4::gentoo
# required by kde-base/kdelibs-4.14.8::gentoo[handbook]
# required by kde-base/qguiplatformplugin_kde-4.11.19::gentoo
# required by kde-plasma/plasma-desktop-5.5.4::gentoo[qt4]
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdelibs4support-5.18.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/krunner-5.18.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.4::gentoo
# required by kde-plasma/khotkeys-5.5.4::gentoo
# required by kde-plasma/plasma-meta-5.5.4::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kded-5.18.0 ~amd64
# required by google-chrome (argument)
=www-client/google-chrome-48.0.2564.97_p1 ~amd64
# required by paraview (argument)
=sci-visualization/paraview-4.4.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.4::gentoo[pulseaudio]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-pa-5.5.4 ~amd64


I have x11-drivers/nvidia-drivers-355.11-r2


Last edited by drudox on Mon Feb 01, 2016 11:02 am; edited 1 time in total
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 11:01 am    Post subject: Reply with quote

i have x11-drivers/nvidia-drivers-355.11-r2
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 11:41 am    Post subject: Reply with quote

genstorm wrote:
Hint: nvidia-drivers-355.11-r3 and later would merge perfectly fine with xorg-server-1.18.

Please check your entries in package.keywords.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 11:49 am    Post subject: Reply with quote

I don't understand what I have to check ! could u help me pls ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 12:16 pm    Post subject: Reply with quote

Please check available nvidia-drivers and xorg-server versions on your system:

Code:
$ equery l -ip nvidia-drivers
$ equery l -ip xorg-server


Please check if you have unmasked xorg-server in the past:

Code:
$ grep -R xorg-server /etc/portage/package.keywords


Finally, please get to know how portage works with those directories: https://wiki.gentoo.org/wiki/Handbook:X86/Portage/Files
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 4:54 pm    Post subject: Reply with quote

Code:
quad-Gentoo ~ # grep -R xorg-server /etc/portage/package.keywords
grep: /etc/portage/package.keywords: No such file or directory


I have add ~amd64 in my mask.conf .. so now I have

Code:
quad-Gentoo ~ # equery l -ip nvidia-drivers                     
 * Searching for nvidia-drivers ...
[-P-] [M ] x11-drivers/nvidia-drivers-96.43.23-r1:0/96
[-P-] [M ] x11-drivers/nvidia-drivers-173.14.39-r1:0/173
[-P-] [  ] x11-drivers/nvidia-drivers-304.131:0/304
[-P-] [  ] x11-drivers/nvidia-drivers-304.131-r1:0/304
[-P-] [  ] x11-drivers/nvidia-drivers-340.96:0/340
[-P-] [  ] x11-drivers/nvidia-drivers-340.96-r1:0/340
[-P-] [  ] x11-drivers/nvidia-drivers-346.96-r1:0/346
[-P-] [  ] x11-drivers/nvidia-drivers-346.96-r2:0/346
[-P-] [  ] x11-drivers/nvidia-drivers-352.63:0/352
[-P-] [  ] x11-drivers/nvidia-drivers-352.79:0/352
[-P-] [  ] x11-drivers/nvidia-drivers-355.11-r2:0/355
[-P-] [  ] x11-drivers/nvidia-drivers-355.11-r3:0/355
[IP-] [  ] x11-drivers/nvidia-drivers-361.18-r1:0/361
quad-Gentoo ~ # equery l -ip xorg-server
 * Searching for xorg-server ...
[-P-] [  ] x11-base/xorg-server-1.12.4-r5:0/1.12.4
[-P-] [  ] x11-base/xorg-server-1.12.4-r7:0/1.12.4
[-P-] [  ] x11-base/xorg-server-1.15.2-r2:0/1.15.2
[-P-] [  ] x11-base/xorg-server-1.15.2-r4:0/1.15.2
[-P-] [  ] x11-base/xorg-server-1.16.4:0/1.16.1
[-P-] [  ] x11-base/xorg-server-1.16.4-r5:0/1.16.1
[-P-] [  ] x11-base/xorg-server-1.17.4:0/1.17.4
[IP-] [  ] x11-base/xorg-server-1.18.0:0/1.18.0
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 4:58 pm    Post subject: Reply with quote

thanks for your help ! but i still dont understand .... I have upgrade to xorg-server1.18.0 and nvidia drivers have been automatically upgrade to x11-drivers/nvidia-drivers-361.18-r1
Is it ok ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 5:22 pm    Post subject: Reply with quote

drudox wrote:
Code:
quad-Gentoo ~ # grep -R xorg-server /etc/portage/package.keywords
grep: /etc/portage/package.keywords: No such file or directory

My fault, it is package.accept_keywords these days, I keep forgetting.

Code:
I have add ~amd64 in my mask.conf

What exactly did you do?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Mon Feb 01, 2016 5:34 pm; edited 2 times in total
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 5:33 pm    Post subject: Reply with quote

Code:
quad-Gentoo ~ # grep -R xorg-server /etc/portage/package.accept_keywords
quad-Gentoo ~ #


I've added
Code:
ACCEPT_KEYWORDS="~amd64"
in /etc/portage/make.conf , then i've emerge xorg-server and the 1.18 versions has been compiled with x11-drivers1.18 ... nvidia-drivers-361 and other 10 upgraded packages
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 5:34 pm    Post subject: Reply with quote

If you switched from amd64 to ~amd64 in your make.conf then yes, it solves your problem by going unstable for all the packages on your system.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Feb 01, 2016 9:08 pm    Post subject: Reply with quote

ok but i've still problem after giving

Code:
emerge --ask --changed-use --newrepo --deep world

the output is
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 

  (dev-qt/qtdbus-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    (and 1 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 5 more with the same problem)

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (kde-frameworks/frameworkintegration-5.18.0:5/5.18::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                             
    (and 19 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.5.1 required by (dev-qt/qtscript-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    (and 8 more with the same problem)

  (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.4.2[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                                                               
    (and 2 more with the same problem)

app-text/poppler:0

  (app-text/poppler-0.40.0-r1:0/58::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    app-text/poppler:0/51=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.5.0:0/0::gentoo, installed)
                    ^^^^^^                                                                                                                                         
    (and 1 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^                 ^^^^^                                                                                                                     
    (and 1 more with the same problem)

  (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.5.1[gles2=] required by (dev-qt/qtopengl-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                           
    (and 5 more with the same problem)

media-libs/giflib:0

  (media-libs/giflib-5.1.2:0/7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.4.0:0/5::gentoo, installed)
                     ^^^^^                                                                                                 

media-gfx/exiv2:0

  (media-gfx/exiv2-0.24-r1:0/13::gentoo, installed) pulled in by
    >=media-gfx/exiv2-0.20:0/13=[xmp] required by (kde-apps/libkexiv2-4.14.3:4/4.14::gentoo, installed)
                          ^^^^^^                                                                                                           
    (and 3 more with the same problem)

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    >=media-gfx/exiv2-0.25:=[xmp=] required by (kde-apps/libkexiv2-15.12.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                ^^^^                                                                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-l10n-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-l10n-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdetoys-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdetoys-meta required by @selected

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-2.7.11-r2:2.7/2.7::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, installed)

  (kde-apps/kdeutils-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdeutils-meta required by @selected

  (kde-apps/kdenetwork-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdenetwork-meta required by @selected

  (kde-apps/kate-15.08.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kate-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdenetwork-meta-15.08.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kdenetwork-meta required by @selected
    >=kde-apps/kdenetwork-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdegames-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdegames-meta required by @selected

  (kde-apps/kdemultimedia-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdemultimedia-meta required by @selected

  (kde-apps/kate-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/kate-4.14.3:4[aqua=] (>=kde-apps/kate-4.14.3:4[-aqua]) required by (kde-apps/kdesdk-meta-4.14.3:4/4::gentoo, installed)

  (kde-apps/kdepim-l10n-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/kdepim-l10n-4.14.3:4[aqua=] (>=kde-apps/kdepim-l10n-4.14.3:4[-aqua]) required by (kde-apps/kdepim-meta-4.14.8:4/4::gentoo, installed)

  (kde-apps/kdeadmin-meta-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdeadmin-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdeadmin-meta required by @selected

  (kde-apps/kdegraphics-meta-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdegraphics-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdegraphics-meta required by @selected

  (kde-apps/kdegraphics-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdegraphics-meta required by @selected

  (kde-apps/kdeutils-meta-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kdeutils-meta required by @selected
    >=kde-apps/kdeutils-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdeadmin-meta-4.14.3:4/4::gentoo, installed) pulled in by
    kde-apps/kdeadmin-meta required by @selected

  (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4[threads(+)] required by (dev-python/pytz-2015.7:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/pyxdg-0.25-r1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pycups-1.9.72:0/0::gentoo, installed)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.26:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/sip-4.16.9:0/11::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/versioneer-0.15:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/python-dateutil-2.4.2-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.1:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/PyQt5-5.5.1:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    dev-lang/python:3.4[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    dev-lang/python:3.4[tk?] (dev-lang/python:3.4) required by (dev-python/pyopengl-3.1.0:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[threads(+)] required by (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, installed)
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygments-2.1:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/docutils-0.12:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[tk?,threads(+)] (dev-lang/python:3.4[threads(+)]) required by (dev-python/matplotlib-1.5.1:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/cycler-0.9.0:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[threads] required by (kde-base/pykde4-4.14.3:4/4.14::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pycurl-7.19.3.1-r2:0/0::gentoo, installed)
    dev-lang/python required by @selected

  (kde-apps/kdetoys-meta-15.08.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdetoys-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdetoys-meta required by @selected

  (kde-plasma/kscreenlocker-5.5.4:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kscreenlocker-5.5.4:5 required by (kde-plasma/plasma-meta-5.5.4:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/kscreenlocker-5.5.4:5 required by (kde-plasma/plasma-workspace-5.5.4:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/kscreenlocker-5.5.4:5 required by (kde-plasma/kwin-5.5.4:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdemultimedia-meta-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdemultimedia-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdemultimedia-meta required by @selected

  (kde-base/kcheckpass-4.11.19:4/4.11::gentoo, installed) pulled in by
    >=kde-base/kcheckpass-4.11.19:4[aqua=] (>=kde-base/kcheckpass-4.11.19:4[-aqua]) required by (kde-base/kscreensaver-4.11.19:4/4.11::gentoo, installed)

  (kde-apps/kdegames-meta-15.08.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdegames-meta-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdegames-meta required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Thank you very very much for your support !!!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6869
Location: Austria

PostPosted: Mon Feb 01, 2016 9:34 pm    Post subject: Reply with quote

That really is Portage's way of punishment for you going from amd64 to ~amd64 in the middle of an upgrade.

You could try adding --update and --backtrack=300 to your emerge command.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Feb 02, 2016 2:47 pm    Post subject: Reply with quote

still problems ...

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.1:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-Data-Dumper-2.158.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                             
    (and 20 more with the same problem)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    (and 30 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.58.0-r1:0/1.58.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.56.0= required by (app-office/akonadi-server-1.13.0-r2:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                             

media-gfx/exiv2:0

  (media-gfx/exiv2-0.24-r1:0/13::gentoo, installed) pulled in by
    media-gfx/exiv2:0/13= required by (app-misc/strigi-0.7.8-r1:0/0::gentoo, installed)
                   ^^^^^^                                                                                                 
    (and 1 more with the same problem)

  (media-gfx/exiv2-0.25-r2:0/14::gentoo, ebuild scheduled for merge) pulled in by
    >=media-gfx/exiv2-0.25:=[xmp=] required by (kde-apps/libkexiv2-15.12.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                ^^^^                                                                                                                                                                   

media-libs/x264:0

  (media-libs/x264-0.0.20151011:0/148::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/x264-0.0.20140308:0/142::gentoo, installed) pulled in by
    >=media-libs/x264-0.0.20100423:0/142= required by (media-video/mplayer-1.2.1:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                   
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-l10n-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-l10n-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdepim-l10n-4.14.3-r1:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdepim-l10n-4.14.3-r1:4[aqua=] (>=kde-apps/kdepim-l10n-4.14.3-r1:4[-aqua]) required by (kde-apps/kdepim-meta-4.14.10-r1:4/4::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


how can bypass this problem ??? pls help :cry:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum