Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] New USB ethernet device?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sat Jan 16, 2016 1:32 pm    Post subject: [SOLVED] New USB ethernet device? Reply with quote

Hallo!
i have been recently gifted with an Asus Zenbook, which comes with a nice USB ethernet (wired, 1gbps) adapter, it's a black box labelled ASUS which is recognized by gentoo as:

Code:

[72404.554169] usb 2-3: new SuperSpeed USB device number 3 using xhci_hcd
[72404.565601] usb 2-3: New USB device found, idVendor=0bda, idProduct=8153
[72404.565608] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[72404.565612] usb 2-3: Product: USB 10/100/1000 LAN
[72404.565616] usb 2-3: Manufacturer: Realtek
[72404.565620] usb 2-3: SerialNumber: 9CEBE823EDD1


and lsusb says:
Code:

laptop usb # lsusb
Bus 002 Device 003: ID 0bda:8153 Realtek Semiconductor Corp.


I cannot find any driver which will work on this... i am using a Gentoo Sources 4.1.12 kernel...

The classic rtl8150 driver does not work.

Anyone has any ideas?
_________________
Willy Gardiol
willy@gardiol.org


Last edited by shimitar on Sat Jan 16, 2016 2:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42569
Location: 56N 3W

PostPosted: Sat Jan 16, 2016 1:43 pm    Post subject: Reply with quote

shimitar,

Its the
Code:
< > Realtek RTL8152/RTL8153 Based USB Ethernet Adapters (NEW)
you need.
Search for CONFIG_USB_RTL8152
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sat Jan 16, 2016 1:56 pm    Post subject: Reply with quote

Thank you!
It seems that genkernel does not build it by default! Will have to remember to run menuconfig next time.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42569
Location: 56N 3W

PostPosted: Sat Jan 16, 2016 2:01 pm    Post subject: Reply with quote

shimitar,

You can customise genkernel yourself or file a bug and ask the devs to add it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum