Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Connman not starting with systemd [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Fri Jan 15, 2016 2:31 am    Post subject: Connman not starting with systemd [SOLVED] Reply with quote

I'm getting an 'exit failure' upon starting connman with systemd. I'm not sure when this started but systemd can't start connman with
Code:
systemctl start connman.service


Anyone else having this issue with the latest connman package?


Last edited by dsreyes1014 on Thu Jan 28, 2016 6:02 am; edited 1 time in total
Back to top
View user's profile Send private message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Sun Jan 24, 2016 2:43 am    Post subject: Reply with quote

It won't start on two machines now.

Code:
# journalctl -u connman


is giving me

Code:
systemd[1]: Starting Network Connection Manager Daemon...
connmand[225]: Connection Manager version 1.30
connmand[225]: connmand[225]: Connection Manager version 1.30
systemd[1]: Started Network Connection Manager Daemon.
systemd[1]: connman.service: Main process exited, code=exited, status=1/FAILURE
connmand[225]: connmand[225]: Aborting (signal 11) [/usr/sbin/connmand]
systemd[1]: connman.service: Unit entered failed state.
systemd[1]: connman.service: Failed with result 'exit-code'.
Back to top
View user's profile Send private message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Tue Jan 26, 2016 12:58 am    Post subject: Reply with quote

Anyone having these issues? I noticed on Arch they have a 1.30-1. Should I wait for an update on Gentoo? I've checked systemd files and tried starting connman with connmand -n but still nothing. Don't know what to check next with the program.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Tue Jan 26, 2016 1:48 am    Post subject: Reply with quote

Did this start after an upgrade since dhcpcd:6.10.0 went stable? If you are on 6.10.0 maybe the below applies:
I'm not having the problem, don't use connman and am batting around 1000 for being wrong in 2016 - (my brain is firmly still on holidays ;) )- but this looks like it might be related to:
Quote:
2016-01-08-some-dhcpcd-hooks-are-now-examples
Title Some dhcpcd hooks are now examples
Author William Hubbs <williamh@gentoo.org>
Posted 2016-01-08
Revision 2

In dhcpcd-6.10.0, the following hooks are no longer installed in
/lib/dhcpcd/dhcpcd-hooks by default:

10-wpa_supplicant
15-timezone
29-lookup-hostname

These are now installed in /usr/share/dhcpcd/hooks, which is an example
directory.

If you were using these hooks before you upgrade to 6.10.0, you will
need to copy them back to the /lib/dhcpcd/dhcpcd-hooks directory after the
upgrade.

If you are using dhcpcd you may need to add back wpa_supplicant per the above: That's what I'd try first, anyway.
Code:
cp /usr/share/dhcpcd/hooks/10-wpa_supplicant /lib/dhcpcd/dhcpcd-hooks/
Back to top
View user's profile Send private message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Tue Jan 26, 2016 1:58 am    Post subject: Reply with quote

ian.au wrote:
Did this start after an upgrade since dhcpcd:6.10.0 went stable? If you are on 6.10.0 maybe the below applies:
I'm not having the problem, don't use connman and am batting around 1000 for being wrong in 2016 - (my brain is firmly still on holidays ;) )- but this looks like it might be related to:
Quote:
2016-01-08-some-dhcpcd-hooks-are-now-examples
Title Some dhcpcd hooks are now examples
Author William Hubbs <williamh@gentoo.org>
Posted 2016-01-08
Revision 2

In dhcpcd-6.10.0, the following hooks are no longer installed in
/lib/dhcpcd/dhcpcd-hooks by default:

10-wpa_supplicant
15-timezone
29-lookup-hostname

These are now installed in /usr/share/dhcpcd/hooks, which is an example
directory.

If you were using these hooks before you upgrade to 6.10.0, you will
need to copy them back to the /lib/dhcpcd/dhcpcd-hooks directory after the
upgrade.

If you are using dhcpcd you may need to add back wpa_supplicant per the above: That's what I'd try first, anyway.
Code:
cp /usr/share/dhcpcd/hooks/10-wpa_supplicant /lib/dhcpcd/dhcpcd-hooks/



Copied those hooks into the new directory and still the same exact behavior.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 422
Location: Australia

PostPosted: Tue Jan 26, 2016 2:36 am    Post subject: Reply with quote

Sorry, I'm not really able to troubleshoot that for you further, I don't have any systems here using connman.

After copying the hooks back, I assume you restarted the dhcpcd service to pick up the changes before trying to restart connman?

If so, maybe it wasn't this issue at all. Does
Code:
# journalctl -p err -b
return anything useful?
Back to top
View user's profile Send private message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Tue Jan 26, 2016 2:55 am    Post subject: Reply with quote

ian.au wrote:
Sorry, I'm not really able to troubleshoot that for you further, I don't have any systems here using connman.

After copying the hooks back, I assume you restarted the dhcpcd service to pick up the changes before trying to restart connman?

If so, maybe it wasn't this issue at all. Does
Code:
# journalctl -p err -b
return anything useful?


Just some btrfs could not find root errors and an eviocskeycode error. Nothing helpful related to connman other than an Aborting message.
Back to top
View user's profile Send private message
dsreyes1014
n00b
n00b


Joined: 19 Oct 2015
Posts: 21

PostPosted: Thu Jan 28, 2016 6:01 am    Post subject: Reply with quote

Ok so I downgraded iptables to version iptables-1.4.21 from iptables-1.6.0 and now connman works so the problem seems to be with iptables-1.6.0 not working well with connman-1.30. I marking this as solved for now.
Back to top
View user's profile Send private message
infirit
l33t
l33t


Joined: 11 Jan 2003
Posts: 778
Location: Hoofddorp / The Netherlands

PostPosted: Sat Mar 05, 2016 4:48 pm    Post subject: Reply with quote

It needs a patch to work with recent iptables, see https://bugs.gentoo.org/show_bug.cgi?id=573174#c1
_________________
EASY TO INSTALL = Difficult to install, but instruction manual has pictures.
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum