Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Could not find the root block device in UUID=
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Tue Jan 12, 2016 4:31 pm    Post subject: Could not find the root block device in UUID= Reply with quote

Salve, sono nuovo e mi presento... sono Max e mi appassiona il mondo del linux.
Sottoporrei gentilmente un quesito alla vostra attenzione.
Ho installato Gentoo su un hard-disk estraibile contenente anche dei salvataggi provenienti da Windows.
L'iter da me seguito è questo:
- ho avviato ubuntu con live usb e partizionato l'hard disco estraibile con Gparted come ext4 (su una partizione ci sono rimasti i salvataggi di Windows e la restante da circa 59 GB l'ho lasciata x Gentoo)
- ho avviato il CD minimal di Gentoo e all'avvio ho partizionato ulteriormente la partizione ext4 con fdisk -l /dev/sdb (in quanto l'estraibile me lo sente come sdb), creando 4 partizioni primarie (sdb1 BIOS-Fat32, sdb2 BOOT-linux, sdb3 Swap-linux e sdb4 ROOT-linux) come suggerito dall'handbook-Gentoo
- ho seguito tutto passo passo per scaricare lo stage3 (e il portage) e x scompattarli (i486, essendo il mio pc un pò datato - è del 2006)
- sono entrato con chroot e ho impostato manualmente il kernel (poi compilato manualmente non utilizzando genkernell)
- ho installato Grub2
All'avvio di Grub mi rileva il Gentoo, e fin qui tutto Ok, ma quando l'avvia dopo poco appare un msg simile a questo (adesso non mi ricordo esattamente, ma è molto simile):

"Could not find the root block device in UUID=....................................
Please specify another value or: press Enter for the same, type "shell" for a shell or "q" to skip... "

e se digito q:

"mount: Can't find /newroot in /etc/fstab"

E' che non sente la partizione di root?

Premetto che ho provato a editare il grub.cfg inserendo, sulle righe relative al root, /dev/sdb4 al posto dei numeri UUID... inoltre, sempre sullo stesso file, ho cambiato da root=(hd1,4) a root=(hd1,3) - infatti hd1,3 non dovrebbe corrispondere a sdb4 (visto che sda è il c: di Windows)? O forse per Gentoo sdb è sempre hd0?
Il file fstab dovrebbe essere configurato bene:
/dev/sdb2 /boot ext2 defaults 0 2
/dev/sdb3 swap sw defaults 0 0
/dev/sdb4 / ext4 noauto 0 1

E' forse un problema di compilazione del Kernel?
In fase di compilazione c'è stato un errore:

"sys-devel/bin86-0.16.21::gentoo failed (compile phase)
emake failed"

Ringrazio tanto chi mi vorrà dare una mano.
Saluti
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42585
Location: 56N 3W

PostPosted: Tue Jan 12, 2016 7:42 pm    Post subject: Reply with quote

Maxxx

Welcome to Gentoo

Moved from Kernel & Hardware to Forum italiano (Italian).
Google Translate is not good enough for me to help.

Please post in English in the main forums.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Tue Jan 12, 2016 7:58 pm    Post subject: Reply with quote

Ok, thank you... wrong forum.
I just posted in italian session.
Tomorrow i post in english forum a translation.

bye
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Tue Jan 12, 2016 8:31 pm    Post subject: Reply with quote

Hi, I'm new... I,m Max and I are passionate about the world of Linux.
Kindly I have subjected a question to your attention.
I installed Gentoo on a removable hard drive that also contains backups from Windows.
The process I follow is this:
- I started with ubuntu live usb and partitioned the removable hard disk with Gparted as ext4 (in one partition there were backups for Windows and the remaining approximately 59 GB I left for Gentoo)
- I started the minimal CD Gentoo and at startup I partitioned further ext4 partition with fdisk -l / dev / sdb (the removable HD is sdb), creating four primary partitions (sdb1 BIOS-FAT32, sdb2 BOOT-linux, sdb3 swap/linux and sdb4 ROOT-linux) as suggested from Gentoo's handbook
- I followed everything step by step to download the stage3 (and Portage) and unpack (i486, being my PC a little dated - was published in 2006)
- I came with chroot and I manually set the kernel (then compiled manually not using genkernell)
- I installed Grub2
I detect the start of Grub Gentoo, so everything OK, but when the start after just appears a msg like this (I do not remember exactly, but it's very similar):

"Could not find the root block device in UUID = ....................................
Please specify another value or: press Enter for the same, type "shell" for a shell or "q" to skip ... "

and if I type q:

"Mount: Can not find / newroot in / etc / fstab"

It does not detect the root partition?

I state that I tried to edit the grub.cfg inputting, the rows relating to root, / dev / sdb4 instead of numbers UUID ... also, always on the same file, I changed from root = (hd1,4) to root = (hd1,3) - in fact hd1,3 should not match sdb4 (sda is the HD of Windows)? Or maybe Gentoo SDB is always hd0?
The fstab file must be configured properly:
/Dev/sdb2 /boot ext2 defaults 0 2
/Dev/sdb3 swap sw defaults 0 0
/Dev/sdb4 / ext4 noauto 0 1

And 'maybe a problem of compiling the Linux kernel?
At compile time there was an error:

"Sys-devel / bin86-0.16.21 :: gentoo failed (compile phase)
emake failed "

I thank all those who want me to help.
Greetings
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum