Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLVED]Xorg - startx problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 175
Location: Italy/Cosenza

PostPosted: Tue Jan 12, 2016 4:05 pm    Post subject: [RESOLVED]Xorg - startx problem Reply with quote

hi, I finished installing gentoo yesterday, I have a problem with xorg, I installed i3wm and created the home user .xinitrc with the line "exec i3" like arch that I dual boot. Startx me back with Xauthority errors (which I also copied from the home of arch to make an attempt to be anything, the partition of the home and the same but have different folders) by examining the log looks like a driver problem, but I have selected for the same gentoo options I selected when I compiled the kernel arch ... so I do not know why I have driver issues. Thank you in advance
This is the log:
https://arin.ga/ylCGkb
RESOLVED------
facepalm, last night it did the connection and the command that I launched was not unsuccessful , sorryyyyyy


Last edited by oscarandrea on Tue Jan 12, 2016 5:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jan 12, 2016 4:16 pm    Post subject: Reply with quote

The X server starts and terminates normally. Something might be wrong with your session file or i3 installation.

Try removing ~/.xsession for now, and setting the XSESSION variable in /etc/env.d/ then "env-update" and "source /etc/profile".
https://wiki.gentoo.org/wiki/Xorg/Guide#Using_startx
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 175
Location: Italy/Cosenza

PostPosted: Tue Jan 12, 2016 4:40 pm    Post subject: Reply with quote

OK, new user create, now 1 error for "exec i3"
echo XSESSION="13" > /etc/env.d/90xsession
does not work
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jan 12, 2016 9:54 pm    Post subject: Reply with quote

oscarandrea wrote:
XSESSION="13"
That doesn't seem correct to me.

~/.xinitrc will take precedence over XSESSION, so you need to rename or remove it before starting X.
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 175
Location: Italy/Cosenza

PostPosted: Wed Jan 13, 2016 7:19 pm    Post subject: Reply with quote

Thanks, however I had already solved :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum