Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu] libeproxy & EGL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Tue Jan 12, 2016 1:12 pm    Post subject: [Résolu] libeproxy & EGL Reply with quote

Bonjour,

J'ai voulu faire une update de mes paquets et libeproxy me pose problème...

Code:
checking for EGL... no
configure: error: Package requirements (egl) were not met:

Package egl was not found in the pkg-config search path.
Perhaps you should add the directory containing `egl.pc'
to the PKG_CONFIG_PATH environment variable
Package 'egl', required by 'world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EGL_CFLAGS
and EGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-libs/libepoxy-1.3.1/work/libepoxy-1.3.1-abi_x86_32.x86/config.log
 * ERROR: media-libs/libepoxy-1.3.1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  133:  Called src_configure
 *             environment, line 4201:  Called autotools-multilib_src_configure
 *             environment, line  731:  Called multilib-minimal_src_configure
 *             environment, line 2744:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *             environment, line 2958:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2674:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2672:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *             environment, line  542:  Called multilib-minimal_abi_src_configure
 *             environment, line 2738:  Called multilib_src_configure
 *             environment, line 3175:  Called autotools-utils_src_configure
 *             environment, line  772:  Called econf '--docdir=/usr/share/doc/libepoxy-1.3.1'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=media-libs/libepoxy-1.3.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/libepoxy-1.3.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/libepoxy-1.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libepoxy-1.3.1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/libepoxy-1.3.1/work/libepoxy-1.3.1-abi_x86_32.x86'
 * S: '/var/tmp/portage/media-libs/libepoxy-1.3.1/work/libepoxy-1.3.1'

>>> Failed to emerge media-libs/libepoxy-1.3.1, Log file:

>>>  '/var/tmp/portage/media-libs/libepoxy-1.3.1/temp/build.log'

 * Messages for package sys-apps/systemd-226-r2:

 * It's recommended to set an empty value to the following kernel config option:
 * CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
 *   CONFIG_DEVPTS_MULTIPLE_INSTANCES:    is not set when it should be.
 *   CONFIG_IDE:    should not be set. But it is.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.

 * Messages for package media-sound/pulseaudio-7.1:

 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=64

 * Messages for package media-libs/libepoxy-1.3.1:

 * ERROR: media-libs/libepoxy-1.3.1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  133:  Called src_configure
 *             environment, line 4201:  Called autotools-multilib_src_configure
 *             environment, line  731:  Called multilib-minimal_src_configure
 *             environment, line 2744:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *             environment, line 2958:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2674:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 2672:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *             environment, line  542:  Called multilib-minimal_abi_src_configure
 *             environment, line 2738:  Called multilib_src_configure
 *             environment, line 3175:  Called autotools-utils_src_configure
 *             environment, line  772:  Called econf '--docdir=/usr/share/doc/libepoxy-1.3.1'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=media-libs/libepoxy-1.3.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/libepoxy-1.3.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/libepoxy-1.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libepoxy-1.3.1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/libepoxy-1.3.1/work/libepoxy-1.3.1-abi_x86_32.x86'
 * S: '/var/tmp/portage/media-libs/libepoxy-1.3.1/work/libepoxy-1.3.1'


Je pense que le problème vient de la première ligne.
J'ai essayé de mettre egl dans make.conf mais ça ne change rien


Last edited by titusIII on Wed Jan 13, 2016 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Tue Jan 12, 2016 1:47 pm    Post subject: Reply with quote

Après avoir ajouté ton use, as-tu fais un update pour l'appliquer:
Code:
emerge -DuNav --with-bdeps=y @world
?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Tue Jan 12, 2016 2:29 pm    Post subject: Reply with quote

Oui, ça donne exactement la même erreur
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Tue Jan 12, 2016 2:43 pm    Post subject: Reply with quote

Bug connu

Tu dois ajouter le USE abi_x86_32 pour x11-proto/xproto
Code:
echo "x11-proto/xproto abi_x86_32" >> /etc/portage/package.use/multilib_deps


Puis relancer ton emerge
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Tue Jan 12, 2016 2:52 pm    Post subject: Reply with quote

Pour x11-proto/xproto ?

Ca ne change rien, toujours ce problème avec EGL
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Tue Jan 12, 2016 3:03 pm    Post subject: Reply with quote

Je n'ai pas d'autre idée à part t'abonner au bug et dire que tu as ajouté le USE et que çà n'arrange pas les choses.

Ou alors, tu masques cette version de libepoxy pour le moment, pour récupérer la version précédente, en espérant qu'elle fonctionne.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Tue Jan 12, 2016 3:08 pm    Post subject: Reply with quote

C'est masqué, la version précédente ne pose pas de soucis.

Merci !


(Il y a un bouton pour mettre en résolu quelque part?)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Tue Jan 12, 2016 8:09 pm    Post subject: Reply with quote

(change ton titre ;))
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum