Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
block: plasma needs baloo:5, dolphin:4 can't
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1187
Location: Stuttgart, Germany

PostPosted: Sun Jan 03, 2016 11:02 am    Post subject: block: plasma needs baloo:5, dolphin:4 can't Reply with quote

Happy New Year, to those of you that use that calendar.

I'm trying to remerge packages to deal with gcc's new ABI (following the gentoo news item that points to this blog).

However, as part of the rebuild, I'm running into a dumb set of package blocks, which I hope you folks can help me resolve:

Code:
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.17.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-frameworks/baloo-5.17.0:5/5.17::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/baloo-5.14.0:5 required by (kde-plasma/plasma-workspace-5.5.2-r1:5/5::gentoo, ebuild scheduled for merge)
    kde-frameworks/baloo:5/5.17
    >=kde-frameworks/baloo-5.14.0:5 required by (kde-plasma/plasma-desktop-5.5.2:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/dolphin-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    kde-base/baloo:4/4.14
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    >=kde-base/baloo-4.13.0:4[aqua=,-minimal(-)] (>=kde-base/baloo-4.13.0:4[-aqua,-minimal(-)]) required by (kde-misc/baloo-kcmadv-2014.04.27:4/4::gentoo, ebuild scheduled for merge)


However, if I mask baloo:5, it complains that plasma-desktop and plasma-workspace both need it. If I block those packages, emerge complains that they are needed, but doesn't specify the dependency.

Is there a way to find out what packages require them? 'equery d' doesn't return dependencies for packages that aren't yet installed, it seems.
Or, alternately: does dolphin:5 actually work outside of the kde wm now? Last time I tried it, it was terrible (no service menus, colors all wrong, slow, sucked). Has this improved? I'm running FVWM (because I'm hardcore), and last I heard dolphin:5 was terrible outside of its own wm.
Failing that: is there another file manager I could be using in fvwm? I want the following:
* a right-click menu with options for compressing, encrypting, moving, and shredding files (along with the reverse operation for the first two)
* uses my specified GTK theme
* lightweight
* works without systemd

I've been looking around, and everything I find for file managers is really old, and none of the alternatives I've found are really any good. Is it really that hard to have a decent lightweight file manager outside of the (apparently increasingly closed) ecosystems of the two main WMs?

Thanks for the help,

EE
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 836

PostPosted: Sun Jan 03, 2016 11:05 am    Post subject: Reply with quote

Code:
emerge -C baloo
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Jan 03, 2016 11:29 am    Post subject: Reply with quote

@Perfect Gentleman: That's no solution, packages are present that will pull both baloos back in.

Don't you use the plasma profile? OK FVWM, obviously not.

Code:
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.17.0)

USE=minimal is key here. And of course please set it permanently (for baloo:4!) in your package.use. You can only have set it temporarily when you emerged dolphin/baloo the last time.


Alternatively you could think about why you have baloo-kcmadv installed on a machine not(?) using kde-workspace-4, get rid of that, unmask dolphin:5 and get rid of baloo:4 altogether.

Quote:
Or, alternately: does dolphin:5 actually work outside of the kde wm now?

Oh, OK, I don't think that has been fixed upstream yet.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1187
Location: Stuttgart, Germany

PostPosted: Sun Jan 03, 2016 12:20 pm    Post subject: Reply with quote

Some other app (I can't remember now, but recent) in the KDE ecosystem requires baloo with '-minimal', which was the start of this whole problem.

So, in short: dolphin:5 sucks horribly outside of kde, but I apparently can no longer use dolphin:4 because it depends on baloo:4, which plasma-workspace and plasma-desktop no longer accept.

Somewhat off-topic: is this a trend in the two main WMs that still isn't being reconsidered? I mean, it seems both the KDE and GNOME devs are pushing a unified UI model, such that their apps no longer work in isolation, and depend on a monolithic installation to work. I almost got into a flamewar with a dev from the Unity project, because their WM now explicitly ignores .xmodmap and provides no alternative, on the grounds that letting users set their own keybindings "makes it impossible to present a coherent UI" (ie, it's not a bug, it's a feature). My solution to that was to ditch Unity altogether in favor of enlightenment. But now KDE is how many years into version 5, and one of their main apps -- a file manager, of all things -- still cannot function without being within its own WM, and they are pushing users into that WM more insistently (by, for example, this requirement of baloo with -minimal, which seemingly forces baloo:5). I thought the linux way rested on modularity, simplicity, robustness, and ease of customization (among other things), and the apparent insistence on a single WM ecosystem goes against that. Grrrr! /rant

Thanks for the help. Krusader seems like a nice file manager (though a two-pane file manager doesn't fulfill any but rare use cases for me).

EE
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Jan 03, 2016 12:27 pm    Post subject: Reply with quote

ExecutorElassus wrote:
Some other app (I can't remember now, but recent) in the KDE ecosystem requires baloo with '-minimal', which was the start of this whole problem.

No, can't be. ;) https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-base/baloo

I said USE=minimal is key. This flag makes baloo:4 coinstallable with baloo:5, it doesn't force anything.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 535
Location: Cape Town, South Africa

PostPosted: Sun Feb 07, 2016 9:54 pm    Post subject: Still an issue Reply with quote

hi

I use USE=minimal to get emerge to function, is there a better way around this?

Code:

ebuild   R    ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal*" 0 KiB
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.16.0)

Total: 18 packages (1 new, 17 reinstalls), Size of downloads: 330 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/kdepim-common-libs-4.14.10:4/4.14::gentoo, installed)

  (kde-frameworks/baloo-5.16.0:5/5.16::gentoo, installed) pulled in by
    >=kde-frameworks/baloo-5.15.0:5 required by (kde-apps/baloo-widgets-15.08.3:5/5::gentoo, installed)
    >=kde-frameworks/baloo-5.15.0:5 required by (kde-apps/dolphin-15.08.3:5/5::gentoo, installed)



Yes, I use KMail. Don't like Evolution.

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Feb 07, 2016 10:01 pm    Post subject: Reply with quote

That's exactly the way it is planned. ;)

Using plasma profile solves this automatically for you.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 535
Location: Cape Town, South Africa

PostPosted: Sun Feb 07, 2016 10:07 pm    Post subject: Reply with quote

genstorm wrote:
That's exactly the way it is planned. ;)

Using plasma profile solves this automatically for you.


Is it now safe (sane?) to switch to Plasma?

I was letting KDE migrate me across gradually...

What about KDEPIM ... that does not seem to be migrated yet? Or am I misunderstanding eix?

thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Feb 07, 2016 10:40 pm    Post subject: Reply with quote

You're not using Plasma-5, but installing kf5-based applications? Imo amd64 users should use KDE4 (and stay away from kf5 upgrades), ~amd64 users should migrate to Plasma-5 as they will get more and more applications upgrades that do not really work well within Plasma-4.

No, PIM hasn't made it to tree yet. It remains in kde overlay until it is deemed fit for addition to tree.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 535
Location: Cape Town, South Africa

PostPosted: Sun Feb 07, 2016 11:00 pm    Post subject: Reply with quote

genstorm wrote:
You're not using Plasma-5, but installing kf5-based applications? Imo amd64 users should use KDE4 (and stay away from kf5 upgrades), ~amd64 users should migrate to Plasma-5 as they will get more and more applications upgrades that do not really work well within Plasma-4.

No, PIM hasn't made it to tree yet. It remains in kde overlay until it is deemed fit for addition to tree.


Not sure how to answer that ... :-) You know how it goes... build a new box, determined to run STABLE, then portage wants this ~AMD64, then that, then I decide to make KDE ~AMD64 because some things were broken and the bleeding edge fixed them ... so in truth I am a bit confused, and tend to let Portage handle what's happening.

However that Baloo thing has been broken for a few weeks, so I was wondering if there was a way around it, but I guess I will have to continue using USE=minimal and wait for KDE PIM to get with the program, and then it will hopefully resolve itself automagically as per normal... :-)

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Feb 07, 2016 11:04 pm    Post subject: Reply with quote

Well, USE=minimal (in package.use - NOT globally!) IS the solution, or do you still see a block? :D


iandoug wrote:
Not sure how to answer that ... :-) You know how it goes... build a new box, determined to run STABLE, then portage wants this ~AMD64, then that, then I decide to make KDE ~AMD64 because some things were broken and the bleeding edge fixed them ... so in truth I am a bit confused, and tend to let Portage handle what's happening.

Portage only wants this or that ~amd64 because you asked for it in the first place. ;) That's why you never enter packages without version atom into package.keywords - it goes out of control. Instead, always use something like `=kde-apps/kwrite-4.14*` or `kde-apps/kwrite:4`, just as an example.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 226

PostPosted: Mon Feb 08, 2016 8:57 pm    Post subject: Reply with quote

Quote:
then I decide to make KDE ~AMD64 because some things were broken


When it comes to plasma5 I would also agree that it makes only sense currently with kde/qt both on ~amd64. Otherwise be prepared to wait another 5-10 years. 8-P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum