Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma 5: ConsoleKit suspend to ram segfauts [No Solution]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Sat Jan 02, 2016 6:11 pm    Post subject: Plasma 5: ConsoleKit suspend to ram segfauts [No Solution] Reply with quote

The issue: Clicking the suspend to ram button under the kde power menu item works the first time, but fails every subsequent time due to segfault in consolekit. Works fine if the system automatically suspends to ram due to expired timer. LolWut O_o

For stack traces and more detailed information, please see https://bugs.gentoo.org/show_bug.cgi?id=563030.

After consolekit crashes, ck-list-sessions returns nothing, but terminates normally.

A little background: I have always started X11 and KDE from the command-line via startx after a console login. I have stuck to this method because KDE and to some extent the X11 video layer are prone to bugs and breakage that will at some point prevent the graphical env from starting. I usually use /etc/env.d/90xsession with XSESSION="KDE-4" to startkde, however, after upgrading to Plasma 5, I found that this method was not supported nor documented.

The following are things that I have tired to resolve this problem:

Created a /etc/X11/Sessions/PLASMA-5 and set XSESSION="PLASMA-5":
Code:
#!/bin/sh
exec "/usr/bin/startkde"


Tried ck-launch-session dbus-launch --sh-syntax --exit-with-session "/usr/bin/startkde" in my ~/.xinitrc which produces the same segfault.
Code:
~ $ ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2016-01-02T19:21:48.167004Z'
        login-session-id = '5'
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2016-01-02T19:23:46.894819Z'
        login-session-id = '5'


Tried exec ck-launch-session dbus-launch --sh-syntax --exit-with-session "/usr/bin/startkde" in my ~/.xinitrc which produces the same segfault. This approach produces the problem I outlined above. ck-list-sessions also produces the wrong number of sessions, 2.
Code:
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2016-01-02T19:16:58.519195Z'
        login-session-id = '4'
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2016-01-02T19:16:59.932738Z'
        login-session-id = '4'



I have also tried a number of graphical login environments like sddm. They produce the same result as outlined above.

I also tired exec dbus-launch --exit-with-session startkde which produces what I believe is the correct ck-list-sessions output, however, when I check the power menu, suspend is no longer an option. Only lock and logout.
Code:

~ $ ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2016-01-02T01:35:20.870778Z'
        login-session-id = '2'


Please excuse the no solution tag, I have been trying to receive support for for these issues for over a month now and I have been met with heavy resistance.
Back to top
View user's profile Send private message
whgentoo
n00b
n00b


Joined: 28 Dec 2015
Posts: 5

PostPosted: Sat Jan 02, 2016 11:06 pm    Post subject: Reply with quote

Have you tried turning off "Lock screen on resume" as a workaround?
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Sat Jan 02, 2016 11:11 pm    Post subject: Reply with quote

No, however I just rebuilt a few things and its temp working at the moment. I basically did the GCC5.3 rebuild + consolekit + some missing kde wallet packages. Either the rebuild fixed it which I find unlikely for a number of reasons like the problem has gone on longer than GCC5.3 has been around. I am leaning more towards an issue with kde wallet missing. Last time this happened the problem came back so I want to test this for a few days. I am still also seeing the double session issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum