Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Wireless not working after suspend
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Fri Jan 01, 2016 2:32 pm    Post subject: [SOLVED] Wireless not working after suspend Reply with quote

I've solved my connection problems doing different steps so I am not sure what exactly fixed it.

Here is the summary of my problems from my OP:
Problem: long time to detect wireless on startup

Solution: used original kernel .config file from LiveDVD and re-compiled kernel. Had to add extras to it like battery, power, suspend, hibernate, and make it preemptive. Now when DE starts up from reboot wireless is picked up right away.

Problem: wireless doesn't connect after resume from suspend when lid is opened.
Solution: not sure what fixed it. I tried different ways:

1) unmerge NetworkManager. emerge networkmanager with USE="-consolekit"
2) unmerge consolekit. emerge consolekit with USE="-networkmanager"
3) stop iptables before going to suspend

I did these 3 things but don't know which one of them fixed the issue. All I know I don't have to logout/login after suspend to get my wirelss working 8)

UPDATE: it wasn't iptables
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum