Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help installing plasma
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 12:35 am    Post subject: Help installing plasma Reply with quote

Hi

I have just finished installing a fresh Gentoo install. I have set the profile to /desktop/plasma

I have ran the emerge world command and it done 3 hours of installing but when I run emerge plasma-meta I get USE errors.

Do I need to install kde 4 before I can install plasma?

Thanks for any help.

Happy new year.
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 4:08 am    Post subject: Re: Help installing plasma Reply with quote

RoboGrinch wrote:
Hi

I have just finished installing a fresh Gentoo install. I have set the profile to /desktop/plasma
I have ran the emerge world command and it done 3 hours of installing but when I run emerge plasma-meta I get USE errors.

Please post the errors.

Quote:
Do I need to install kde 4 before I can install plasma?

No, KDE4 and KDE5 (plasma, frameworks and kde-apps) are separate.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 8:49 am    Post subject: Reply with quote

Code:
emerege --ask kde-plasma/plasma-meta


*lots of code scrolls**

Code:
The following USE changes are necessary to proceed:
(see "package.use" in portage(5) man page for more details)
# required by x11-drivers/xf86-video-vmware-13.1.0::gentoo
# required by x11-base/xorg/drivers-1.17::gentoo[video_cards_vmware]
# required by x11-base/sorg-server-1.17.4::gentoo[xorg]
# required by x11-drivers/xf86-video-tdfx-video-tdfx-1.4.6::gentoo
>=media-libs/mesa-11.0.6 xa


Then it goes back to prompt.

http://postimg.org/image/daqdgfswx/ <----- image of screen
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 11:56 am    Post subject: Reply with quote

Really, everything you need to know is in that last code segment you posted. It's not an error, it's a very informative message (solution included) complete with a link where to get help. As you can see, it is not even plasma related, rather about xorg-server/mesa with vmware configuration.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 12:08 pm    Post subject: Reply with quote

RoboGrinch wrote:
Code:
emerege --ask kde-plasma/plasma-meta


*lots of code scrolls**

Code:
The following USE changes are necessary to proceed:
(see "package.use" in portage(5) man page for more details)
# required by x11-drivers/xf86-video-vmware-13.1.0::gentoo
# required by x11-base/xorg/drivers-1.17::gentoo[video_cards_vmware]
# required by x11-base/sorg-server-1.17.4::gentoo[xorg]
# required by x11-drivers/xf86-video-tdfx-video-tdfx-1.4.6::gentoo
>=media-libs/mesa-11.0.6 xa


Then it goes back to prompt.

http://postimg.org/image/daqdgfswx/ <----- image of screen


In looking at your photo and what you have posted....the short answer.....enter yes and update the config files. I use dispatch-conf to update my package.use, etc...
All I see are additional packages that are needed to move forward with the KDE meta package installation.


Last edited by davidbrooke on Fri Jan 01, 2016 12:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 12:17 pm    Post subject: Reply with quote

It actually seems like it might be this:

Code:
[blocks B      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking plasma
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 12:18 pm    Post subject: Reply with quote

Actually looking twice at it, do you really need vmware and tdfx enabled? Could it be that you haven't set VIDEO_CARDS in your make.conf?

You're also trying to emerge plasma-5 on a stable system. This will require _a_lot_ of package.keywords and package.unmask wrangling.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 12:20 pm    Post subject: Reply with quote

RoboGrinch wrote:
It actually seems like it might be this:

Code:
[blocks B      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking plasma

Please post all the info about a block. Gentoo usually gives more than you have posted.
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 12:25 pm    Post subject: Reply with quote

Also if you need help in posting the info..use the following package to automatically post:
wgetpaste
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 12:26 pm    Post subject: Reply with quote

Hint: You can use app-text/wgetpaste to share portage's output instead of taking pictures of your screen.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 12:59 pm    Post subject: Reply with quote

Thanks for the help guys...

Here is the total output....

Code:

Gentop ~ # emerge --ask kde-plasma/plasma-meta

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 20 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libyaml-0.1.6  USE="-doc -examples -static-libs {-test}"
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] dev-db/lmdb-0.9.14  USE="-static-libs"
[ebuild  N     ] sys-libs/libunwind-1.1  USE="-debug -debug-frame -libatomic -lzma -static-libs"
[ebuild  N     ] sys-apps/tcp-wrappers-7.6.22-r1  USE="ipv6 -netgroups -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-base/xorg-drivers-1.17  INPUT_DEVICES="-acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -keyboard (-libinput) -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ] net-wireless/wireless-regdb-20151022
[ebuild  N     ] sys-libs/mtdev-1.1.5  USE="-static-libs"
[ebuild  N     ] dev-util/google-perftools-2.0-r2  USE="debug -largepages -minimal -static-libs {-test}"
[ebuild  N     ] virtual/perl-MIME-Base64-3.140.0-r1
[ebuild  N     ] dev-perl/URI-1.600.0-r1
[ebuild  N     ] app-arch/snappy-1.1.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax"
[ebuild  N     ] dev-libs/leveldb-1.18-r1  USE="snappy tcmalloc -static-libs"
[ebuild  N     ] x11-libs/libxkbfile-1.0.9  USE="-static-libs"
[ebuild  N     ] x11-misc/xbitmaps-1.1.1
[ebuild  N     ] x11-proto/resourceproto-1.2.0
[ebuild  N     ] x11-proto/fontsproto-2.1.3  USE="-doc"
[ebuild  N     ] x11-proto/bigreqsproto-1.1.2  USE="-doc"
[ebuild  N     ] x11-proto/xcmiscproto-1.2.2  USE="-doc"
[ebuild  N     ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild  N     ] x11-libs/libpciaccess-0.13.4  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/trapproto-3.4.3
[ebuild  N     ] x11-proto/xf86dgaproto-2.1-r2  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libqmi-1.12.6  USE="-doc -static-libs"
[ebuild  N     ] x11-apps/xkbcomp-1.3.0
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] x11-libs/libXfont-1.5.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild  N     ] net-misc/dhcp-4.3.1-r2  USE="client ipv6 ldap server ssl (-selinux) -vim-syntax"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="ipv6 pam -activefilter -atm -dhcp -eap-tls -gtk -radius"
[ebuild  N     ] net-dialup/rp-pppoe-3.11-r3  USE="-tk"
[ebuild  N     ] net-misc/socat-1.7.3.0  USE="ipv6 readline ssl tcpd"
[ebuild     U ~] dev-qt/qtcore-5.5.1 [5.4.2]
[ebuild  N     ] dev-lang/swig-3.0.5  USE="pcre -ccache -doc"
[ebuild  N     ] dev-libs/nss-3.20.1  USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/slang-2.2.4-r1  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  NS    ] dev-qt/qtscript-5.4.2-r1 [4.8.6-r2] USE="jit -debug -scripttools {-test}"
[ebuild  N    ~] dev-qt/qtpaths-5.5.1  USE="-debug {-test}"
[ebuild  N     ] dev-util/boost-build-1.56.0  USE="python -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-fonts/noto-2015.04  USE="X"
[ebuild  N     ] dev-libs/libnl-3.2.27  USE="python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-libs/libevdev-1.4.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/boost-1.56.0-r1  USE="icu nls python threads -context -debug -doc -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] app-eselect/eselect-ruby-20131227
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-python/pygments-2.0.2-r2  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] net-libs/libndp-1.5  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-python/m2crypto-0.22.3-r4  PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-misc/xkeyboard-config-2.16
[ebuild  N     ] dev-python/docutils-0.12  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] net-wireless/crda-1.1.3-r1
[ebuild  N     ] x11-apps/setxkbmap-1.3.1
[ebuild  NS    ] dev-qt/qtsql-5.4.2 [4.8.6-r1] USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}"
[ebuild  N     ] dev-lang/ruby-2.1.7  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs"
[ebuild  N     ] dev-lang/ruby-2.0.0_p647-r1  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2"
[ebuild  N     ] dev-ruby/rubygems-2.2.5-r1  USE="-server {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] virtual/rubygems-10  RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rake-0.9.6-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/json-1.8.2-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/racc-1.4.11  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rdoc-4.2.0  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby22)"
[ebuild  N     ] dev-libs/libinput-1.1.0  USE="{-test}"
[ebuild  N     ] x11-apps/xrdb-1.1.0
[ebuild  N     ] x11-apps/xsetroot-1.1.1
[ebuild  N     ] net-wireless/wpa_supplicant-2.4-r3  USE="dbus hs2-0 readline ssl -ap -eap-sim -fasteap -gnutls -p2p (-ps3) -qt4 (-selinux) -smartcard -tdls -uncommon-eap-types -wimax -wps"
[ebuild  N     ] media-gfx/fontforge-20150612-r1  USE="X cairo gif jpeg png python readline svg tiff unicode -gtk -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-qt/qdbus-5.4.2  USE="-debug {-test}"
[ebuild  N     ] x11-apps/xmessage-1.0.4
[ebuild  N     ] x11-apps/xinit-1.3.4-r1  USE="minimal -systemd"
[ebuild  N    ~] kde-frameworks/kf-env-3
[ebuild  N     ] x11-base/xorg-server-1.17.4  USE="glamor ipv6 nptl suid udev xorg -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb"
[ebuild  NS    ] dev-qt/qtsvg-5.4.2 [4.8.6-r1] USE="-debug {-test}"
[ebuild  NS    ] dev-qt/qtopengl-5.4.2 [4.8.6-r1] USE="-debug -gles2 {-test}"
[ebuild  N     ] x11-drivers/xf86-input-evdev-2.9.2
[ebuild  N    ~] kde-frameworks/extra-cmake-modules-5.17.0  USE="-doc {-test}"
[ebuild  N     ] dev-qt/linguist-tools-5.4.2  USE="qml -debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.4.2  USE="widgets -debug {-test}"
[ebuild  N    ~] kde-plasma/kwallet-pam-5.5.1  USE="-debug"
[ebuild  N     ] dev-qt/qtquick1-5.4.2  USE="opengl xml -debug -designer {-test} -webkit"
[ebuild  N     ] net-libs/libssh-0.6.5  USE="sftp zlib -debug -doc -examples -gcrypt -gssapi -pcap -server -ssh1 -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  NS    ] dev-qt/qtwebkit-5.4.2 [4.8.6-r1] USE="opengl qml udev -debug -gstreamer -gstreamer010 -multimedia -printsupport {-test} -webp"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.4.2  USE="-debug {-test}"
[ebuild  N     ] dev-libs/libical-1.0.1  USE="-doc -examples -introspection -static-libs"
[ebuild  N    ~] kde-frameworks/kcoreaddons-5.17.0  USE="nls -debug -doc (-fam) {-test}"
[ebuild  N    ~] kde-frameworks/ki18n-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfig-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwidgetsaddons-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwindowsystem-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdbusaddons-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kitemviews-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcodecs-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kguiaddons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/karchive-5.17.0  USE="bzip2 lzma -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/sonnet-5.17.0  USE="hunspell nls -aspell -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kidletime-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-plasma/libkscreen-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-plasma/kdecoration-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/kitemmodels-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/attica-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-wallpapers-5.5.1
[ebuild  N    ~] kde-frameworks/breeze-icons-5.17.0  USE="{-test}"
[ebuild  N    ~] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N    ~] kde-frameworks/kdnssd-5.17.0  USE="nls -debug -doc {-test} -zeroconf"
[ebuild  N    ~] kde-frameworks/threadweaver-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/bluez-qt-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcrash-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdoctools-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcompletion-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjobwidgets-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpty-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kunitconversion-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-integration-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kfilemetadata-5.17.0  USE="exif pdf -debug -doc -epub -ffmpeg -libav -taglib {-test}"
[ebuild  N    ~] kde-frameworks/kservice-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kglobalaccel-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpackage-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjs-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesignerplugin-5.17.0  USE="nls -debug -designer -doc -webkit"
[ebuild  N    ~] kde-frameworks/kemoticons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesu-5.17.0  USE="X -debug -doc"
[ebuild  N    ~] kde-frameworks/kpeople-5.17.0  USE="-debug -doc {-test}"
[ebuild  N     ] net-wireless/bluez-5.35  USE="cups obex readline udev -debug (-selinux) -systemd {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/kjsembed-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifications-5.17.0  USE="X dbus nls -debug -doc (-speech)"
[ebuild  N    ~] kde-plasma/kwrited-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kauth-5.17.0  USE="nls (policykit) -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfigwidgets-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kiconthemes-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/polkit-kde-agent-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/ktextwidgets-5.17.0  USE="-debug -doc (-speech) {-test}"
[ebuild  N    ~] kde-frameworks/kwallet-5.17.0  USE="-debug -doc -gpg {-test}"
[ebuild  N    ~] kde-frameworks/kxmlgui-5.17.0  USE="-attica -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/ksshaskpass-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kbookmarks-5.17.0  USE="nls -debug -doc {-test}"
[ebuild     U ~] sys-auth/consolekit-1.0.0-r1 [0.4.6] USE="-cgroups%"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] net-misc/modemmanager-1.4.12  USE="introspection (policykit) qmi -mbim -qmi-newest -vala"
[ebuild  N    ~] kde-frameworks/solid-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] x11-misc/sddm-0.13.0-r1  USE="consolekit pam -systemd"
[ebuild  N     ] sys-apps/accountsservice-0.6.40  USE="introspection -doc (-selinux) -systemd"
[ebuild  N    ~] kde-frameworks/kio-5.17.0  USE="X acl handbook kwallet -debug -doc -kerberos {-test}"
[ebuild  N    ~] kde-frameworks/kinit-5.17.0  USE="caps man -debug -doc"
[ebuild  N    ~] kde-frameworks/kded-5.17.0  USE="man -debug -doc"
[ebuild  N    ~] kde-frameworks/kdeclarative-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/kparts-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/knewstuff-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifyconfig-5.17.0  USE="phonon -debug -doc"
[ebuild  N    ~] kde-frameworks/frameworkintegration-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/baloo-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kxmlrpcclient-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdelibs4support-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcmutils-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/khtml-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/ktexteditor-5.17.0  USE="-debug -doc -git {-test}"
[ebuild  N    ~] kde-frameworks/kross-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kde-cli-tools-5.5.1  USE="X handbook -debug {-test}"
[ebuild  N    ~] kde-frameworks/kactivities-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/oxygen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kgamma-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/user-manager-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/systemsettings-5.5.1  USE="handbook -debug -gtk"
[ebuild  N    ~] kde-apps/kio-extras-15.08.3  USE="exif handbook phonon sftp -debug -mtp -samba -slp {-test}"
[ebuild  N    ~] kde-frameworks/plasma-5.17.0-r2  USE="X -debug -doc -egl -gles2 {-test}"
[ebuild  N    ~] kde-plasma/kscreen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/sddm-kcm-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/krunner-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kscreenlocker-5.5.1  USE="pam -debug {-test}"
[ebuild  N    ~] kde-plasma/libksysguard-5.5.1  USE="X detailedmemory -debug {-test}"
[ebuild  N    ~] kde-plasma/breeze-5.5.1  USE="-debug -qt4"
[ebuild  N    ~] kde-plasma/bluedevil-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kinfocenter-5.5.1  USE="X handbook opengl pci -debug -egl -gles -ieee1394 -nfs -samba -wayland"
[ebuild  N    ~] kde-plasma/kwin-5.5.1  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N    ~] kde-plasma/milou-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/ksysguard-5.5.1  USE="handbook -debug -lm_sensors"
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="kde python -gnome -mono -networkmanager -perl -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] net-libs/glib-networking-2.44.0  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.50.0  USE="introspection ssl -debug -samba {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-misc/networkmanager-1.0.6-r1  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/networkmanager-qt-5.17.0  USE="-debug -doc -teamd {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-5.5.1.1  USE="dbus geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[ebuild  N    ~] kde-plasma/khotkeys-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/plasma-desktop-5.5.1  USE="evdev fontconfig handbook -debug -gtk2 -gtk3 -legacy-systray -pulseaudio -qt4 {-test} -touchpad"
[ebuild  N    ~] kde-plasma/powerdevil-5.5.1  USE="handbook -debug -systemd"
[ebuild  N    ~] kde-plasma/kmenuedit-5.5.1  USE="handbook hotkeys -debug"
[ebuild  N    ~] kde-plasma/kdeplasma-addons-5.5.1  USE="-debug -ibus -scim"
[ebuild  N    ~] kde-plasma/khelpcenter-5.5.1  USE="handbook -debug"
[uninstall     ] kde-base/khelpcenter-4.14.3
[blocks b      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking kde-plasma/khelpcenter-5.5.1)
[ebuild  N    ~] kde-plasma/plasma-meta-5.5.1  USE="bluetooth display-manager sddm wallpapers -gtk -mediacenter -networkmanager -pulseaudio -sdk"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qttest-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    (and 10 more with the same problem)

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtpaths-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knewstuff-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdeclarative-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kguiaddons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwindowsystem-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm,display-manager]
# required by kde-plasma/plasma-meta (argument)
=x11-misc/sddm-0.13.0-r1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfigwidgets-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksshaskpass-5.5.1 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/extra-cmake-modules-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktexteditor-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcmutils-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemmodels-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kgamma-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/user-manager-5.5.1 ~amd64
# required by kde-plasma/kwrited-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpty-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/milou-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesu-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kunitconversion-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-5.5.1.1 ~amd64
# required by kde-plasma/ksysguard-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdbusaddons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ktextwidgets-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kinfocenter-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwrited-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kidletime-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifications-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/breeze-icons-5.17.0 ~amd64
# required by kde-plasma/milou-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/krunner-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwallet-pam-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/knotifyconfig-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/ksysguard-5.5.1 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kactivities-5.17.0 ~amd64
# required by kde-plasma/milou-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kconfig-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/ki18n-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-apps/kio-extras-15.08.3 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kbookmarks-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreen-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/attica-5.17.0 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kinit-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/bluedevil-5.5.1 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[wallpapers]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-workspace-wallpapers-5.5.1 ~amd64
# required by kde-frameworks/kiconthemes-5.17.0::gentoo
# required by kde-frameworks/kio-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kf-env-3 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjobwidgets-5.17.0 ~amd64
# required by kde-plasma/bluedevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kio-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpeople-5.17.0 ~amd64
# required by kde-apps/kio-extras-15.08.3::gentoo
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdnssd-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo[handbook]
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdoctools-5.17.0 ~amd64
# required by x11-misc/sddm-0.13.0-r1::gentoo[consolekit]
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm,display-manager]
# required by kde-plasma/plasma-meta (argument)
=sys-auth/consolekit-1.0.0-r1 ~amd64
# required by kde-frameworks/kdelibs4support-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdesignerplugin-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khelpcenter-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwin-5.5.1 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kross-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kscreenlocker-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/solid-5.17.0 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwidgetsaddons-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjs-5.17.0 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/karchive-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/powerdevil-5.5.1 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kservice-5.17.0 ~amd64
# required by kde-plasma/ksshaskpass-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kwallet-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtpaths-5.5.1 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcrash-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo[sddm]
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/sddm-kcm-5.5.1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcodecs-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/systemsettings-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kitemviews-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kmenuedit-5.5.1 ~amd64
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-meta-5.5.1 ~amd64
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcoreaddons-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlrpcclient-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-integration-5.5.1 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kde-cli-tools-5.5.1 ~amd64
# required by kde-frameworks/krunner-5.17.0::gentoo
# required by kde-plasma/kdeplasma-addons-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/threadweaver-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kglobalaccel-5.17.0 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kiconthemes-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/sonnet-5.17.0 ~amd64
# required by kde-plasma/bluedevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo[bluetooth]
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/bluez-qt-5.17.0 ~amd64
# required by kde-plasma/ksysguard-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libksysguard-5.5.1 ~amd64
# required by kde-plasma/kmenuedit-5.5.1::gentoo[hotkeys]
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/khotkeys-5.5.1 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kdelibs4support-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/breeze-5.5.1 ~amd64
# required by kde-plasma/systemsettings-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=dev-qt/qtcore-5.5.1 ~amd64
# required by kde-plasma/systemsettings-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/khtml-5.17.0 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdecoration-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/plasma-5.17.0-r2 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kded-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/polkit-kde-agent-5.5.1 ~amd64
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/frameworkintegration-5.17.0 ~amd64
# required by kde-plasma/powerdevil-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kwayland-5.5.1 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/baloo-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kxmlgui-5.17.0 ~amd64
# required by kde-frameworks/baloo-5.17.0::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kfilemetadata-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/kdeplasma-addons-5.5.1 ~amd64
# required by kde-plasma/kwin-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kpackage-5.17.0 ~amd64
# required by kde-plasma/kscreen-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/libkscreen-5.5.1 ~amd64
# required by kde-plasma/khelpcenter-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kparts-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kemoticons-5.17.0 ~amd64
# required by kde-plasma/khotkeys-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kcompletion-5.17.0 ~amd64
# required by kde-frameworks/frameworkintegration-5.17.0::gentoo
# required by kde-plasma/breeze-5.5.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/oxygen-fonts-5.4.3 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kjsembed-5.17.0 ~amd64
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/kauth-5.17.0 ~amd64
# required by kde-plasma/plasma-workspace-5.5.1.1::gentoo[geolocation]
# required by kde-plasma/plasma-desktop-5.5.1::gentoo
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-frameworks/networkmanager-qt-5.17.0 ~amd64
# required by kde-plasma/plasma-meta-5.5.1::gentoo
# required by kde-plasma/plasma-meta (argument)
=kde-plasma/plasma-desktop-5.5.1 ~amd64

Would you like to add these changes to your config files? [Yes/No] y

Autounmask changes successfully written.

 * IMPORTANT: 21 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 1:03 pm    Post subject: Reply with quote

Code:
Autounmask changes successfully written.

 * IMPORTANT: 21 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

So you chose [yes] on that dialog, now you need to actually apply those changes. Use e.g. etc-update to do that.

Again, your choice of stable system + plasma-5 is causing this.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 1:10 pm    Post subject: Reply with quote

Hi thanks for the help, what do you mean by this?

genstorm wrote:
Again, your choice of stable system + plasma-5 is causing this.


Really appreciate this help.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 1:17 pm    Post subject: Reply with quote

I now get this:

Code:
Gentop ~ # emerge --ask kde-plasma/plasma-meta

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libyaml-0.1.6  USE="-doc -examples -static-libs {-test}"
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] x11-base/xorg-drivers-1.17  INPUT_DEVICES="-acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -keyboard (-libinput) -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ] sys-libs/libunwind-1.1  USE="-debug -debug-frame -libatomic -lzma -static-libs"
[ebuild  N     ] dev-db/lmdb-0.9.14  USE="-static-libs"
[ebuild  N     ] sys-apps/tcp-wrappers-7.6.22-r1  USE="ipv6 -netgroups -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-wireless/wireless-regdb-20151022
[ebuild  N     ] sys-libs/mtdev-1.1.5  USE="-static-libs"
[ebuild  N     ] dev-util/google-perftools-2.0-r2  USE="debug -largepages -minimal -static-libs {-test}"
[ebuild  N     ] virtual/perl-MIME-Base64-3.140.0-r1
[ebuild  N     ] dev-perl/URI-1.600.0-r1
[ebuild  N     ] app-arch/snappy-1.1.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax"
[ebuild  N     ] dev-libs/leveldb-1.18-r1  USE="snappy tcmalloc -static-libs"
[ebuild  N     ] x11-libs/libxkbfile-1.0.9  USE="-static-libs"
[ebuild  N     ] x11-proto/resourceproto-1.2.0
[ebuild  N     ] x11-misc/xbitmaps-1.1.1
[ebuild  N     ] x11-proto/fontsproto-2.1.3  USE="-doc"
[ebuild  N     ] x11-libs/libpciaccess-0.13.4  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/xf86dgaproto-2.1-r2  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/xcmiscproto-1.2.2  USE="-doc"
[ebuild  N     ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild  N     ] x11-proto/bigreqsproto-1.1.2  USE="-doc"
[ebuild  N     ] x11-proto/trapproto-3.4.3
[ebuild  N     ] net-libs/libqmi-1.12.6  USE="-doc -static-libs"
[ebuild  N     ] x11-apps/xkbcomp-1.3.0
[ebuild  N     ] x11-libs/libXfont-1.5.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] net-misc/dhcp-4.3.1-r2  USE="client ipv6 ldap server ssl (-selinux) -vim-syntax"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="ipv6 pam -activefilter -atm -dhcp -eap-tls -gtk -radius"
[ebuild  N     ] net-dialup/rp-pppoe-3.11-r3  USE="-tk"
[ebuild  N     ] net-misc/socat-1.7.3.0  USE="ipv6 readline ssl tcpd"
[ebuild     U ~] dev-qt/qtcore-5.5.1 [5.4.2]
[ebuild  N     ] dev-lang/swig-3.0.5  USE="pcre -ccache -doc"
[ebuild  N     ] dev-libs/nss-3.20.1  USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/slang-2.2.4-r1  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  NS    ] dev-qt/qtscript-5.4.2-r1 [4.8.6-r2] USE="jit -debug -scripttools {-test}"
[ebuild  N    ~] dev-qt/qtpaths-5.5.1  USE="-debug {-test}"
[ebuild  N     ] dev-util/boost-build-1.56.0  USE="python -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-fonts/noto-2015.04  USE="X"
[ebuild  N     ] dev-libs/libnl-3.2.27  USE="python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-libs/libevdev-1.4.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/boost-1.56.0-r1  USE="icu nls python threads -context -debug -doc -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] app-eselect/eselect-ruby-20131227
[ebuild  N     ] dev-python/pygments-2.0.2-r2  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] net-libs/libndp-1.5  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-python/m2crypto-0.22.3-r4  PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-misc/xkeyboard-config-2.16
[ebuild  N     ] dev-python/docutils-0.12  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] net-wireless/crda-1.1.3-r1
[ebuild  N     ] x11-apps/setxkbmap-1.3.1
[ebuild  NS    ] dev-qt/qtsql-5.4.2 [4.8.6-r1] USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}"
[ebuild  N     ] dev-lang/ruby-2.1.7  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs"
[ebuild  N     ] dev-lang/ruby-2.0.0_p647-r1  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2"
[ebuild  N     ] dev-ruby/rubygems-2.2.5-r1  USE="-server {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] virtual/rubygems-10  RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rake-0.9.6-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/json-1.8.2-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/racc-1.4.11  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rdoc-4.2.0  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby22)"
[ebuild  N     ] dev-libs/libinput-1.1.0  USE="{-test}"
[ebuild  N     ] x11-apps/xrdb-1.1.0
[ebuild  N     ] x11-apps/xsetroot-1.1.1
[ebuild  N     ] net-wireless/wpa_supplicant-2.4-r3  USE="dbus hs2-0 readline ssl -ap -eap-sim -fasteap -gnutls -p2p (-ps3) -qt4 (-selinux) -smartcard -tdls -uncommon-eap-types -wimax -wps"
[ebuild  N     ] media-gfx/fontforge-20150612-r1  USE="X cairo gif jpeg png python readline svg tiff unicode -gtk -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] x11-apps/xinit-1.3.4-r1  USE="minimal -systemd"
[ebuild  N     ] dev-qt/qdbus-5.4.2  USE="-debug {-test}"
[ebuild  N     ] x11-apps/xmessage-1.0.4
[ebuild  N    ~] kde-frameworks/kf-env-3
[ebuild  N     ] x11-base/xorg-server-1.17.4  USE="glamor ipv6 nptl suid udev xorg -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb"
[ebuild  NS    ] dev-qt/qtsvg-5.4.2 [4.8.6-r1] USE="-debug {-test}"
[ebuild  NS    ] dev-qt/qtopengl-5.4.2 [4.8.6-r1] USE="-debug -gles2 {-test}"
[ebuild  N     ] x11-drivers/xf86-input-evdev-2.9.2
[ebuild  N    ~] kde-frameworks/extra-cmake-modules-5.17.0  USE="-doc {-test}"
[ebuild  N     ] dev-qt/linguist-tools-5.4.2  USE="qml -debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.4.2  USE="widgets -debug {-test}"
[ebuild  N    ~] kde-plasma/kwallet-pam-5.5.1  USE="-debug"
[ebuild  N     ] dev-qt/qtquick1-5.4.2  USE="opengl xml -debug -designer {-test} -webkit"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.4.2  USE="-debug {-test}"
[ebuild  NS    ] dev-qt/qtwebkit-5.4.2 [4.8.6-r1] USE="opengl qml udev -debug -gstreamer -gstreamer010 -multimedia -printsupport {-test} -webp"
[ebuild  N     ] net-libs/libssh-0.6.5  USE="sftp zlib -debug -doc -examples -gcrypt -gssapi -pcap -server -ssh1 -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libical-1.0.1  USE="-doc -examples -introspection -static-libs"
[ebuild  N    ~] kde-frameworks/kcoreaddons-5.17.0  USE="nls -debug -doc (-fam) {-test}"
[ebuild  N    ~] kde-frameworks/ki18n-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfig-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwidgetsaddons-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwindowsystem-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdbusaddons-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kitemviews-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcodecs-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kguiaddons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/karchive-5.17.0  USE="bzip2 lzma -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/sonnet-5.17.0  USE="hunspell nls -aspell -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kidletime-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-plasma/libkscreen-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-plasma/kdecoration-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/attica-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kitemmodels-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-wallpapers-5.5.1
[ebuild  N    ~] kde-frameworks/bluez-qt-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N    ~] kde-frameworks/threadweaver-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/breeze-icons-5.17.0  USE="{-test}"
[ebuild  N    ~] kde-frameworks/kdnssd-5.17.0  USE="nls -debug -doc {-test} -zeroconf"
[ebuild  N    ~] kde-frameworks/kcrash-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdoctools-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcompletion-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjobwidgets-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpty-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kunitconversion-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-integration-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kfilemetadata-5.17.0  USE="exif pdf -debug -doc -epub -ffmpeg -libav -taglib {-test}"
[ebuild  N    ~] kde-frameworks/kservice-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kglobalaccel-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpackage-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjs-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesignerplugin-5.17.0  USE="nls -debug -designer -doc -webkit"
[ebuild  N    ~] kde-frameworks/kemoticons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesu-5.17.0  USE="X -debug -doc"
[ebuild  N    ~] kde-frameworks/kpeople-5.17.0  USE="-debug -doc {-test}"
[ebuild  N     ] net-wireless/bluez-5.35  USE="cups obex readline udev -debug (-selinux) -systemd {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/kjsembed-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifications-5.17.0  USE="X dbus nls -debug -doc (-speech)"
[ebuild  N    ~] kde-plasma/kwrited-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kauth-5.17.0  USE="nls (policykit) -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfigwidgets-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kiconthemes-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/polkit-kde-agent-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/ktextwidgets-5.17.0  USE="-debug -doc (-speech) {-test}"
[ebuild  N    ~] kde-frameworks/kwallet-5.17.0  USE="-debug -doc -gpg {-test}"
[ebuild  N    ~] kde-frameworks/kxmlgui-5.17.0  USE="-attica -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/ksshaskpass-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kbookmarks-5.17.0  USE="nls -debug -doc {-test}"
[ebuild     U ~] sys-auth/consolekit-1.0.0-r1 [0.4.6] USE="-cgroups%"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] net-misc/modemmanager-1.4.12  USE="introspection (policykit) qmi -mbim -qmi-newest -vala"
[ebuild  N    ~] kde-frameworks/solid-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] x11-misc/sddm-0.13.0-r1  USE="consolekit pam -systemd"
[ebuild  N     ] sys-apps/accountsservice-0.6.40  USE="introspection -doc (-selinux) -systemd"
[ebuild  N    ~] kde-frameworks/kio-5.17.0  USE="X acl handbook kwallet -debug -doc -kerberos {-test}"
[ebuild  N    ~] kde-frameworks/kinit-5.17.0  USE="caps man -debug -doc"
[ebuild  N    ~] kde-frameworks/kded-5.17.0  USE="man -debug -doc"
[ebuild  N    ~] kde-frameworks/kdeclarative-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/kparts-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/knewstuff-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifyconfig-5.17.0  USE="phonon -debug -doc"
[ebuild  N    ~] kde-frameworks/frameworkintegration-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/baloo-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kxmlrpcclient-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdelibs4support-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcmutils-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/khtml-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kross-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/ktexteditor-5.17.0  USE="-debug -doc -git {-test}"
[ebuild  N    ~] kde-plasma/kde-cli-tools-5.5.1  USE="X handbook -debug {-test}"
[ebuild  N    ~] kde-frameworks/kactivities-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/oxygen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kgamma-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/user-manager-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/systemsettings-5.5.1  USE="handbook -debug -gtk"
[ebuild  N    ~] kde-apps/kio-extras-15.08.3  USE="exif handbook phonon sftp -debug -mtp -samba -slp {-test}"
[ebuild  N    ~] kde-frameworks/plasma-5.17.0-r2  USE="X -debug -doc -egl -gles2 {-test}"
[ebuild  N    ~] kde-plasma/kscreen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/sddm-kcm-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/krunner-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kscreenlocker-5.5.1  USE="pam -debug {-test}"
[ebuild  N    ~] kde-plasma/libksysguard-5.5.1  USE="X detailedmemory -debug {-test}"
[ebuild  N    ~] kde-plasma/breeze-5.5.1  USE="-debug -qt4"
[ebuild  N    ~] kde-plasma/kinfocenter-5.5.1  USE="X handbook opengl pci -debug -egl -gles -ieee1394 -nfs -samba -wayland"
[ebuild  N    ~] kde-plasma/bluedevil-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kwin-5.5.1  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N    ~] kde-plasma/milou-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/ksysguard-5.5.1  USE="handbook -debug -lm_sensors"
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="kde python -gnome -mono -networkmanager -perl -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] net-libs/glib-networking-2.44.0  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.50.0  USE="introspection ssl -debug -samba {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-misc/networkmanager-1.0.6-r1  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/networkmanager-qt-5.17.0  USE="-debug -doc -teamd {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-5.5.1.1  USE="dbus geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[ebuild  N    ~] kde-plasma/khotkeys-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/powerdevil-5.5.1  USE="handbook -debug -systemd"
[ebuild  N    ~] kde-plasma/plasma-desktop-5.5.1  USE="evdev fontconfig handbook -debug -gtk2 -gtk3 -legacy-systray -pulseaudio -qt4 {-test} -touchpad"
[ebuild  N    ~] kde-plasma/kdeplasma-addons-5.5.1  USE="-debug -ibus -scim"
[ebuild  N    ~] kde-plasma/kmenuedit-5.5.1  USE="handbook hotkeys -debug"
[ebuild  N    ~] kde-plasma/khelpcenter-5.5.1  USE="handbook -debug"
[uninstall     ] kde-base/khelpcenter-4.14.3
[blocks b      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking kde-plasma/khelpcenter-5.5.1)
[ebuild  N    ~] kde-plasma/plasma-meta-5.5.1  USE="bluetooth display-manager sddm wallpapers -gtk -mediacenter -networkmanager -pulseaudio -sdk"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtxml-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    (and 10 more with the same problem)

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtpaths-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 1:18 pm    Post subject: Reply with quote

RoboGrinch wrote:
Hi thanks for the help, what do you mean by this?

genstorm wrote:
Again, your choice of stable system + plasma-5 is causing this.

You have ACCEPT_KEYWORDS="amd64" in your make.conf. That means you get stabilised updates only. Plasma-5 is still not stable keyworded so it requires you to edit all those files in package.keywords. It's OK if you want to learn to deal with portage configuration real quick, but it might not be the most comfortable way to get things going the first time with Gentoo. ;)

ACCEPT_KEYWORDS="~amd64" would enable all these 'unstable' updates 'for free', at the cost of possibly more bugs (you will get much more updates more often for all of your system).

Code:
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

Try to add the suggested backtrack option to your emerge cmd.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 1:28 pm    Post subject: Reply with quote

I breezed through the gentoo install, the handbook made it so easy.

As soon as I got to plasma5 its been a nightmare...

Should I maybe install KDE4 instead?

I have tried all the options... I now get this:

Code:

Gentop ~ # emerge --backtrack=30 --verbose-conflicts --ask kde-plasma/plasma-meta

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libyaml-0.1.6  USE="-doc -examples -static-libs {-test}"
[ebuild  N     ] sys-apps/tcp-wrappers-7.6.22-r1  USE="ipv6 -netgroups -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libunwind-1.1  USE="-debug -debug-frame -libatomic -lzma -static-libs"
[ebuild  N     ] dev-db/lmdb-0.9.14  USE="-static-libs"
[ebuild  N     ] x11-base/xorg-drivers-1.17  INPUT_DEVICES="-acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -keyboard (-libinput) -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] net-wireless/wireless-regdb-20151022
[ebuild  N     ] sys-libs/mtdev-1.1.5  USE="-static-libs"
[ebuild  N     ] dev-util/google-perftools-2.0-r2  USE="debug -largepages -minimal -static-libs {-test}"
[ebuild  N     ] virtual/perl-MIME-Base64-3.140.0-r1
[ebuild  N     ] dev-perl/URI-1.600.0-r1
[ebuild  N     ] app-arch/snappy-1.1.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax"
[ebuild  N     ] dev-libs/leveldb-1.18-r1  USE="snappy tcmalloc -static-libs"
[ebuild  N     ] x11-libs/libxkbfile-1.0.9  USE="-static-libs"
[ebuild  N     ] x11-proto/resourceproto-1.2.0
[ebuild  N     ] x11-misc/xbitmaps-1.1.1
[ebuild  N     ] x11-proto/fontsproto-2.1.3  USE="-doc"
[ebuild  N     ] x11-proto/xcmiscproto-1.2.2  USE="-doc"
[ebuild  N     ] x11-proto/trapproto-3.4.3
[ebuild  N     ] x11-proto/bigreqsproto-1.1.2  USE="-doc"
[ebuild  N     ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild  N     ] x11-libs/libpciaccess-0.13.4  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/xf86dgaproto-2.1-r2  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libqmi-1.12.6  USE="-doc -static-libs"
[ebuild  N     ] x11-apps/xkbcomp-1.3.0
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] x11-libs/libXfont-1.5.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild  N     ] net-misc/dhcp-4.3.1-r2  USE="client ipv6 ldap server ssl (-selinux) -vim-syntax"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="ipv6 pam -activefilter -atm -dhcp -eap-tls -gtk -radius"
[ebuild  N     ] net-dialup/rp-pppoe-3.11-r3  USE="-tk"
[ebuild  N     ] net-misc/socat-1.7.3.0  USE="ipv6 readline ssl tcpd"
[ebuild     U ~] dev-qt/qtcore-5.5.1 [5.4.2]
[ebuild  N     ] dev-lang/swig-3.0.5  USE="pcre -ccache -doc"
[ebuild  N     ] dev-libs/nss-3.20.1  USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/slang-2.2.4-r1  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  NS    ] dev-qt/qtscript-5.4.2-r1 [4.8.6-r2] USE="jit -debug -scripttools {-test}"
[ebuild  N    ~] dev-qt/qtpaths-5.5.1  USE="-debug {-test}"
[ebuild  N     ] dev-util/boost-build-1.56.0  USE="python -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-fonts/noto-2015.04  USE="X"
[ebuild  N     ] dev-libs/libnl-3.2.27  USE="python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-libs/libevdev-1.4.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/boost-1.56.0-r1  USE="icu nls python threads -context -debug -doc -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] app-eselect/eselect-ruby-20131227
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-python/pygments-2.0.2-r2  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] net-libs/libndp-1.5  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-python/m2crypto-0.22.3-r4  PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-misc/xkeyboard-config-2.16
[ebuild  N     ] dev-python/docutils-0.12  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] net-wireless/crda-1.1.3-r1
[ebuild  N     ] x11-apps/setxkbmap-1.3.1
[ebuild  NS    ] dev-qt/qtsql-5.4.2 [4.8.6-r1] USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}"
[ebuild  N     ] dev-lang/ruby-2.1.7  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs"
[ebuild  N     ] dev-lang/ruby-2.0.0_p647-r1  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2"
[ebuild  N     ] dev-ruby/rubygems-2.2.5-r1  USE="-server {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] virtual/rubygems-10  RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rake-0.9.6-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/json-1.8.2-r1  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/racc-1.4.11  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby19)"
[ebuild  N     ] dev-ruby/rdoc-4.2.0  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 (-ruby22)"
[ebuild  N     ] dev-libs/libinput-1.1.0  USE="{-test}"
[ebuild  N     ] x11-apps/xrdb-1.1.0
[ebuild  N     ] x11-apps/xsetroot-1.1.1
[ebuild  N     ] net-wireless/wpa_supplicant-2.4-r3  USE="dbus hs2-0 readline ssl -ap -eap-sim -fasteap -gnutls -p2p (-ps3) -qt4 (-selinux) -smartcard -tdls -uncommon-eap-types -wimax -wps"
[ebuild  N     ] x11-apps/xmessage-1.0.4
[ebuild  N     ] dev-qt/qdbus-5.4.2  USE="-debug {-test}"
[ebuild  N     ] x11-apps/xinit-1.3.4-r1  USE="minimal -systemd"
[ebuild  N     ] media-gfx/fontforge-20150612-r1  USE="X cairo gif jpeg png python readline svg tiff unicode -gtk -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N    ~] kde-frameworks/kf-env-3
[ebuild  N     ] x11-base/xorg-server-1.17.4  USE="glamor ipv6 nptl suid udev xorg -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb"
[ebuild  NS    ] dev-qt/qtsvg-5.4.2 [4.8.6-r1] USE="-debug {-test}"
[ebuild  NS    ] dev-qt/qtopengl-5.4.2 [4.8.6-r1] USE="-debug -gles2 {-test}"
[ebuild  N     ] x11-drivers/xf86-input-evdev-2.9.2
[ebuild  N    ~] kde-frameworks/extra-cmake-modules-5.17.0  USE="-doc {-test}"
[ebuild  N     ] dev-qt/linguist-tools-5.4.2  USE="qml -debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.4.2  USE="widgets -debug {-test}"
[ebuild  N    ~] kde-plasma/kwallet-pam-5.5.1  USE="-debug"
[ebuild  N     ] dev-qt/qtquick1-5.4.2  USE="opengl xml -debug -designer {-test} -webkit"
[ebuild  NS    ] dev-qt/qtwebkit-5.4.2 [4.8.6-r1] USE="opengl qml udev -debug -gstreamer -gstreamer010 -multimedia -printsupport {-test} -webp"
[ebuild  N     ] net-libs/libssh-0.6.5  USE="sftp zlib -debug -doc -examples -gcrypt -gssapi -pcap -server -ssh1 -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.4.2  USE="-debug {-test}"
[ebuild  N     ] dev-libs/libical-1.0.1  USE="-doc -examples -introspection -static-libs"
[ebuild  N    ~] kde-frameworks/kcoreaddons-5.17.0  USE="nls -debug -doc (-fam) {-test}"
[ebuild  N    ~] kde-frameworks/ki18n-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfig-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwidgetsaddons-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kwindowsystem-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdbusaddons-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kitemviews-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcodecs-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kguiaddons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/karchive-5.17.0  USE="bzip2 lzma -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/kidletime-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/sonnet-5.17.0  USE="hunspell nls -aspell -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/libkscreen-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-plasma/kdecoration-5.5.1  USE="-debug {-test}"
[ebuild  N    ~] kde-frameworks/attica-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kitemmodels-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-wallpapers-5.5.1
[ebuild  N    ~] kde-frameworks/kdnssd-5.17.0  USE="nls -debug -doc {-test} -zeroconf"
[ebuild  N    ~] kde-frameworks/threadweaver-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/bluez-qt-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/breeze-icons-5.17.0  USE="{-test}"
[ebuild  N    ~] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N    ~] kde-frameworks/kcrash-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdoctools-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcompletion-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjobwidgets-5.17.0  USE="X nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpty-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kunitconversion-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kwayland-integration-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kfilemetadata-5.17.0  USE="exif pdf -debug -doc -epub -ffmpeg -libav -taglib {-test}"
[ebuild  N    ~] kde-frameworks/kservice-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kglobalaccel-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kpackage-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kjs-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesignerplugin-5.17.0  USE="nls -debug -designer -doc -webkit"
[ebuild  N    ~] kde-frameworks/kemoticons-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdesu-5.17.0  USE="X -debug -doc"
[ebuild  N    ~] kde-frameworks/kpeople-5.17.0  USE="-debug -doc {-test}"
[ebuild  N     ] net-wireless/bluez-5.35  USE="cups obex readline udev -debug (-selinux) -systemd {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/kjsembed-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifications-5.17.0  USE="X dbus nls -debug -doc (-speech)"
[ebuild  N    ~] kde-plasma/kwrited-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kauth-5.17.0  USE="nls (policykit) -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kconfigwidgets-5.17.0  USE="man -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kiconthemes-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/polkit-kde-agent-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/ktextwidgets-5.17.0  USE="-debug -doc (-speech) {-test}"
[ebuild  N    ~] kde-frameworks/kwallet-5.17.0  USE="-debug -doc -gpg {-test}"
[ebuild  N    ~] kde-frameworks/kxmlgui-5.17.0  USE="-attica -debug -doc {-test}"
[ebuild  N    ~] kde-plasma/ksshaskpass-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/kbookmarks-5.17.0  USE="nls -debug -doc {-test}"
[ebuild     U ~] sys-auth/consolekit-1.0.0-r1 [0.4.6] USE="-cgroups%"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] net-misc/modemmanager-1.4.12  USE="introspection (policykit) qmi -mbim -qmi-newest -vala"
[ebuild  N    ~] kde-frameworks/solid-5.17.0  USE="nls -debug -doc {-test}"
[ebuild  N    ~] x11-misc/sddm-0.13.0-r1  USE="consolekit pam -systemd"
[ebuild  N     ] sys-apps/accountsservice-0.6.40  USE="introspection -doc (-selinux) -systemd"
[ebuild  N    ~] kde-frameworks/kio-5.17.0  USE="X acl handbook kwallet -debug -doc -kerberos {-test}"
[ebuild  N    ~] kde-frameworks/kinit-5.17.0  USE="caps man -debug -doc"
[ebuild  N    ~] kde-frameworks/kded-5.17.0  USE="man -debug -doc"
[ebuild  N    ~] kde-frameworks/kdeclarative-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/kparts-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/knewstuff-5.17.0  USE="-debug -doc"
[ebuild  N    ~] kde-frameworks/knotifyconfig-5.17.0  USE="phonon -debug -doc"
[ebuild  N    ~] kde-frameworks/baloo-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/frameworkintegration-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kxmlrpcclient-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kdelibs4support-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/kcmutils-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/khtml-5.17.0  USE="X -debug -doc {-test}"
[ebuild  N    ~] kde-frameworks/ktexteditor-5.17.0  USE="-debug -doc -git {-test}"
[ebuild  N    ~] kde-frameworks/kross-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kde-cli-tools-5.5.1  USE="X handbook -debug {-test}"
[ebuild  N    ~] kde-frameworks/kactivities-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/oxygen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kgamma-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/user-manager-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/systemsettings-5.5.1  USE="handbook -debug -gtk"
[ebuild  N    ~] kde-apps/kio-extras-15.08.3  USE="exif handbook phonon sftp -debug -mtp -samba -slp {-test}"
[ebuild  N    ~] kde-frameworks/plasma-5.17.0-r2  USE="X -debug -doc -egl -gles2 {-test}"
[ebuild  N    ~] kde-plasma/kscreen-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/sddm-kcm-5.5.1  USE="-debug"
[ebuild  N    ~] kde-frameworks/krunner-5.17.0  USE="-debug -doc {-test}"
[ebuild  N    ~] kde-plasma/kscreenlocker-5.5.1  USE="pam -debug {-test}"
[ebuild  N    ~] kde-plasma/libksysguard-5.5.1  USE="X detailedmemory -debug {-test}"
[ebuild  N    ~] kde-plasma/breeze-5.5.1  USE="-debug -qt4"
[ebuild  N    ~] kde-plasma/bluedevil-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/kinfocenter-5.5.1  USE="X handbook opengl pci -debug -egl -gles -ieee1394 -nfs -samba -wayland"
[ebuild  N    ~] kde-plasma/kwin-5.5.1  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N    ~] kde-plasma/milou-5.5.1  USE="-debug"
[ebuild  N    ~] kde-plasma/ksysguard-5.5.1  USE="handbook -debug -lm_sensors"
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="kde python -gnome -mono -networkmanager -perl -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] net-libs/glib-networking-2.44.0  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.50.0  USE="introspection ssl -debug -samba {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-misc/networkmanager-1.0.6-r1  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] kde-frameworks/networkmanager-qt-5.17.0  USE="-debug -doc -teamd {-test}"
[ebuild  N    ~] kde-plasma/plasma-workspace-5.5.1.1  USE="dbus geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[ebuild  N    ~] kde-plasma/khotkeys-5.5.1  USE="handbook -debug"
[ebuild  N    ~] kde-plasma/kmenuedit-5.5.1  USE="handbook hotkeys -debug"
[ebuild  N    ~] kde-plasma/plasma-desktop-5.5.1  USE="evdev fontconfig handbook -debug -gtk2 -gtk3 -legacy-systray -pulseaudio -qt4 {-test} -touchpad"
[ebuild  N    ~] kde-plasma/kdeplasma-addons-5.5.1  USE="-debug -ibus -scim"
[ebuild  N    ~] kde-plasma/powerdevil-5.5.1  USE="handbook -debug -systemd"
[ebuild  N    ~] kde-plasma/khelpcenter-5.5.1  USE="handbook -debug"
[uninstall     ] kde-base/khelpcenter-4.14.3
[blocks b      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking kde-plasma/khelpcenter-5.5.1)
[ebuild  N    ~] kde-plasma/plasma-meta-5.5.1  USE="bluetooth display-manager sddm wallpapers -gtk -mediacenter -networkmanager -pulseaudio -sdk"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtsql-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtopengl-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qttest-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtnetwork-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtdbus-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtconcurrent-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtxml-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                       

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/kscreenlocker-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     
    >=dev-qt/qtcore-5.5.1:5 required by (kde-frameworks/frameworkintegration-5.17.0:5/5.17::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/plasma-workspace-5.5.1.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtpaths-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Gentop ~ #
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 1:32 pm    Post subject: Reply with quote

Try a higher value for backtrack, such as 500. If that doesn't help, you need to manually unmask dev-qt/* packages. Well, you're almost there already.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 1:41 pm    Post subject: Reply with quote

Hi,

backtrack=500 didnt work...

To unmask will this work?

Code:
echo "=dev-qt/*" > /etc/portage/package.unmask/dev-qt


Its failing here:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtsql-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtdbus-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qttest-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtxml-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtopengl-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtconcurrent-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtnetwork-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/kscreenlocker-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (kde-frameworks/frameworkintegration-5.17.0:5/5.17::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtpaths-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/plasma-workspace-5.5.1.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                 

Many Thanks
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 1:51 pm    Post subject: Reply with quote

Review my post>Step #3 in the this thread:
https://forums.gentoo.org/viewtopic-t-1033066-highlight-.html

It seems you are using the stable amd64 version of Gentoo. As Genstorm mentioned, KDE5 is in testing Gentoo which means the use of package.accept_keywords to get testing packages into stable Gentoo.

Also use the link I provided to help out overall with KDE5 install on stable Gentoo.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 01, 2016 1:53 pm    Post subject: Reply with quote

RoboGrinch wrote:
To unmask will this work?

Code:
echo "=dev-qt/*" > /etc/portage/package.unmask/dev-qt

No.
1.: It's bad practise to unmask all of dev-qt like that
2.: I said unmask, but I really meant you need to put some lines into package.keywords. (that's two different levels of unmasking)

Basically all these qt packages that it mentions are installed need to be unmasked (in package.keywords) by their 5.5.1 version (look at the other files that portage created in there):

Code:
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtsql-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtdbus-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qttest-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtxml-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtopengl-5.4.2:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtconcurrent-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtnetwork-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 1:58 pm    Post subject: Reply with quote

Hi Guys,

Thanks for all the help, I know it must be annoying these issues I am having... I just appreciate your time and effort.

I added this to the /etc/portage/package.accept_keywords

Code:
=dev-qt/* ~amd64


This caused this error


Code:
--- Invalid atom in /etc/portage/package.accept_keywords: =dev-qt/*
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:00 pm    Post subject: Reply with quote

RoboGrinch wrote:
Hi Guys,

Thanks for all the help, I know it must be annoying these issues I am having... I just appreciate your time and effort.

I added this to the /etc/portage/package.accept_keywords

Code:
=dev-qt/* ~amd64


This caused this error


Code:
--- Invalid atom in /etc/portage/package.accept_keywords: =dev-qt/*


Remove the "="
Code:
dev-qt/* ~amd64
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 2:03 pm    Post subject: Reply with quote

Hi

I added that to the file and I get even more errors now it seems?

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtconcurrent-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtdbus-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.4.2 required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                   

  (dev-qt/qtcore-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qdbus-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtnetwork-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/plasma-workspace-5.5.1.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtpaths-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtquick1-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtsql-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.0:5 required by (kde-plasma/kscreenlocker-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/linguist-tools-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtdeclarative-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtgui-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (kde-frameworks/frameworkintegration-5.17.0:5/5.17::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtsvg-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qttest-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtquickcontrols-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtscript-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtopengl-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtdbus-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtgraphicaleffects-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtxml-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                   
    >=dev-qt/qtcore-5.5.1:5 required by (dev-qt/qtxmlpatterns-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               
    >=dev-qt/qtcore-5.5.1:5[icu] required by (dev-qt/qtwebkit-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                               

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.4.2 required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^                 ^^^^^                                                                                               
    ~dev-qt/qtwidgets-5.4.2[gles2=] required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
    ^                 ^^^^^                                                                                               

  (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwidgets-5.5.1:5 required by (dev-qt/qtwebkit-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                             
    >=dev-qt/qtwidgets-5.5.1:5 required by (dev-qt/qtquickcontrols-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                             
    ~dev-qt/qtwidgets-5.5.1[gles2=] required by (dev-qt/qtopengl-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                               
    >=dev-qt/qtwidgets-5.5.1:5[gles2=] required by (dev-qt/qtdeclarative-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                             
    >=dev-qt/qtwidgets-5.5.1:5 required by (dev-qt/qtsvg-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                             
    >=dev-qt/qtwidgets-5.5.1:5 required by (dev-qt/qtquick1-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                             

dev-qt/qtgui:5

  (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.4.2[xcb] required by (dev-qt/qtx11extras-5.4.2:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                   
    ~dev-qt/qtgui-5.4.2[gles2=] required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                   
    ~dev-qt/qtgui-5.4.2[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                   

  (dev-qt/qtgui-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-5.5.1:5 required by (dev-qt/qtsvg-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                 
    >=dev-qt/qtgui-5.5.1:5[gles2=] required by (dev-qt/qtquick1-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                 
    ~dev-qt/qtgui-5.5.1[gles2=] required by (dev-qt/qtopengl-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                   
    >=dev-qt/qtgui-5.5.1:5 required by (dev-qt/qtquick1-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                 
    >=dev-qt/qtgui-5.5.1:5 required by (dev-qt/qtwebkit-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                 
    ~dev-qt/qtgui-5.5.1[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                   
    >=dev-qt/qtgui-5.5.1:5[gles2=] required by (dev-qt/qtdeclarative-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                 
    >=dev-qt/qtgui-5.5.1:5 required by (dev-qt/qtquickcontrols-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                     
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Fri Jan 01, 2016 2:13 pm    Post subject: Reply with quote

Review my post in the this thread:
https://forums.gentoo.org/viewtopic-t-1033066-highlight-.html

.....to help out overall with KDE5 install on stable Gentoo.
Back to top
View user's profile Send private message
RoboGrinch
n00b
n00b


Joined: 30 Dec 2015
Posts: 37

PostPosted: Fri Jan 01, 2016 2:20 pm    Post subject: Reply with quote

Hi

Thanks, its a great post... I have followed it and still getting the above errors...

Would you recommend running a

Code:
emerge -avuND world


after the changes I have made?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum