Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python upgrade blocking (eselect-python/python-exec)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Tue Dec 29, 2015 1:33 pm    Post subject: Python upgrade blocking (eselect-python/python-exec) Reply with quote

Since over a month upgrading GenToo is impossible since eselect-python and python-exec are in such a huge super-block state it is not possible to fix. A month ago somebody on this forum claimed it is in the midts of a python transition and the super-block would go away. Fast-forward 1 month and everything is STILL broken.

Can somebody in charge of this upgrade-mess state when this mess is eventually going to be resolved?

Code:
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[uninstall     ] dev-lang/python-3.3.5-r1:3.3::gentoo  USE="gdbm hardened ipv6 ncurses readline ssl threads xml -build -doc -examples -sqlite -tk -wininst"
[blocks b      ] <dev-lang/python-3.3.5-r4:3.3 ("<dev-lang/python-3.3.5-r4:3.3" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

Total: 41 packages (38 upgrades, 1 new, 2 reinstalls, 1 uninstall), Size of downloads: 161,225 KiB
Conflict: 5 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-python required by @selected
    >=app-eselect/eselect-python-20091230 required by (dev-python/turbojson-1.3.2:0/0::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed)

  (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4 required by (dev-python/pypax-0.9.2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/cryptography-1.0.2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/certifi-2015.11.20:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/genshi-0.7:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/simplejson-3.8.1:0/0::gentoo, installed)
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (app-admin/webapp-config-1.54-r1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/cython-0.22:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (sys-apps/kmod-21:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyasn1-0.1.8:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/beautifulsoup-4.3.2:4/4::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/cffi-1.2.1:0/1.2.1::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pyopenssl-0.14:0/0::gentoo, installed)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.24:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/reportlab-3.1.44-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (sys-libs/libcap-ng-0.7.7:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyyaml-3.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyelftools-0.22:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/zope-interface-4.1.1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyparsing-2.0.3:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/markdown-2.6.5:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/ply-3.6-r1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/configobj-5.0.6:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/docutils-0.12:0/0::gentoo, installed)
    dev-lang/python:3.4[xml] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/psycopg-2.5.3:2/2::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pytz-2015.6:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygments-2.0.2-r2:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[tk?,threads(+)] (dev-lang/python:3.4[threads(+)]) required by (dev-python/pillow-2.8.1:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycrypto-2.6.1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/python-dateutil-2.2:0/0::gentoo, installed)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4 required by (sys-boot/grub-2.02_beta2-r8:2/2::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (sys-apps/file-5.22:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/lxml-3.4.4:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/zope-interface-4.1.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyparsing-2.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cython-0.22:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ssl?,xml] (>=dev-lang/python-2.7.5-r2:2.7[ssl,xml]) required by (dev-python/soappy-0.12.5-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycrypto-2.6.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyelftools-0.22:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sqlobject-2.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/enum34-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/docutils-0.12:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/alsa-lib-1.0.29:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-words-13.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cffi-1.2.1:0/1.2.1::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mechanize-0.2.5-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite?] (>=dev-lang/python-2.7.5-r2:2.7) required by (www-apps/trac-1.0.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/twisted-core-13.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-python/wstools-0.4.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-0.1.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyprotocols-1.0_pre2306-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-print/cups-2.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/usbutils-008-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-java/javatoolkit-0.3.0-r9:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygments-2.0.2-r2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pypgsql-2.5.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplejson-3.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxml-0.8.4-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/tdb-1.3.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyopenssl-0.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxslt-1.1.28-r5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/genshi-0.7:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/file-5.22:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/decoratortools-1.8-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-conch-13.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-dateutil-2.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/beautifulsoup-4.3.2:4/4::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyyaml-3.11:0/0::gentoo, installed)
    =dev-lang/python-2* required by (sys-libs/libieee1284-0.2.11-r3:0/0::gentoo, installed)
    =dev-lang/python-2* required by (dev-python/turbojson-1.3.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pytz-2015.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ply-3.6-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-db/postgresql-9.4.5-r1:9.4/9.4::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cheetah-2.4.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/m2crypto-0.22.3-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/lxml-3.4.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/kmod-21:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pypax-0.9.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/pydot-1.0.28-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-util/scons-2.4.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?,threads(+)] (>=dev-lang/python-2.7.5-r2:2.7[threads(+)]) required by (dev-python/pillow-2.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/psycopg-2.5.3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/turbokid-1.0.5-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-web-13.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/egenix-mx-base-3.2.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.24:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/subversion-1.8.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pychart-1.39-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-libs/libcap-ng-0.7.7:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/webapp-config-1.54-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyrex-0.9.9-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/talloc-2.1.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/fpconst-0.7.3-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cryptography-1.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/util-linux-2.26.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/graphviz-2.38.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/reportlab-3.1.44-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipaddress-1.0.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/formencode-1.2.6-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ruledispatch-0.5_pre2306-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-devel/gdb-7.9.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/turbocheetah-1.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/configobj-5.0.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (sys-libs/tevent-0.9.21-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/markdown-2.6.5:0/0::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/kid-0.9.6-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/zope-interface-4.1.1::gentoo
# required by @selected
# required by @world (argument)

_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6227
Location: Room 101

PostPosted: Tue Dec 29, 2015 2:16 pm    Post subject: Re: Python upgrade blocking (eselect-python/python-exec) Reply with quote

Dragonlord wrote:
Since over a month upgrading GenToo is impossible since eselect-python and python-exec are in such a huge super-block state it is not possible to fix. A month ago somebody on this forum claimed it is in the midts of a python transition and the super-block would go away. Fast-forward 1 month and everything is STILL broken.

Dragonlord ... no, from the above I would say it is "possible to fix", but such a fix is dependent on your having the skills required for using ~arch (unstable). If you keyword ~arch you can not then expect that it functions like stable and that such issues will be taken care of for you ... that is the reason why its unstable, and why keywords exist. If you don't want to be exposed to the unstable branch then don't keyword ~arch.

best ... khay
Back to top
View user's profile Send private message
joergwissen
n00b
n00b


Joined: 24 Oct 2014
Posts: 6

PostPosted: Tue Dec 29, 2015 3:10 pm    Post subject: Reply with quote

I'm also struggling with this and have not found a solution. so far wiggling my way through with emerge --exclude.
Required skill level seems to be more than trivial, any hints to resolve this are gladly accepted.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Dec 29, 2015 3:13 pm    Post subject: Reply with quote

Something seems to be fishy here.

First of all, why is app-eselect/eselect-python in @world ?

Second, what's the output of 'emerge -1pv dev-lang/python:2.7 dev-lang/python:3.3 dev-lang/python:3.4' ?
Back to top
View user's profile Send private message
joergwissen
n00b
n00b


Joined: 24 Oct 2014
Posts: 6

PostPosted: Tue Dec 29, 2015 3:38 pm    Post subject: Re: Python upgrade blocking (eselect-python/python-exec) Reply with quote

First:
Why is eselect-python in @world?
It appears to be pulled in by python update to 3.5 and conflicts with the existing python versions.
And probably because I use keyword ~arch as khay suggested.
Code:

emerge -p python


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] dev-lang/python-3.5.1-r2 [2.7.10-r3, 3.4.3-r2] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst"
[ebuild     U  ] dev-lang/python-exec-2.1 [2.0.2]
[ebuild     U  ] app-eselect/eselect-python-20151117-r2 [20140125]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.5.1-r2:3.5/3.5m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3-r2:3.4/3.4::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r3:2.7/2.7::gentoo, installed)




Second:
Code:
emerge -1pv dev-lang/python:2.7 dev-lang/python:3.3 dev-lang/pytho:3.4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/python-2.7.11-r1:2.7::gentoo [2.7.10-r3:2.7::gentoo] SE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml (-berkdb) -build doc -examples -hardened -libressl -sqlite -tk -wininst" 12003 KiB
[ebuild     U  ] dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo [3.4.3-r2:3.4/3.4::gntoo] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardene -libressl -sqlite -tk -wininst" 0 KiB
[ebuild  NS    ] dev-lang/python-3.3.5-r7:3.3/3.3m::gentoo [2.7.10-r3:2.7::gento, 3.4.3-r2:3.4::gentoo] USE="gdbm ipv6 ncurses readline ssl threads xml -build-doc -examples -hardened -libressl -sqlite -tk -wininst" 0 KiB
[ebuild     U  ] dev-lang/python-exec-2.1:2::gentoo [2.0.2:2::gentoo] PYTHON_TAGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5 (-jython2_5%*)" 81 KiB
[ebuild     U  ] app-eselect/eselect-python-20151117-r2::gentoo [20140125::gento] 62 KiB
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-pyhon-20151117" is blocking dev-lang/python-exec-2.1)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Dec 29, 2015 5:40 pm    Post subject: Reply with quote

@joergwissen: that's what you get for tacking onto a seemingly similar problem, without giving any clue if it's actually the same.

Likely app-eselect/eselect-python isn't in your world (actually, given the emerge output, it definitely isn't).
Also, you don't have python:3.3 installed, so that part doesn't concerns you either.

Given the slotting, 'emerge -p python' is plain meaningless too.

Finally, if you'd just drop python:3.3 from the line, the emerge output doesn't show any problem for you.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Wed Dec 30, 2015 1:37 am    Post subject: Reply with quote

I'm not use keywords especially not on python stuff. A problem with the gentoo provided amd64 profile? I hard-set now "app-eselect/eselect-python amd64" and this seems to fix the problem. No idea why the gentoo amd64 profile pulls in app-eselect/eselect-python with ~amd64.
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
joergwissen
n00b
n00b


Joined: 24 Oct 2014
Posts: 6

PostPosted: Wed Dec 30, 2015 3:15 am    Post subject: Reply with quote

@Dragonlord
Just to establish if we have the same issue.

I'm doing this:
emerge -pv --update --deep @world

and get that:
Code:


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/python-2.7.11-r1:2.7::gentoo [2.7.10-r3:2.7::gentoo] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -sqlite -tk -wininst" 12003 KiB
[ebuild     U  ] dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo [3.4.3-r2:3.4/3.4::gentoo] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst" 0 KiB
[ebuild     U  ] dev-lang/python-exec-2.1:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5) (-jython2_5%*)" 81 KiB
[ebuild     U  ] app-eselect/eselect-python-20151117-r2::gentoo [20140125::gentoo] 62 KiB
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[ebuild     U  ] sys-devel/llvm-3.7.0-r5:0/3.7.0::gentoo [3.7.0-r4:0/3.7.0::gentoo] USE="libffi ncurses static-analyzer xml -clang -debug -doc -gold -libedit -lldb -multitarget -ocaml -python {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" VIDEO_CARDS="-radeon" 0 KiB

Total: 5 packages (5 upgrades), Size of downloads: 12144 KiB
Conflict: 1 block


When you say hard-set now "app-eselect/eselect-python amd64" you mean adding this to package.keywords?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6227
Location: Room 101

PostPosted: Wed Dec 30, 2015 4:14 am    Post subject: Reply with quote

@joergwissen ... that block is a lower case 'b', and so should be resolved by portage. I don't see there being an issue, if you remove --pretend the merge should be successful.

@Dragonlord ... =app-eselect/eselect-python-20151117 shouldn't be selected as its ~amd64 ... and the fact that its blocking =dev-lang/python-exec-2.1 suggested to me ~amd64 as it is similarly keyworded. The fact you are required to explictly keyword 'app-eselect/eselect-python amd64' isn't normal, are you perhaps setting PYTHON_TARGETS in make.conf?

best ... khay
Back to top
View user's profile Send private message
joergwissen
n00b
n00b


Joined: 24 Oct 2014
Posts: 6

PostPosted: Wed Dec 30, 2015 1:53 pm    Post subject: Reply with quote

@khay
You are right, it worked. Thanks for your help.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Wed Dec 30, 2015 2:05 pm    Post subject: Reply with quote

khayyam wrote:
@joergwissen ... that block is a lower case 'b', and so should be resolved by portage. I don't see there being an issue, if you remove --pretend the merge should be successful.

@Dragonlord ... =app-eselect/eselect-python-20151117 shouldn't be selected as its ~amd64 ... and the fact that its blocking =dev-lang/python-exec-2.1 suggested to me ~amd64 as it is similarly keyworded. The fact you are required to explictly keyword 'app-eselect/eselect-python amd64' isn't normal, are you perhaps setting PYTHON_TARGETS in make.conf?

best ... khay

I don't use PYTHON_TARGETS. I don't know where it comes from but maybe in a future upgrade the problem goes away without needing this. At last it works now. That's fine enough for me.
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
oz_tiram
n00b
n00b


Joined: 31 May 2015
Posts: 44

PostPosted: Sun Jan 24, 2016 11:41 am    Post subject: Reply with quote

I am also stuck with this problem. I would like to install python 3.5 on my system and remove python 3.4.
I am not using PYTHON_TARGETS nor I have ~amd64 in my ACCEPT_KEYWORDS.

Still I am seeing this:

Code:

 # grep -ri python /etc/portage/
/etc/portage/make.conf:#PYTHON_TARGETS="python2_7 python3_4"
/etc/portage/make.conf:#USE_PYTHON="2.7 3.4"
/etc/portage/package.use/iputils:>=mate-base/mate-menus-1.12.0-r1 python
 # emerge -a  app-eselect/eselect-python =dev-lang/python-3.5.1-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ~] dev-lang/python-3.5.1-r2 [2.7.10-r1, 3.4.3] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst"
[ebuild     U ~] dev-lang/python-exec-2.1 [2.0.1-r1]
[ebuild     U ~] app-eselect/eselect-python-20151117-r2 [20111108]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/certifi-2015.9.6.2:0/0::gentoo, installed)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-desktop-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-menus-1.12.0-r1:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.9.6.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/newt-0.52.15:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/xpyb-1.3.1-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-applets-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (x11-misc/mozo-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-python
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.5.1-r2:3.5/3.5m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-lang/python-3.5.1-r2::gentoo
# required by =dev-lang/python-3.5.1-r2 (argument)
=app-eselect/eselect-python-20151117-r2 ~amd64
# required by dev-python/pygtksourceview-2.10.1-r1::gentoo
# required by dev-vcs/git-2.4.10::gentoo[python,gtk]
# required by @selected
# required by @world (argument)
=dev-lang/python-exec-2.1 ~amd64
# required by =dev-lang/python-3.5.1-r2 (argument)
=dev-lang/python-3.5.1-r2 ~amd64



Can someone provide guidance here? Can I remove app-eselect/eselect-python-20151117 without breaking my system?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8566
Location: Austria

PostPosted: Sun Jan 24, 2016 11:52 am    Post subject: Reply with quote

Code:
>=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.5.1-r2:3.5/3.5m::gentoo, ebuild scheduled for merge)

If you want python-3.5.1, that requires >=eselect-python-20151117-r1.

Code:
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)

Read: (Currently only available) python:3.4 version lower than 3.4.3-r4 is blocking app-eselect/eselect-python-20151117-r2

Solution: Unmask dev-lang/python-3.4.3-r7

Code:
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

Read: (Currently only available) python:2.7 version lower than 2.7.10-r4 is blocking app-eselect/eselect-python-20151117-r2

Solution: Unmask dev-lang/python-2.7.11-r2
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
oz_tiram
n00b
n00b


Joined: 31 May 2015
Posts: 44

PostPosted: Sun Jan 24, 2016 12:38 pm    Post subject: Reply with quote

HI,

Thanks for the reply, I added this to
Code:
# cat /etc/portage/package.accept_keywords
=dev-lang/python-3.4.3-r7 ~amd64
=dev-lang/python-2.7.11-r2 ~amd64


But I am still not having success here:

Code:
# emerge -a  app-eselect/eselect-python =dev-lang/python-3.5.1-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ~] dev-lang/python-3.5.1-r2 [2.7.10-r1, 3.4.3] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst"
[ebuild     U ~] dev-lang/python-exec-2.1 [2.0.1-r1]
[ebuild     U ~] app-eselect/eselect-python-20151117-r2 [20111108]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/certifi-2015.9.6.2:0/0::gentoo, installed)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-desktop-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-menus-1.12.0-r1:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.9.6.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/newt-0.52.15:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/xpyb-1.3.1-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-applets-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (x11-misc/mozo-1.12.0:0/0::gentoo-mate-112, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-python
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.5.1-r2:3.5/3.5m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-lang/python-3.5.1-r2::gentoo
# required by =dev-lang/python-3.5.1-r2 (argument)
=app-eselect/eselect-python-20151117-r2 ~amd64
# required by dev-python/pygtksourceview-2.10.1-r1::gentoo
# required by dev-vcs/git-2.4.10::gentoo[python,gtk]
# required by @selected
# required by @world (argument)
=dev-lang/python-exec-2.1 ~amd64
# required by =dev-lang/python-3.5.1-r2 (argument)
=dev-lang/python-3.5.1-r2 ~amd64


Would you like to add these changes to your config files? [Yes/No]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8566
Location: Austria

PostPosted: Sun Jan 24, 2016 12:43 pm    Post subject: Reply with quote

Since you don't do a world update here, the older python versions are not considered for upgrade. So you need to manually add them to your emerge command to solve the conflict, or update world first, and then emerge python-3.5. Whatever you prefer.

Code:
# emerge -a  app-eselect/eselect-python =dev-lang/python-3.5.1-r2

^ However, do you really want to have eselect-python and python in your world file? Better add --oneshot (-1) to your emerge if you want to upgrade dependencies.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
oz_tiram
n00b
n00b


Joined: 31 May 2015
Posts: 44

PostPosted: Sun Jan 24, 2016 12:51 pm    Post subject: Reply with quote

I am walking in circles here. I added the packages manually, but still no success:
Code:

# emerge -a  app-eselect/eselect-python =dev-lang/python-3.5.1-r2 dev-lang/python-exec =dev-lang/python-2.7.11-r2 =app-eselect/eselect-python-20151117-r2  =dev-lang/python-3.4.3-r7 =dev-lang/python-exec-2.1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-lang/python-2.7.11-r2 [2.7.10-r1] USE="-libressl%"
[ebuild     U ~] dev-lang/python-3.4.3-r7 [3.4.3] USE="-libressl%"
[ebuild  NS   ~] dev-lang/python-3.5.1-r2 [2.7.10-r1, 3.4.3] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst"
[ebuild     U ~] dev-lang/python-exec-2.1 [2.0.1-r1]
[ebuild     U ~] app-eselect/eselect-python-20151117-r2 [20111108]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8566
Location: Austria

PostPosted: Sun Jan 24, 2016 12:51 pm    Post subject: Reply with quote

Code:
Would you like to merge these packages? [Yes/No]


(portage is now able to auto-resolve the block, that's why you see the lowercase '[blocks b ]')

Please add --oneshot to your command, you are polluting your world file otherwise.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
oz_tiram
n00b
n00b


Joined: 31 May 2015
Posts: 44

PostPosted: Sun Jan 24, 2016 12:55 pm    Post subject: Reply with quote

So if it would no be able to resolve the block, what would I see?

(open rant: this isn't user friendly, that portage isn't saying itself /close rant)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8566
Location: Austria

PostPosted: Sun Jan 24, 2016 12:56 pm    Post subject: Reply with quote

Erm, why don't you just hit y to emerge? It works! :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
oz_tiram
n00b
n00b


Joined: 31 May 2015
Posts: 44

PostPosted: Sun Jan 24, 2016 12:58 pm    Post subject: Reply with quote

because I am a clueless noob :-P and I want to understand what is going on here.

I found out, in the man page of emerge:

Quote:
B blocked by another package (unresolved conflict)
b blocked by another package (automatically resolved conflict)



Phew, now I will hit enter!

Danke, thanks for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum