Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
's' key not working with new Gentoo install. [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Tue Dec 29, 2015 5:55 am    Post subject: 's' key not working with new Gentoo install. [solved] Reply with quote

's' key not working with GDM install.
The 's" works from terminal on boot but not after a startx is issued and Gnome(GDM) starts.
Gnome3 + systemd

I copied all the s's

- switched keyboards
- set locale to "US"


Note: terminal is not working after set the keyboard to "US"
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Fri Jan 01, 2016 1:51 pm; edited 6 times in total
Back to top
View user's profile Send private message
valentind
n00b
n00b


Joined: 28 Dec 2015
Posts: 4

PostPosted: Tue Dec 29, 2015 1:29 pm    Post subject: Reply with quote

I also have problem on an old install that I have just upgraded. 's' key does not work in GDM. Work-around is to use "alt-s" which types a s. In Gnome 3, both 's' and 'l' keys are bound respectively to opening the on-screen keyboard, and opening help. Work-around is to bind those actions to other short cuts.
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Tue Dec 29, 2015 1:54 pm    Post subject: Reply with quote

valentind wrote:
I also have problem on an old install that I have just upgraded. 's' key does not work in GDM. Work-around is to use "alt-s" which types a s. In Gnome 3, both 's' and 'l' keys are bound respectively to opening the on-screen keyboard, and opening help. Work-around is to bind those actions to other short cuts.


Thanks for the line. alt-s did not work for me.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
valentind
n00b
n00b


Joined: 28 Dec 2015
Posts: 4

PostPosted: Tue Dec 29, 2015 4:12 pm    Post subject: Reply with quote

Caps-Lock on, and shift-s?
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Tue Dec 29, 2015 4:19 pm    Post subject: Reply with quote

valentind wrote:
Caps-Lock on, and shift-s?


That worked. What type of bug is this?
Thanks
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Tue Dec 29, 2015 6:08 pm    Post subject: Reply with quote

deleted this post - not relevant
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Fri Jan 01, 2016 1:50 pm; edited 2 times in total
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Tue Dec 29, 2015 6:33 pm    Post subject: Reply with quote

deleted this post - not relevant
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Fri Jan 01, 2016 1:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Thu Dec 31, 2015 5:32 am    Post subject: Reply with quote

valentind wrote:
I also have problem on an old install that I have just upgraded. 's' key does not work in GDM. Work-around is to use "alt-s" which types a s. In Gnome 3, both 's' and 'l' keys are bound respectively to opening the on-screen keyboard, and opening help. Work-around is to bind those actions to other short cuts.


How did you bind 's' to another short cut? Is it in gmome>settings>keyboard?
I can not find what s is assigned to.

Took me a while to catch on to your post. I'm thinking about re-inStalling.

Shift S workS for me.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Thu Dec 31, 2015 12:55 pm    Post subject: Reply with quote

Starting with gnome-base/gnome-session-2.26.2, users will need to prepend the XDG_MENU_PREFIX variable to get the GNOME menus when using the ~/.xinitrc method to start the desktop. If ~/.xinitrc is not being used it will be handled automatically; no additional configuration is needed.

user $sed -i '1i\export XDG_MENU_PREFIX=gnome-' ~/.xinitrc

[solved]:
I removed :

Code:
user $sed -i '1i\export XDG_MENU_PREFIX=gnome-' ~/.xinitrc


from .xinitrc
\Now I need to reset all the hacking I did on keyboard shortcuts.
Furthermore I need to disable the ScreenKeyboard


!!! now the 'o' key does not work!
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Thu Dec 31, 2015 10:56 pm    Post subject: Reply with quote

- reinstalled gnome3

- same results

- 's' key does not work
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Fri Jan 01, 2016 1:54 pm    Post subject: Reply with quote

[solved]

mv 00-keyboard.conf out of /etc/X11/xorg.conf.d/
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1717

PostPosted: Fri Jan 01, 2016 1:58 pm    Post subject: Reply with quote

And what the content of this file was?
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1079
Location: Tri-Cities, WA USA

PostPosted: Fri Jan 01, 2016 5:59 pm    Post subject: Reply with quote

szatox wrote:
And what the content of this file was?

I'm running systemd on this system.

# more 00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "us"
EndSection
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
doug_ca
n00b
n00b


Joined: 18 Feb 2016
Posts: 4

PostPosted: Thu Feb 18, 2016 4:00 am    Post subject: Reply with quote

I have tried the above suggestions
- assigning the on screen keyboard shortcut (in Settings -> Keyboard -> Shortcuts) to other values, as well as disabling them
- removing the XDG_MENU_PREFIX variable from ~/.xinitrc
- moving 00-keyboard.conf out of /etc/X11/xorg.conf.d/

however I still have to use caps-shift to type "s" in Gnome. I should note that i did not have GDM installed when trying these, but have since installed it hoping it might resolve the problem - it did not.

Would anyone be able to offer other suggestions?
Back to top
View user's profile Send private message
flex1911
n00b
n00b


Joined: 23 Feb 2016
Posts: 1
Location: Волгоград

PostPosted: Tue Feb 23, 2016 8:43 pm    Post subject: Reply with quote

doug_ca wrote:
I have tried the above suggestions
- assigning the on screen keyboard shortcut (in Settings -> Keyboard -> Shortcuts) to other values, as well as disabling them
- removing the XDG_MENU_PREFIX variable from ~/.xinitrc
- moving 00-keyboard.conf out of /etc/X11/xorg.conf.d/

however I still have to use caps-shift to type "s" in Gnome. I should note that i did not have GDM installed when trying these, but have since installed it hoping it might resolve the problem - it did not.

Would anyone be able to offer other suggestions?


Also have that problem on my Gentoo desktop, i've fixed that in shell by rebinding functions, but it is not working in gdm.
Back to top
View user's profile Send private message
doug_ca
n00b
n00b


Joined: 18 Feb 2016
Posts: 4

PostPosted: Fri Feb 26, 2016 12:28 am    Post subject: 's' key not working with Gnome & GDM Reply with quote

I recently emerged to 3.18 from 3.16 (gnome, gdm, etc.) and am still having this problem. Also, the "r" key does not work at the login screen - but works once logged in.
Back to top
View user's profile Send private message
doug_ca
n00b
n00b


Joined: 18 Feb 2016
Posts: 4

PostPosted: Sat Feb 27, 2016 3:09 am    Post subject: Reply with quote

I found that disabling media-keys as suggested here

https://forums.gentoo.org/viewtopic-t-1034240.html

worked for me. The "s" key can now be used in Gnome. To save future readers a click, the solution is to use gnome-base/dconf-editor to modify

org/gnome/settings-daemon/plugins/media-keys/active

to false. There is also a bug for this issue here:

https://bugs.gentoo.org/show_bug.cgi?id=560346
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum