Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox hwaccel flag and ATI-drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
esperto
Apprentice
Apprentice


Joined: 27 Dec 2004
Posts: 156
Location: Brazil

PostPosted: Wed Dec 23, 2015 5:04 pm    Post subject: Firefox hwaccel flag and ATI-drivers Reply with quote

Hi all,

A few weeks ago I've updated from firefox 42 to 42-r2 and everything went to shit, firefox window was slow to update itself, got blank screens and had to click outside the window every time I'd to scroll or clicked a link to force a redraw.
After several tests yesterday I removed the hwaccel flag and it is back to normal again, does anyone knows how can this be solved (have the hardware accelleration back)?

I'm on kernel 3.18.9 (gentoo-source) and ati-drivers version 15.9-r1, my graphics card is a HD7770.

thx
Rafael
_________________
nasci pelado, careca e sem dente, o que vier é lucro
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 77

PostPosted: Thu Dec 24, 2015 9:46 am    Post subject: Reply with quote

I'm experiencing the same issue also with random crashes on some scripts with embedded flash/html5 youtube videos. My solution and to keep hw acceleration too was to toggle "webgl.disabled" flag on in about:config. Previously I couldn't access the about:support tab to check for hw acceleration which now is OK.
Good luck!
Back to top
View user's profile Send private message
esperto
Apprentice
Apprentice


Joined: 27 Dec 2004
Posts: 156
Location: Brazil

PostPosted: Thu Dec 24, 2015 11:36 am    Post subject: Reply with quote

Just tried toggling webgl.disable and recompiled with hwaccel flag on, didn't work, same as before.
This is strange.
Where can I find 42-r2 changelog? maybe I can find out what have changed.
_________________
nasci pelado, careca e sem dente, o que vier é lucro
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 769

PostPosted: Thu Jan 14, 2016 5:49 am    Post subject: Reply with quote

Hardware acceleration never worked in Firefox with ati-drivers. hwaccel flag just force-enables it, but the result is unusable browser. If you want hardware acceleration, switch to open source drivers or use Chome (it supports hardware acceleration with ati-drivers).
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Thu Jan 14, 2016 1:29 pm    Post subject: Reply with quote

unK wrote:
Hardware acceleration never worked in Firefox with ati-drivers. hwaccel flag just force-enables it, but the result is unusable browser. If you want hardware acceleration, switch to open source drivers or use Chome (it supports hardware acceleration with ati-drivers).

Chrome was my option. Works just perfect. ... after 10 or more years with Firefox
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum