Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing plasma-meta-5.5.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Mon Dec 21, 2015 1:36 am    Post subject: Installing plasma-meta-5.5.1 Reply with quote

Good day everyone,

I've successfully installed another Gentoo base system and X server. I now want to install latest KDE Plasma 5.5.1. However, right from fresh install, I am getting the following error:

https://bpaste.net/show/98eaf3eb8103

I always get confused with these package error blocks. I tried using USE="qt3support bindist -graphite -qt5" custom flags but I just keep being asked to /etc/portage/package.use/iputils and after I execute "etc-update" nothing changes.

I am guessing what to do at this point anyways. I also tried "--backtrack=100" option and basically grasping for straws at this point because I never understand package conflict issues too well and how to resolve them. I did install qtcore 5.5.1 hoping to force using qt5 but to no avail - I keep getting package conflict issue.

Could somebody please suggest what I should do to proceed with this KDE 5.5.1 installation?

And these are the global USE flags I am using:

Code:

USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 amr audiofile avi -bindist bittorrent bluetooth bzip2 cairo cdda cddb cdparanoia cdr chm cli consolekit cpudetection cracklib berkdb crypt css cue cups cxx dbus djvu dri dv dvd dvdr dvdread ebook encode exif faac ffmpeg flac flash foomaticdb fortran ftp gd gdbm gif gphoto2 gpm graphite gtk iconv imlib id3tag ieee1394 imagemagick ios ipod ipv6 irc jabber jingle jpeg jpeg2k libnotify libwww logrotate lua lua-cairo lua-imlib lzo mad matroska mbox mikmod mmx mmxext mng modules mp3 mpeg mplayer multilib musepack ncurses networkmanager nfs nls nptl nsplugin ogg oggvorbis openal opencore-amr openexr opengl openmp oscar pam pcre pdf png policykit portaudio ppp pulseaudio qt5 -qt3support -qt4 quicktime raw rdesktop readline real samba scanner sdl semantic-desktop session smp speex spell srt sse sse2 sse3 sse4.1 sse4.2 sse4a sse5 ssl ssse3 svg tcpd tga theora tiff truetype udev unicode usb userlocales v4l v4l2 vaapi vcd vdpau vhosts vim-syntax vorbis wavpack webkit webp wimax win32codecs wmf wxwindows x264 xanim xcomposite xinerama xpm xv xvid xvmc zlib video extraengine sasl icu -libproxy"

Thank you kindly,
Victor.
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Mon Dec 21, 2015 2:30 am    Post subject: Reply with quote

The following url with my post should help with some of your issues:
https://forums.gentoo.org/viewtopic-t-1033066-highlight-.html
1. It appears that you are using Gentoo amd64 so the QT5 solution should work.
2. Is dbus running?
3. I didn't set bindist.
4. You can use my post to basically install KDE5 (plasma 5, frameworks and KDE-apps).
Alot of your problems should get solved.
Back to top
View user's profile Send private message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Mon Dec 21, 2015 5:51 am    Post subject: Reply with quote

davidbrooke wrote:
The following url with my post should help with some of your issues:
https://forums.gentoo.org/viewtopic-t-1033066-highlight-.html
1. It appears that you are using Gentoo amd64 so the QT5 solution should work.
2. Is dbus running?
3. I didn't set bindist.
4. You can use my post to basically install KDE5 (plasma 5, frameworks and KDE-apps).
Alot of your problems should get solved.


Thank you for this information. I followed all the steps in that thread (installed layman etc) but still was getting package blocks. I then installed each package showing as "installed" in the list and used these emerge use flags:

Code:

USE="qt3support bindist -qt4"


and was successfully able to launch plasma 5.5.1 compilation process :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum