Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Very long bringing up net.eth0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Yarra
n00b
n00b


Joined: 09 Apr 2011
Posts: 9

PostPosted: Sat Dec 19, 2015 1:31 pm    Post subject: Very long bringing up net.eth0 Reply with quote

After update to udev-225 bringing net.eth0 is very long. About 1 miunte.

How to fix it?

Code:
 cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
#mac_eth0="00:22:15:0B:18:FD"
config_eth0="192.168.2.2 netmask 255.255.255.0"
#gateway_eth0="192.168.2.1"
routes_eth0="default via 192.168.2.1"
dns_servers="192.168.2.1"
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Sun Dec 20, 2015 7:00 am    Post subject: Reply with quote

Can you post the relevant of log?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42559
Location: 56N 3W

PostPosted: Sun Dec 20, 2015 8:53 am    Post subject: Reply with quote

Yarra,

I'll guess that you have a r8169 card that can benefit from firmware.
The driver waits for 60 sec if the firmware cannot be found.

dmesg will show the pause and the firmware load failure.
Please put your dmesg on a pastebin and post a link to it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Yarra
n00b
n00b


Joined: 09 Apr 2011
Posts: 9

PostPosted: Sun Dec 20, 2015 10:15 am    Post subject: Reply with quote

This delay did not appear until after the upgrade.


dmesg
rc.log
emerge --info
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42559
Location: 56N 3W

PostPosted: Sun Dec 20, 2015 2:00 pm    Post subject: Reply with quote

Yarra,

You do have a r8169 network card as eth0 but its not the cause of the delay.
Indeed, there are no delays to be seen in dmesg, nor are there any attempts to load firmware.

Your dmesg is truncated. I would expect to find a line like my
Code:
[   12.262753] r8169 0000:0a:06.0 eth0: link up
but its missing.
Maybe its your very old kernel?
Code:
Linux version 3.3.8-gentoo


If you have been updating your kernel, the newer kernel(s) are not being used.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum