Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
connman adding 2nd IP to eth0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
NTICompass
Apprentice
Apprentice


Joined: 11 Jun 2008
Posts: 171
Location: /home/nticompass/

PostPosted: Fri Dec 18, 2015 5:58 am    Post subject: connman adding 2nd IP to eth0 Reply with quote

I have Enlightenment E19 installed. In order to get a network icon in the taskbar, I installed net-misc/connman, net-misc/econnman (from 'sera' overlay).

I noticed that now, my eth0 has 2 IPs:

Code:

nticompass@hypercube ~ % ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:30:1b:bd:11:25 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet 192.168.1.122/24 brd 192.168.1.255 scope global secondary eth0
       valid_lft forever preferred_lft forever


I'm wondering if this is because /etc/init.d/connman and /etc/init.d/net.eth0 are assigning an IP address. How do I fix this and only have one IP assigned?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1762
Location: United Kingdom

PostPosted: Fri Dec 18, 2015 12:31 pm    Post subject: Reply with quote

I have not used ConnMan for a few years, but I assume it is subject to the same requirement as that other well-known network manager, NetworkManager, namely that you should not have multiple network management services running concurrently. So I suppose you would need to disable all net.* services from starting automatically:

https://wiki.gentoo.org/wiki/NetworkManager#Service

NetworkManager - Gentoo Wiki wrote:
Remove any existing network management services (if installed):
root # for service in $(rc-update show default | grep 'net\.' | awk '{ print $1 }'); do rc-update del $service default; done

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum