Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libnl-3.2.27 breaks networking [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Tue Dec 15, 2015 11:25 pm    Post subject: libnl-3.2.27 breaks networking [Solved] Reply with quote

Last night I merged world in my Stable amd64 installation and libnl was upgraded from 3.2.26 to 3.2.27. Today no networks were shown in the NetworkManager front-end (plasma-nm) in KDE 4 after I logged in, and NetworkManager had crashed and would always crash if I re-started it. I downgraded libnl to 3.2.26 and all was well again. Anyone else seeing this problem?


EDIT (12 Jan., 2016): The problem went away after I 'upgraded world' plus manually installed upgrades to a couple of NetworkManager packages. As far as I can tell, other than libnl-3.2.27, the following three packages are the only new versions of network-related packages that were installed:

net-misc/networkmanager-1.0.10
net-libs/libnm-qt/0.9.8.4
net-dns/bind-tools-9.10.3_p2

I don't think Version 9.10.3_p2 of bind-tools made any difference (it was pulled in by the world update a week ago), so I suspect the two NetworkManager packages I manually installed today are what finally helped.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum