Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Problems with eselect-python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Dec 14, 2015 9:00 am    Post subject: [solved] Problems with eselect-python Reply with quote

Hi,
while updating my system I got an blockage of python due to eselect-python, I tried to fix it but it still won't work. Here is the output:
Code:
# emerge python
Calculating dependencies... done!
[ebuild     U ~] dev-lang/python-3.4.3-r5 [3.4.3-r2]
[ebuild  N    ~] app-eselect/eselect-python-20151117-r1
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-python-20151117-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r5:3.4/3.4m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mpmath-0.19:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.9.6.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-tex/sage-latex-2.3.4:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/blinker-1.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/bottleneck-0.8.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/lxml-3.4.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/backports-abc-0.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cython-0.23:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?,threads(+)] (>=dev-lang/python-2.7.5-r2:2.7[threads(+)]) required by (dev-python/matplotlib-1.4.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/speaklater-1.3-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/talloc-2.1.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/enum34-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/futures-3.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numexpr-2.4.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-0.10.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-silk-0.2:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (x11-misc/alacarte-3.11.91:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/alabaster-0.7.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (app-portage/layman-2.0.0-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (app-admin/system-config-printer-1.4.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/xpyb-1.3.1-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/backports-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-editors/atom-1.0.3:0/0::aegypius, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipaddress-1.0.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/jsonschema-2.3.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-web-14.0.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/sphinx-1.3.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyzmq-14.4.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/py-1.4.30:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cvxopt-1.1.7:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/Babel-2.1.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-portage/cpuinfo2cpuflags-1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/zope-interface-4.1.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-text/gnome-doc-utils-0.20.10-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (net-libs/gupnp-0.20.14:0/4::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cffi-1.2.1:0/1.2.1::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ssl] required by (sci-mathematics/sage-notebook-0.11.4-r4:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/chardet-2.2.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-openid-1.2.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/gtk-builder-convert-2.24.28:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/docutils-0.12:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite] required by (dev-python/rpy-2.7.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxdg-0.25-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/python-dateutil-2.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pytables-3.1.1-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/jinja-2.7.3:0/0::gentoo, installed)
    =dev-lang/python-2.7* required by (dev-libs/keybinder-0.3.0-r200:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (media-video/totem-3.16.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/twisted-core-14.0.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/webassets-0.10.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libpeas-1.14.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/service_identity-14.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sympy-0.7.6.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-oldsessions-0.10:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[readline,sqlite,threads(+)] required by (dev-python/ipython-3.2.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/itsdangerous-0.24:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[sqlite?] (>=dev-lang/python-2.7.5-r2:2.7) required by (dev-python/python-openid-2.2.5-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygments-2.0.2-r1:0/0::gentoo, installed)
    dev-lang/python:2.7 required by (dev-util/atom-shell-0.22.3-r3:0/22::aegypius, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/terminado-0.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (www-servers/tornado-4.2.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/networkx-1.10-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/newt-0.52.15:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/webapp-config-1.54-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/markupsafe-0.23:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/requests-2.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ptyprocess-0.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/gnome-python-base-2.28.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-i18n/ibus-1.5.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyparsing-2.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?] (>=dev-lang/python-2.7.5-r2:2.7) required by (dev-python/pyopengl-3.0.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyopenssl-0.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (gnome-extra/gnome-tweak-tool-3.16.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycups-1.9.72:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-mail-14.0.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cryptography-1.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-backports_abc-0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/decorator-4.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[readline,sqlite] required by (sci-mathematics/sage-6.8-r2:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pandas-0.17.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/anjuta-3.16.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycurl-7.19.3.1-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/wxpython-3.0.2.0:3.0/3.0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/libixion-0.9.0:0/0.10::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyatspi-2.16.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/snowballstemmer-1.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-babel-0.8-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mistune-0.7.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (dev-vcs/mercurial-3.3.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?,threads(+)] (>=dev-lang/python-2.7.5-r2:2.7[threads(+)]) required by (dev-python/pillow-2.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/xxdiff-4.0_beta1_p20110426:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pkgconfig-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/libproxy-0.4.11-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sip-4.16.9:0/11::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-irc/telepathy-idle-0.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-util/atom-shell-0.22.3-r3:0/22::aegypius, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (media-gfx/inkscape-0.48.5-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/werkzeug-0.9.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ply-3.6-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplegeneric-0.8.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-modules-0.0.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/backports-ssl-match-hostname-3.4.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycrypto-2.6.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/singledispatch-3.4.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/twisted-names-14.0.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/gexiv2-0.10.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pexpect-3.3-r1:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pytz-2015.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (sci-libs/scipy-0.15.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/flask-autoindex-0.5:0/0::sage-on-gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/characteristic-14.3.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-futures-0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/simplejson-3.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-0.1.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/sphinx_rtd_theme-0.1.9:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/gconf-python-2.28.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


emerge --info:
Code:
# emerge --info
Portage 2.2.20.1 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.21-r1, 4.0.9-gentoo x86_64)
=================================================================
System uname: Linux-4.0.9-gentoo-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.2
KiB Mem:    16433856 total,   1339176 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of repository gentoo: Mon, 14 Dec 2015 07:00:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r2::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

aegypius
    location: /var/lib/layman/aegypius
    masters: gentoo
    priority: 50

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bitmap-fonts bluetooth branding bzip2 cairo cdda cdr cleartype cli colord corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif git glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gzip iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mulitilib multilib nautilus ncurses nls nptl nsplugin ogg opengl openmp openmpi pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline scanner sdl seccomp session spell sse sse2 ssl startup-notification subversion svg systemd tcpd threads tiff tracker truetype type1 udev udisks unicode upower usb vim-syntax vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python3_4 python2_7" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="3.4 2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Any ideas what the issue is?


Last edited by chi86 on Thu Dec 17, 2015 7:49 am; edited 1 time in total
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1407

PostPosted: Mon Dec 14, 2015 10:53 am    Post subject: Reply with quote

in your
/etc/portage/package.accept_keywords/package.keywords wrote:

=app-eselect/eselect-python-20151117-r1 ~amd64
dev-lang/python:2.7


Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Thu Dec 17, 2015 7:49 am    Post subject: Reply with quote

Marlo wrote:
in your
/etc/portage/package.accept_keywords/package.keywords wrote:

=app-eselect/eselect-python-20151117-r1 ~amd64
dev-lang/python:2.7


Ma

Thx! that worked!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum