Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
post kwin 5.5.0 which forced wayland results in black screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Thu Dec 10, 2015 4:35 pm    Post subject: post kwin 5.5.0 which forced wayland results in black screen Reply with quote

Greetings,

so I've upgraded kde to 5.5.0 which resulted in kwin forcing wayland.
now whenever I log into kde, I'm greeted with black screen.
how can I debug this?

Thanks.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Thu Dec 10, 2015 5:45 pm    Post subject: Reply with quote

KWin does not "force wayland", although it does use some libwayland/kwayland stuff. You should still start an X session as normal.
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Thu Dec 10, 2015 10:02 pm    Post subject: Reply with quote

kensington wrote:
KWin does not "force wayland", although it does use some libwayland/kwayland stuff. You should still start an X session as normal.

by "force" I mean pulls wayland.

when I try to login using the plasma profile, it doesn't even logs in.
when I select the plasma wayland, I end up with black screen.

I use latest sddm.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Dec 11, 2015 4:54 pm    Post subject: Reply with quote

Is there any information in the sddm, X, or .xsession-errors logs? Does it launch correctly outside of sddm?
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Sat Dec 12, 2015 5:30 pm    Post subject: Reply with quote

don't know what happened but now it starts ok, it's a shame the krunner crushes upon login.
closing.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Dec 12, 2015 9:53 pm    Post subject: Reply with quote

krunner crashes with baloo file search activated or deactivated?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Mon Dec 14, 2015 6:33 pm    Post subject: Reply with quote

from what I can see baloo is disabled.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Dec 14, 2015 6:35 pm    Post subject: Reply with quote

Does it resemble the following bug, in case you got a crash dump?

https://bugs.kde.org/show_bug.cgi?id=353342
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Tue Dec 15, 2015 8:49 pm    Post subject: Reply with quote

genstorm wrote:
Does it resemble the following bug, in case you got a crash dump?

https://bugs.kde.org/show_bug.cgi?id=353342


nope, as said, my issue is with krunner but latest update seems for fix it.
got one plasma crash on the other hand but it was only once.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum