Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem updating Xorg-server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Tue Dec 08, 2015 9:13 pm    Post subject: Problem updating Xorg-server Reply with quote

Hello everyone!!
I'm quite new in Gentoo so I'm not really used to all the options portage gives me so I prefer to ask here before doing something wrong.

I'm having some problems updating xorg from version 1.16.4 as it's blocked by the package xf86-video-modesetting. So here comes the question:
What should I do to update my system?

Should I mask xorg-server? Or is it better to force the update?

If I mask xorg-server will I be able to unmask it later in order to update it or will I be forever with the version 1.16.4?

If you need more info I will post it here ASAP

Thank you very much in advance :D
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Dec 08, 2015 10:04 pm    Post subject: Reply with quote

xorg-server-1.17 incorporates what was previously xf86-video-modesetting, so the packages cannot be installed at the same time.

Unless you have explicitly installed xf86-video-modesetting and thus the package is in @world, emerge should auto-resolve the blocker (denoted by a small b instead of capital B in the emerge output).

If the package is in @world, "emerge --deselect xf86-video-modesetting" will remove it from there.
Back to top
View user's profile Send private message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Tue Dec 08, 2015 10:57 pm    Post subject: Reply with quote

chithanh wrote:
xorg-server-1.17 incorporates what was previously xf86-video-modesetting, so the packages cannot be installed at the same time.

Unless you have explicitly installed xf86-video-modesetting and thus the package is in @world, emerge should auto-resolve the blocker (denoted by a small b instead of capital B in the emerge output).

If the package is in @world, "emerge --deselect xf86-video-modesetting" will remove it from there.


Understood! Thank you very much!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum