Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need advice get past kde4 blockers of kde5 stuff [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 819
Location: Alaska

PostPosted: Tue Dec 08, 2015 3:13 am    Post subject: need advice get past kde4 blockers of kde5 stuff [solved] Reply with quote

I've been passively letting portage manage my slow upgrade to kde5. But I'm starting to get blockers I'm not sure how to deal with. I tried unmerging a few and they still show up as blockers.. I think because I have been using kde4 sets. The files in /etc/portage/sets/ such as kde-baseapps have things like
Code:
# Autogenerated by regenerate-files, DO NOT EDIT.
# move kde-base/dolphin kde-apps/dolphin
kde-apps/dolphin:4
and I think that :4 is what is giving the blockers power.

Here's the type of blockers:
Code:
[blocks B      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.08.3)
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.16.0)
[blocks B      ] kde-apps/print-manager:4 ("kde-apps/print-manager:4" is blocking kde-apps/print-manager-15.08.3-r1)
[blocks B      ] kde-apps/kdesu[handbook] ("kde-apps/kdesu[handbook]" is blocking kde-plasma/kde-cli-tools-5.4.3)
[blocks B      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.08.3)

Total: 64 packages (29 upgrades, 1 downgrade, 25 new, 8 in new slots, 1 reinstall, 6 uninstalls), Size of downloads: 190,320 KiB
Conflict: 11 blocks (5 unsatisfied)

  (kde-apps/dolphin-15.08.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/dolphin-15.08.3:5 required by (kde-apps/dolphin-plugins-15.08.3:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/dolphin required by @kde-baseapps

  (kde-apps/print-manager-4.14.3:4/4.14::gentoo, installed) pulled in by
    kde-apps/print-manager:4 required by @kdeutils
    >=kde-apps/print-manager-4.14.3:4[aqua=] (>=kde-apps/print-manager-4.14.3:4[-aqua]) required by (kde-apps/kdeutils-meta-4.14.3:4/4::gentoo, installed)

  (kde-apps/dolphin-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/dolphin-4.14.3:4[aqua=] (>=kde-apps/dolphin-4.14.3:4[-aqua]) required by (kde-apps/kdebase-meta-4.14.3:4/4::gentoo, installed)

  (kde-apps/print-manager-15.08.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/print-manager required by @selected

  (kde-apps/kdesu-15.08.3:4/15.08::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdesu-4.14.3:4[aqua=] (>=kde-apps/kdesu-4.14.3:4[-aqua]) required by (kde-apps/kdebase-runtime-meta-4.14.3:4/4::gentoo, installed)
    kde-apps/kdesu:4 required by @kdebase-runtime
    >=kde-apps/kdesu-4.14.3:4[aqua=] (>=kde-apps/kdesu-4.14.3:4[-aqua]) required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=kde-apps/kdesu-4.14.3:4[aqua=] (>=kde-apps/kdesu-4.14.3:4[-aqua]) required by (kde-apps/kdepasswd-15.08.3:4/15.08::gentoo, installed)

  (kde-base/baloo-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-base/kdepim-common-libs-4.14.10:4/4.14::gentoo, installed)
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
    >=kde-base/baloo-4.12.0:4[aqua=] (>=kde-base/baloo-4.12.0:4[-aqua]) required by (media-gfx/digikam-4.14.0:4/4::gentoo, installed)
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo, installed)
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/dolphin-4.14.3:4/4.14::gentoo, installed)



So in my /var/lib/portage/world_sets I have:
Code:
@kdeadmin
#@kdeartwork
@kdebase
@kdegraphics
@kdemultimedia
@kdeutils


I could edit the /etc/portage/sets/ files and take out the :4 but that probably isn't what I should do. Curious if somewhat could point me in the right direction.

thx, JD


Last edited by hunky on Tue Dec 08, 2015 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Dec 08, 2015 8:46 am    Post subject: Re: need advice on getting past kde4 blockers of kde5 stuff Reply with quote

You can't use a set for kde-applications right now. The one you are currently using is coming from the overlay apparently, unless you copied it, and will conflict with kde-applications-15.08 upgrades (especially because of the slot definition). Use meta ebuilds instead.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 819
Location: Alaska

PostPosted: Tue Dec 08, 2015 4:51 pm    Post subject: Reply with quote

thanks genstorm,

I laid in bed last night thinking that would be a solution so nice to be confirmed. So I removed the kde sets and still getting a blocker with baloo.

Baloo-4.14.3 is being pulled in by digikam-4.14.0 and kdepim-common-libs-4.14.10, blocking baloo-5.16.0. I use digikam - is it dependent on that version of baloo? If so, I presume I will need to mask all the upgrades until digikam goes to 5?

cheers, JD
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 819
Location: Alaska

PostPosted: Tue Dec 08, 2015 5:26 pm    Post subject: Reply with quote

Well, I added -nepomuk and -semantic-desktop to make.conf and it ended the baloo dependency and cut the upgrades from 190MB down to 40MB. So for now that might be a solution. I don't mind having baloo around though so will have to remember what I did. /jd
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Tue Dec 08, 2015 8:42 pm    Post subject: Reply with quote

I'm also sitting with this baloo blocker, are there any other options? I use Kmail and AFAIK the search functionality relies on baloo and semantic, and I need to have that around... :-)

thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Dec 08, 2015 9:02 pm    Post subject: Reply with quote

First of all, if you are going to move to plasma-5 and kde-applications-15.xx, it is a very good idea to switch to the plasma profile.

Second, if you set USE=minimal for kde-base/baloo (which is done by plasma profile automatically), it will no longer block the newer kde-frameworks/baloo.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Tue Dec 08, 2015 9:53 pm    Post subject: Reply with quote

genstorm wrote:
First of all, if you are going to move to plasma-5 and kde-applications-15.xx, it is a very good idea to switch to the plasma profile.

Second, if you set USE=minimal for kde-base/baloo (which is done by plasma profile automatically), it will no longer block the newer kde-frameworks/baloo.


1. Um, I'm kinda letting portage take care of that for me ... seems to be a "migration in progress" ... I started out running a Stable system, but portage wanted this and that and the other as ~amd64 so I have quite a collection on ~amd64 already, and the rest on stable.

AFAIK plasma-5 is not quite ready for Prime Time? Hence I'm letting portage decide when to move what.

Not quite sure about setting to "plasma profile" ... is that one of those one-way trap doors?

2. let me try the USE=minimal trick ... it worked before on some things ...

This bunch that I need to do are intertwined like a maze in Zork:

Code:

trooper 2new # emerge -auvDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] kde-frameworks/baloo-5.16.0:5/5.16::gentoo  USE="-debug -doc {-test}" 174 KiB
[ebuild  NS   ~] kde-apps/libkomparediff2-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-debug {-test}" 56 KiB
[uninstall     ] kde-apps/libkomparediff2-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug {-test}"
[blocks b      ] kde-apps/libkomparediff2:4 ("kde-apps/libkomparediff2:4" is blocking kde-apps/libkomparediff2-15.08.3)
[ebuild  NS   ~] kde-apps/kompare-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="handbook -debug" 337 KiB
[uninstall     ] kde-apps/kompare-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-apps/kompare:4 ("kde-apps/kompare:4" is blocking kde-apps/kompare-15.08.3)
[ebuild  NS   ~] kde-apps/baloo-widgets-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-debug {-test}" 56 KiB
[uninstall     ] kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.08.3)
[ebuild  N    ~] kde-apps/dolphin-15.08.3:5::gentoo  USE="handbook semantic-desktop -debug {-test} (-thumbnail)" 642 KiB
[ebuild  NS   ~] kde-apps/dolphin-plugins-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="git -bazaar -debug -dropbox -subversion" 58 KiB
[uninstall     ] kde-apps/dolphin-plugins-4.14.3:4/4.14::gentoo  USE="git (-aqua) -bazaar -debug -mercurial -subversion"
[blocks b      ] kde-apps/dolphin-plugins:4 ("kde-apps/dolphin-plugins:4" is blocking kde-apps/dolphin-plugins-15.08.3)
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.16.0)

Total: 6 packages (2 new, 4 in new slots, 4 uninstalls), Size of downloads: 1,321 KiB
Conflict: 5 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-frameworks/baloo-5.16.0:5/5.16::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/baloo-5.14.0:5 required by (kde-apps/dolphin-15.08.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/baloo-5.14.0:5 required by (kde-apps/baloo-widgets-15.08.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/baloo-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-base/kdepim-common-libs-4.14.10:4/4.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

trooper 2new # USE=minimal emerge -auvDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/libsodium-1.0.2:0/13::gentoo  USE="asm minimal* urandom -static-libs" 0 KiB
[ebuild   R    ] dev-util/google-perftools-2.0-r2:0/4::gentoo  USE="debug minimal* -largepages -static-libs {-test}" 0 KiB
[ebuild   R    ] sys-apps/iproute2-3.19.0::gentoo  USE="berkdb iptables ipv6 minimal* -atm (-selinux)" 0 KiB
[ebuild   R    ] media-libs/libsndfile-1.0.26::gentoo  USE="alsa minimal* -sqlite -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] sys-libs/ncurses-5.9-r5:0/5::gentoo  USE="cxx gpm minimal* unicode -ada -debug -doc -profile -static-libs -tinfo -trace" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] dev-lang/spidermonkey-1.8.5-r4:0/mozjs185::gentoo  USE="minimal* -debug -static-libs {-test}" 0 KiB
[ebuild   R    ] x11-base/xorg-server-1.17.4:0/1.17.4::gentoo  USE="ipv6 minimal* nptl suid udev xorg -dmx -doc -glamor -kdrive (-libressl) (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb" 0 KiB
[ebuild   R    ] sys-auth/pambase-20150213::gentoo  USE="consolekit cracklib minimal* nullok sha512 -debug -gnome-keyring -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) -systemd" 0 KiB
[ebuild   R   ~] kde-apps/libkonq-15.08.3:4/15.08::gentoo  USE="minimal* (-aqua) -debug {-test}" 0 KiB
[ebuild  NS   ~] kde-apps/libkomparediff2-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-debug {-test}" 56 KiB
[uninstall     ] kde-apps/libkomparediff2-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug {-test}"
[blocks b      ] kde-apps/libkomparediff2:4 ("kde-apps/libkomparediff2:4" is blocking kde-apps/libkomparediff2-15.08.3)
[ebuild  NS   ~] kde-apps/kompare-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="handbook -debug" 337 KiB
[uninstall     ] kde-apps/kompare-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-apps/kompare:4 ("kde-apps/kompare:4" is blocking kde-apps/kompare-15.08.3)
[ebuild   R    ] net-nds/openldap-2.4.38-r2::gentoo  USE="berkdb crypt gnutls icu ipv6 minimal* perl samba ssl syslog tcpd -cxx -debug -experimental -iodbc -kerberos -odbc -overlays -sasl (-selinux) -slp -smbkrb5passwd" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] virtual/ssh-0::gentoo  USE="minimal*" 0 KiB
[ebuild   R    ] app-arch/tar-1.27.1-r2::gentoo  USE="acl minimal* nls xattr (-selinux) -static" 0 KiB
[ebuild   R    ] app-editors/nano-2.3.6::gentoo  USE="magic minimal* ncurses nls spell unicode -debug -justify -slang" 0 KiB
[ebuild   R    ] dev-util/dialog-1.2.20150920::gentoo  USE="minimal* nls unicode -examples -static-libs" 0 KiB
[ebuild   R    ] www-servers/lighttpd-1.4.35-r1::gentoo  USE="bzip2 gdbm ipv6 ldap minimal* mysql pcre php ssl xattr zlib -doc -fam -kerberos -libev -lua -memcache -mmap -rrdtool (-selinux) {-test} -uploadprogress -webdav" 0 KiB
[ebuild   R    ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="minimal* (-aqua) -debug" 0 KiB
[ebuild  N    ~] kde-frameworks/baloo-5.16.0:5/5.16::gentoo  USE="-debug -doc {-test}" 174 KiB
[ebuild  NS   ~] kde-apps/baloo-widgets-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-debug {-test}" 56 KiB
[uninstall     ] kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.08.3)
[ebuild  N    ~] kde-apps/dolphin-15.08.3:5::gentoo  USE="handbook semantic-desktop -debug {-test} (-thumbnail)" 642 KiB
[ebuild  NS   ~] kde-apps/dolphin-plugins-15.08.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="git -bazaar -debug -dropbox -subversion" 58 KiB
[uninstall     ] kde-apps/dolphin-plugins-4.14.3:4/4.14::gentoo  USE="git (-aqua) -bazaar -debug -mercurial -subversion"
[blocks b      ] kde-apps/dolphin-plugins:4 ("kde-apps/dolphin-plugins:4" is blocking kde-apps/dolphin-plugins-15.08.3)

Total: 22 packages (2 new, 4 in new slots, 16 reinstalls, 4 uninstalls), Size of downloads: 1,321 KiB
Conflict: 4 blocks

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libcdio:0

  (dev-libs/libcdio-0.92:0/15::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libcdio-0.90-r1[-minimal,abi_x86_32(-),abi_x86_64(-)] required by (media-video/vcdimager-0.7.24:0/0::gentoo, installed)
                               ^^^^^^^^                             


Would you like to merge these packages? [Yes/No]


Okay let me run that hope it all works out.... thanks a lot :-)

Cheers,Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Dec 08, 2015 10:10 pm    Post subject: Reply with quote

iandoug wrote:
1. Um, I'm kinda letting portage take care of that for me ... seems to be a "migration in progress" ... I started out running a Stable system, but portage wanted this and that and the other as ~amd64 so I have quite a collection on ~amd64 already, and the rest on stable.

Naturally, don't use plasma profile if you don't upgrade to plasma-5. You won't be happy using kf5-based applications in a kde4-workspace. If you want to 'let portage take care of that', then stay with stable _completely_ - nothing will require ~amd64 packages then.

For the record: Portage only wants 'this and that' as ~amd64 if you personally unmasked ~amd64 stuff - that may or may not require other ~amd64 stuff, naturally, if you defined the unmask without version atom - which is entirely within your own responsibility.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Fri Dec 11, 2015 9:51 pm; edited 3 times in total
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 819
Location: Alaska

PostPosted: Fri Dec 11, 2015 6:37 am    Post subject: Reply with quote

So I went ahead and changed to a plasma desktop, but haven't merged the plasma-meta packages yet. Just still letting portage do with it as it may. Also keeping an eye out on complaints about it - so haven't felt the urge to jump yet. So I've got a bunch of kde5 now, but haven't really noticed any downsides for what I do. Everything is working fine, although I noticed a few of the icons in dolphin went missing but that's no issue for me.. still previews photos and whatnot. So I'm still running kde4 (I have kdelibs-4 installed) and several kde5 apps and frameworks and haven't noticed a downside yet. Your mileage may vary. /jd

PS: thanks genstorm for your patience and willingness to help out. I sure appreciate it and sure others do as well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum