Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo MATE needs *you*
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2251
Location: Germania

PostPosted: Sat Jan 23, 2016 2:21 pm    Post subject: Reply with quote

just in case someone is interested in the problems I faced, I somewhat solved them. see my other post.
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Tue Feb 02, 2016 10:10 am    Post subject: Reply with quote

What needs mate from her mates? Debug? Testers?
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4809
Location: The Peanut Gallery

PostPosted: Tue Feb 02, 2016 4:14 pm    Post subject: Reply with quote

TigerJr wrote:
What needs mate from her mates? Debug? Testers?

Yes to both; helping out wrangling bugs is always a good thing too, ime, and flows naturally from submitting your own reports (patches always welcome.;)
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Tue Feb 02, 2016 5:51 pm    Post subject: Reply with quote

steveL wrote:
TigerJr wrote:
What needs mate from her mates? Debug? Testers?

Yes to both; helping out wrangling bugs is always a good thing too, ime, and flows naturally from submitting your own reports (patches always welcome.;)


What next update of that package would be?

It's hard to say yes for debug and write patches, cause i'm not familiar with gtk developing, but i can try to test new packages, if new ebuilds appear in portage.
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4809
Location: The Peanut Gallery

PostPosted: Wed Feb 03, 2016 4:19 am    Post subject: Reply with quote

TigerJr wrote:
What next update of that package would be?

IDK I don't use it, yet. ;) I only posted because there didn't seem to be any news about the request for help, and I know at least some of us are using it.
Quote:
It's hard to say yes for debug and write patches, cause i'm not familiar with gtk developing, but i can try to test new packages, if new ebuilds appear in portage.

Sure; no-one expects patches, and certainly not straight away. Just becoming a desktop tester would be great, but again don't feel you have to do anything formal.

First find out if you feel okay in #gentoo-desktop and #gentoo-mate and just lurk for a while, and ask about bugs with Mate, either in general, or that you have noticed yourself on the bugzilla or in usage.

Both on IRC: chat.freenode.net or .org.
If you're feeling a bit lost on IRC, a few #gentoo-chat regulars set up #friendly-coders a while ago; you can ask in there about general coding questions, likely referred to another channel for specifics, but it's nice to have a friendly base you can return to.
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Wed Feb 03, 2016 6:45 am    Post subject: Reply with quote

steveL wrote:
Just becoming a desktop tester would be great, but again don't feel you have to do anything formal.


What it means formal? How much time need to test package?
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 841
Location: Germany

PostPosted: Mon Feb 15, 2016 9:09 am    Post subject: Reply with quote

I've been using MATE on Gentoo for some time. Was really happy when I synced portage today and saw the 1.10 finally hit the tree (Not complaining; I know there're not that many maintainers, thanks for your work.)
When I saw that MATE wants me to also use systemd I wasn't that happy anymore.
So, if it is possible to use MATE 1.10 without systemd, let me know and I'll be a desktop tester.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2038
Location: Illinois, USA

PostPosted: Mon Feb 15, 2016 7:40 pm    Post subject: Reply with quote

Clad in Sky wrote:
When I saw that MATE wants me to also use systemd I wasn't that happy anymore.


This is what I've been fearing for a long while.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4809
Location: The Peanut Gallery

PostPosted: Tue Feb 16, 2016 3:53 pm    Post subject: Reply with quote

steveL wrote:
Just becoming a desktop tester would be great, but again don't feel you have to do anything formal.

TigerJr wrote:
What it means formal? How much time need to test package?

"Don't feel you have to do anything formal," means "you do not need to sign up to become a (desktop tester in this case) to help out."

You're already testing them; just take a few minutes to file bug reports about things that are broken, keep a level head on the bugzilla, and help other users.

IOW: engage in the community, as usual, but focus a bit on MATE, if you use it.

If you like using it, and want it to stick around, then by all means feel free to take a more active role still.
/autojoin #gentoo-mate and lurk there whenever you are online, no matter how quiet it is.
Sign up to become a desktop tester, via the url already given, and help out with bug-wrangling (something anyone can do, at any point, anywhere in Gentoo.)
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4809
Location: The Peanut Gallery

PostPosted: Tue Feb 16, 2016 3:54 pm    Post subject: Reply with quote

Clad in Sky wrote:
When I saw that MATE wants me to also use systemd I wasn't that happy anymore.

Tony0945 wrote:
This is what I've been fearing for a long while.

Patch it back to sanity then; chances are they don't really care what does what under the hood, so long as it works.
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 841
Location: Germany

PostPosted: Sun Feb 21, 2016 5:54 pm    Post subject: Reply with quote

If I could patch it myself, I'd've done that. Obviously I can't. Well, I think I can't. I guess it's a bit more than removing systemd from the dependencies.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 718

PostPosted: Mon Feb 22, 2016 1:30 am    Post subject: Reply with quote

No patch needed. Try "-gnome" in make.conf. It looks like the absence of "gnome" alone is not enough.

That's for 1.10, btw.
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 841
Location: Germany

PostPosted: Mon Feb 22, 2016 7:27 am    Post subject: Reply with quote

Yes, thanks. Was about to post that.
Now there's only the notification-daemon blocker left, but that's an easy one, as you mentioned in the other thread.

So, to sum up:

MATE 1.10 does NOT need systemd
Trying to emerge MATE 1.10 without explicitly set -gnome useflag will result in some Gnome stuff being pulled in, depending on systemd
You need to upgrade gtk+ to version 3.18 (still marked ~amd64, not sure if it is stable on x86 and other platforms)
If you have x11-misc/notification-daemon installed you need to remove it - once mate-notification-daemon is installed, you can reinstall x11-misc/notification-daemon if you need it.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 554

PostPosted: Wed Feb 24, 2016 11:39 pm    Post subject: Reply with quote

Clad in Sky wrote:
Yes, thanks. Was about to post that.
Now there's only the notification-daemon blocker left, but that's an easy one, as you mentioned in the other thread.

So, to sum up:

MATE 1.10 does NOT need systemd
Trying to emerge MATE 1.10 without explicitly set -gnome useflag will result in some Gnome stuff being pulled in, depending on systemd
You need to upgrade gtk+ to version 3.18 (still marked ~amd64, not sure if it is stable on x86 and other platforms)
If you have x11-misc/notification-daemon installed you need to remove it - once mate-notification-daemon is installed, you can reinstall x11-misc/notification-daemon if you need it.


I upgraded from Mate-1.8 to Mate-1.10 yesterday without any issues. The notification-daemon blocker was handled automatically during the install process. As far as I know x11-libs/gtk+-3.18.7 is stable on amd64. I had no need to unmask it. It was already on my system. I also recommend that -gnome as well as -systemd get added to the make.conf file if you want to avoid anything related to systemd.
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 554

PostPosted: Wed Feb 24, 2016 11:42 pm    Post subject: Reply with quote

I couldn't find anything in the Mate docs that depreciated mate-calc so why is gnome-extra/gnome-calculator being pulled in instead of just using the existing mate-calc 1.8.0. Both are now installed on my system. The gnome-calculator-3.18.3 won't integrate into the desktop look, and is as slow as everything else gnome3 related but mate-calc 1.8.0 looks and runs like it belongs there.

Mate-1.10 is also pulling in sys-apps/gnome-disk-utility. Another app that doesn't fit into the desktop look and feel and can be replaced by other tools.

I can't seem to find any hard reason these apps would be required. Am I missing something???

TIA.... :?
Back to top
View user's profile Send private message
kajzer
Apprentice
Apprentice


Joined: 27 Nov 2014
Posts: 163

PostPosted: Thu Feb 25, 2016 2:04 am    Post subject: Reply with quote

Yeah, that extras USE flag is somewhat weird, I had to disable it and emerge few apps on my own, this basically :
pluma, engrampa, atril, caja-extensions, mate-system-monitor, mate-utils, eom, mate-polkit

btw I use galculator, looks great in any DE :)
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 554

PostPosted: Fri Feb 26, 2016 4:23 pm    Post subject: Reply with quote

kajzer wrote:
Yeah, that extras USE flag is somewhat weird, I had to disable it and emerge few apps on my own, this basically :
pluma, engrampa, atril, caja-extensions, mate-system-monitor, mate-utils, eom, mate-polkit

btw I use galculator, looks great in any DE :)


I understand why the extras flag is enabled by default. Most users new to Gentoo would want to have a fairly complete working desktop without having to go to extra steps to get one, where more advanced users would do as you did.

I an not a developer and I am just starting to understand the ebuild process, but I haven't found any reason to inject the gnome-calculator or gnome-disk-utility packages into Mate. So I created a modified ebuild to remove those packages and replace gnome-calculator with the mate-calc-1.8.0 ( maybe mate-calc needs a version bump? )package. I've tested it and I haven't noticed any problems as a result YET.

USE AT YOUR OWN RISK
Code:

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit versionator

MATE_MV="$(get_version_component_range 1-2)"

SRC_URI=""
DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
HOMEPAGE="http://mate-desktop.org"

LICENSE="metapackage"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+base -bluetooth +notification +themes +extras"

S="${WORKDIR}"

RDEPEND="
   =mate-base/mate-desktop-${MATE_MV}*:0
   =mate-base/mate-menus-${MATE_MV}*:0
   =mate-base/mate-panel-${MATE_MV}*:0
   =mate-base/mate-session-manager-${MATE_MV}*:0
   =mate-base/mate-settings-daemon-${MATE_MV}*:0
   =x11-wm/marco-${MATE_MV}*:0
   base? (
      =mate-base/caja-${MATE_MV}*:0
      =mate-base/mate-applets-meta-${MATE_MV}*:0
      =mate-base/mate-control-center-${MATE_MV}*:0
      =mate-extra/mate-media-${MATE_MV}*:0
      =x11-misc/mozo-${MATE_MV}*:0
      =x11-terms/mate-terminal-${MATE_MV}*:0
   )
   bluetooth? ( net-wireless/blueman:0 )
   themes? (
      =x11-themes/mate-backgrounds-${MATE_MV}*:0
      =x11-themes/mate-icon-theme-${MATE_MV}*:0
      =x11-themes/mate-themes-meta-${MATE_MV}*:0
   )
   extras? (
      =app-arch/engrampa-${MATE_MV}*:0
      =app-editors/pluma-${MATE_MV}*:0
      =app-text/atril-${MATE_MV}*:0
      mate-extra/mate-calc:0
      =mate-extra/caja-extensions-${MATE_MV}*:0
      =mate-extra/mate-netbook-${MATE_MV}*:0
      =mate-extra/mate-power-manager-${MATE_MV}*:0
      =mate-extra/mate-screensaver-${MATE_MV}*:0
      =mate-extra/mate-system-monitor-${MATE_MV}*:0
      =mate-extra/mate-utils-${MATE_MV}*:0
      =media-gfx/eom-${MATE_MV}*:0
      =net-analyzer/mate-netspeed-${MATE_MV}*:0
   )
"

PDEPEND="
   notification? ( x11-misc/mate-notification-daemon )
   virtual/notification-daemon:0"

pkg_postinst() {
   elog "For installation, usage and troubleshooting details regarding MATE;"
   elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
   elog ""
   if ! has_version x11-misc/mate-notification-daemon; then
      elog "If you experience any issues with notifications, please try using"
      elog "x11-misc/mate-notification-daemon instead your currently installed daemon"
      elog ""
   fi
   elog "MATE 1.10 had some packages renamed, replaced and/or dropped; for more"
   elog "details, see http://mate-desktop.org/blog/2015-06-11-mate-1-10-released/"
   elog ""
   elog "Some packages that are not included in this meta-package but may be of interest:"
   elog "      mate-extra/caja-dropbox"
   elog "      mate-extra/mate-user-share"
}


I decided it was best to keep the extras flag enabled by default.
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Sun Feb 28, 2016 9:42 pm    Post subject: I Trying to update from mate-1.8.0 to mate-1.10.0-r2 Reply with quote

Code:
aegis2 xo # ACCEPT_KEYWORDS=~amd64 emerge mate -a

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] mate-base/mate-common-1.10.0 [1.8.0]
[ebuild  N     ] net-wireless/wireless-tools-30_pre9  USE="-multicall" LINGUAS="-cs -fr"
[ebuild  N     ] app-text/scrollkeeper-9999-r1
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild     U  ] x11-themes/mate-backgrounds-1.10.0 [1.8.0]
[ebuild  NS    ] sys-libs/db-6.0.35 [4.8.30-r2] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] x11-proto/randrproto-1.5.0 [1.4.0-r1]
[ebuild  N     ] media-libs/libdvdread-5.0.3  USE="css -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libepoxy-1.3.1  USE="{-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libfakekey-0.1-r2  USE="-debug -doc"
[ebuild     U  ] x11-libs/libXrandr-1.5.0 [1.4.2]
[ebuild     U  ] x11-themes/mate-icon-theme-1.10.1 [1.8.0]
[ebuild  r  U  ] dev-vcs/subversion-1.9.3 [1.8.14]
[ebuild     U  ] dev-libs/glib-2.46.2-r2 [2.44.1-r1]
[ebuild     U  ] dev-libs/atk-2.18.0 [2.14.0]
[ebuild     U  ] x11-libs/pango-1.38.1 [1.36.8] USE="{-test%}"
[ebuild     U  ] mate-base/libmatekbd-1.10.1 [1.8.0]
[ebuild  N     ] gnome-extra/gucharmap-3.0.1-r200  USE="introspection -cjk -debug -doc"
[ebuild     U  ] mate-base/mate-menus-1.10.1 [1.8.0]
[ebuild     U  ] dev-libs/libmateweather-1.10.0 [1.8.0]
[ebuild     U  ] x11-libs/gtk+-3.18.7 [3.14.13]
[ebuild     U  ] mate-extra/mate-system-monitor-1.10.1 [1.8.0] USE="-systemd%"
[ebuild     U  ] x11-libs/gtksourceview-3.18.2 [3.14.4]
[ebuild     U  ] mate-base/mate-desktop-1.10.2 [1.8.1-r1] USE="introspection%* user-guide%*"
[ebuild  N     ] gnome-extra/gnome-calculator-3.18.3
[ebuild     U  ] mate-extra/mate-utils-1.10.4 [1.8.0]
[ebuild     U  ] mate-base/mate-panel-1.10.1 [1.8.0]
[ebuild     U  ] media-gfx/eom-1.10.5-r1 [1.8.0] USE="introspection%*"
[ebuild     U  ] x11-terms/mate-terminal-1.10.2 [1.8.0]
[ebuild     U  ] app-editors/pluma-1.10.2 [1.8.1]
[ebuild  N     ] mate-extra/mate-netbook-1.10.0
[ebuild  N     ] net-analyzer/mate-netspeed-1.10.2
[ebuild     U  ] x11-misc/mozo-1.10.1 [1.8.0]
[ebuild  N     ] x11-misc/mate-notification-daemon-1.10.2  USE="-debug"
[ebuild  N     ] media-libs/libmatemixer-1.10.1  USE="alsa pulseaudio -debug -oss"
[ebuild     U  ] mate-base/mate-settings-daemon-1.10.3 [1.8.1] USE="sound%*"
[ebuild     U  ] mate-extra/mate-media-1.10.1 [1.8.0]
[ebuild     U  ] mate-base/mate-session-manager-1.10.3 [1.8.1-r1] USE="upower*"
[ebuild  N     ] mate-extra/mate-power-manager-1.10.2  USE="applet -gnome-keyring -man -policykit {-test} -unique"
[ebuild  N     ] mate-base/mate-applets-1.10.4-r1  USE="X upower -ipv6 -policykit" PYTHON_TARGETS="python2_7"
[ebuild  N     ] mate-base/mate-applets-meta-1.10  USE="-appindicator -sensors"
[ebuild     U  ] mate-extra/mate-screensaver-1.10.2-r1 [1.8.0] USE="-opengl*"
[ebuild     U  ] mate-base/caja-1.10.4 [1.8.1]
[ebuild     U  ] x11-wm/marco-1.10.3 [1.8.0]
[ebuild     U  ] app-text/atril-1.10.3-r1 [1.8.0] USE="caja* postscript%* -epub%"
[ebuild     U  ] app-arch/engrampa-1.10.2 [1.8.0] USE="-magic%"
[ebuild  N     ] mate-extra/caja-extensions-1.10.1  USE="mail open-terminal wallpaper -cdr -debug -gajim -image-converter -pidgin -share -upnp"
[ebuild     U  ] mate-base/mate-control-center-1.10.2 [1.8.1]
[ebuild  N     ] sys-apps/gnome-disk-utility-3.18.3.1  USE="-fat -gnome -systemd"
[ebuild     U  ] x11-themes/mate-themes-1.10.5-r181 [1.8.0]
[ebuild  N     ] x11-themes/mate-themes-meta-1.10
[ebuild     U  ] mate-base/mate-1.10.0-r2 [1.8.0] USE="notification%*"
[blocks B      ] <dev-util/gdbus-codegen-2.46.2 ("<dev-util/gdbus-codegen-2.46.2" is blocking dev-libs/glib-2.46.2-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed) pulled in by
    >=dev-util/gdbus-codegen-2.38.2 required by (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge)
    dev-util/gdbus-codegen:0 required by (mate-base/caja-1.10.4:0/0::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.46.2-r2:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36:2 required by (mate-extra/mate-power-manager-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (mate-base/libmatekbd-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.29.15:2 required by (gnome-extra/cinnamon-menus-2.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (x11-misc/mate-notification-daemon-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (dev-libs/libcroco-0.6.8-r1:0.6/0.6::gentoo, installed)
    >=dev-libs/glib-2.31:2[dbus] required by (sys-apps/gnome-disk-utility-3.18.3.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0:1/1::gentoo, installed)
    >=dev-libs/glib-2.44:2 required by (x11-libs/gtksourceview-3.18.2:3.0/3::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.36:2[abi_x86_64(-)]) required by (x11-misc/colord-1.2.12:0/2::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-base/mate-panel-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (app-editors/pluma-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.44:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.44:2[abi_x86_64(-)]) required by (dev-cpp/glibmm-2.44.0:2/2::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (app-text/atril-1.10.3-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (mate-extra/mate-screensaver-1.10.2-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.26:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.26:2[abi_x86_64(-)]) required by (x11-libs/libnotify-0.7.6-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libunique-1.1.6-r1:1/1::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by (gnome-base/librsvg-2.40.9:2/2::gentoo, installed)
    >=dev-libs/glib-2.38:2 required by (dev-python/pygobject-3.14.0:3/3::gentoo, installed)
    >=dev-libs/glib-2.43.2:2 required by (gnome-base/gvfs-1.24.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (dev-libs/dbus-glib-0.102:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/libgee-0.18.0:0.8/2::gentoo, installed)
    >=dev-libs/glib-2.34.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3[abi_x86_64(-)]) required by (sys-fs/udev-216:0/0::gentoo, installed)
    >=dev-libs/glib-2.42:2[abi_x86_64(-)] required by (net-libs/glib-networking-2.42.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.37.3:2[dbus] required by (x11-wm/muffin-2.6.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.28.0:2 required by (net-misc/vinagre-3.16.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-extra/zenity-3.14.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (gnome-base/libglade-2.6.4-r2:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (gnome-extra/libgda-5.2.2:5/4::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-themes/gtk-engines-murrine-0.98.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.37.6:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.37.6:2[abi_x86_64(-)]) required by (dev-libs/json-glib-1.0.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-0.10.31-r1:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (media-libs/gstreamer-0.10.36-r2:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-extra/mate-netbook-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32.3:2 required by (x11-misc/lightdm-1.10.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-base/mate-session-manager-1.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.28:2 required by (x11-libs/colord-gtk-0.1.26:0/1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (dev-python/gnome-python-base-2.28.1-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (gnome-extra/cjs-2.4.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.30.0:2 required by (net-print/cups-pk-helper-0.2.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (app-arch/engrampa-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.37.3:2 required by (sys-apps/accountsservice-0.6.40:0/0::gentoo, installed)
    dev-libs/glib:2 required by (www-client/opera-12.16_p1860-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.37.6:2[abi_x86_64(-)] required by (x11-libs/gdk-pixbuf-2.30.8-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.16.3:2 required by (gnome-extra/gucharmap-3.0.1-r200:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32:2 required by (net-im/telepathy-mission-control-5.16.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.41.2:2 required by (dev-util/gtk-update-icon-cache-3.14.13:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/pango-1.38.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32:2 required by (media-libs/cogl-1.18.2-r1:1.0/20::gentoo, installed)
    >=dev-libs/glib-2:2 required by (app-admin/system-config-printer-1.4.8:0/0::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (app-misc/geoclue-2.2.0:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.17.3:2 required by (mate-base/mate-settings-daemon-1.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.38.2-r1:2= required by (sys-auth/consolekit-0.4.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2[abi_x86_64(-)] required by (app-accessibility/at-spi2-atk-2.14.1:2/2::gentoo, installed)
    >=dev-libs/glib-2.16.1:2 required by (dev-libs/appstream-glib-0.3.4:0/7::gentoo, installed)
    >=dev-libs/glib-2.30.1:2 required by (net-libs/gtk-vnc-0.5.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112-r3:0/0::gentoo, installed)
    >=dev-libs/glib-2.38:2 required by (gnome-base/gnome-keyring-3.14.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.34:2[dbus] required by (dev-util/anjuta-3.18.2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/gdl-3.14.0:3/5::gentoo, installed)
    >=dev-libs/glib-2.36:2[abi_x86_64(-)] required by (app-accessibility/at-spi2-core-2.14.1:2/2::gentoo, installed)
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-plugins/gst-plugins-x-0.10.36-r1:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-0.10.36-r2:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.37.3:2 required by (media-libs/clutter-1.20.2:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.7.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.29.10:2[dbus] required by (gnome-extra/cinnamon-2.6.13:0/0::gentoo, installed)
    >=dev-libs/glib-2.38:2 required by (app-crypt/libsecret-0.18.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.32:2[abi_x86_64(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-util/glade-3.18.3:3.10/6::gentoo, installed)
    dev-libs/glib:2 required by (net-analyzer/mate-netspeed-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32 required by (net-libs/libqmi-1.12.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (x11-terms/mate-terminal-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (media-gfx/eom-1.10.5-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (mate-base/mate-control-center-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r3:2.0/2.0::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (mate-extra/mate-media-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.40:2 required by (gnome-extra/gnome-calculator-3.18.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.38.2-r1:2/2= required by (sys-auth/consolekit-0.4.6:0/0::gentoo, installed)
    >=dev-libs/glib-2.39.1:2 required by (gnome-base/dconf-0.22.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-extra/mate-system-monitor-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.22 required by (sys-power/upower-pm-utils-0.9.23-r2:0/0::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.559:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-extra/caja-extensions-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.38:2 required by (gnome-extra/cinnamon-settings-daemon-2.6.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-misc/networkmanager-1.0.2-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/cinnamon-control-center-2.6.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (mate-base/mate-menus-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32.10:2 required by (x11-wm/marco-1.10.3:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/cairo-1.14.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (media-libs/libmatemixer-1.10.1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/glib[dbus] required by (app-accessibility/caribou-0.4.18.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.4.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (gnome-base/libgnomekbd-3.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (net-libs/libsoup-2.48.1:2.4/2.4::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (net-libs/webkit-gtk-2.4.9:3/25::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-base/mate-desktop-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/gtk+-2.24.28-r1:2/2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (gnome-base/libgtop-2.30.0:2/10::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.4:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-base/mate-applets-1.10.4-r1:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.42:2 required by (dev-libs/gobject-introspection-1.42.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (gnome-extra/nm-applet-1.0.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-libs/glib-2.4.0[abi_x86_64(-)] required by (media-sound/pulseaudio-5.0-r7:0/0::gentoo, installed)
    >=dev-libs/glib-2.37.3:2 required by (gnome-extra/cinnamon-desktop-2.6.5:0/4::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (net-libs/telepathy-glib-0.24.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.16.1:0/0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.36:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] (>=dev-libs/glib-2.36:2[python_targets_python2_7(-),-python_single_target_python2_7(-)]) required by (dev-libs/libmateweather-1.10.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, installed)
    >=dev-libs/glib-2.34.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3[abi_x86_64(-)]) required by (dev-util/pkgconfig-0.28-r2:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.4.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)
    dev-libs/glib:2 required by (app-emulation/xen-tools-4.6.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, installed)
    >=dev-libs/glib-2.31.10:2 required by (gnome-extra/gnome-color-manager-3.14.2:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by (media-libs/harfbuzz-0.9.38:0/0.9.18::gentoo, installed)
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-0.10.31-r1:0.10/0.10::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22:0/0::gentoo, installed)
    >=dev-libs/glib-2.36 required by (sys-fs/udisks-2.1.4:2/2::gentoo, installed)
    dev-libs/glib required by @selected
    >=dev-libs/glib-2.6.0:2 required by (dev-python/gnome-python-desktop-base-2.32.0-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (dev-libs/atk-2.18.0:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36:2 required by (mate-extra/mate-utils-1.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34:2 required by (gnome-extra/nemo-2.4.5:0/0::gentoo, installed)
    >=dev-libs/glib-2.37.3:2 required by (gnome-extra/cinnamon-session-2.6.3:0/0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-misc/modemmanager-1.4.8:0/1::gentoo, installed)
    >=dev-libs/glib-2.38:2 required by (app-crypt/gcr-3.14.0:0/1::gentoo, installed)
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (media-libs/gstreamer-1.4.5:1.0/1.0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (mate-base/caja-1.10.4:0/0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.8:2 required by (app-misc/mc-4.8.14:0/0::gentoo, installed)
    >=dev-libs/glib-2.45.8:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/glib-2.45.8:2[abi_x86_64(-)]) required by (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge)
    dev-libs/glib:2 required by (app-text/poppler-0.32.0:0/51::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (net-misc/spice-gtk-0.25-r1:0/0::gentoo, installed)
    >=dev-libs/glib-2.16.0:2 required by (gnome-base/libgnome-keyring-3.12.0:0/0::gentoo, installed)
    >=dev-libs/glib-2.40:2 required by (x11-libs/vte-0.38.3:2.91/2.91::gentoo, installed)
    >=dev-libs/glib-2.44.1:2 required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages



Mate-1.10.0-r2 needs only new install?

And
Quote:

[ebuild NS ] sys-libs/db-6.0.35 [4.8.30-r2] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64) -32 (-x32)"

Brakes already installed packages those use berkeley db 4.8.30 libs!
_________________

Do not update portage without hotdog!

Xenogentooway?


Last edited by TigerJr on Tue Apr 19, 2016 12:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 446
Location: Vienna/Europe

PostPosted: Mon Mar 21, 2016 8:55 am    Post subject: Reply with quote

kajzer wrote:
Yeah, that extras USE flag is somewhat weird, I had to disable it and emerge few apps on my own ...


Same here, using mate-1.10, but I did it (and recommand it) as follows:

1.) emerge mate with USE="-extras"

2.) nano -w /etc/portage/sets/mate-extras:
Code:
### these are the extras that would be enabled with
### use-flag extras in meta-package mate.
### Comment out those of them that you do not need:
app-arch/engrampa
### pluma is a basic editor, we use geany instead:
# app-editors/pluma
app-text/atril
### gnome-extra/gnome-calculator
### we do not want gnome3 stuff, so we'll use this one instead:
sci-calculators/galculator
mate-extra/caja-extensions
### we have neither a netbook ...
# mate-extra/mate-netbook
### ... nor a laptop:
# mate-extra/mate-power-manager
mate-extra/mate-screensaver
mate-extra/mate-system-monitor
mate-extra/mate-utils
media-gfx/eom
# net-analyser/mate-netspeed
### we can mount disk-images by typing mount
### and format disks by typing mkfs.ext4 :-)
# sys-apps/gnome-disk-utility


Change this according to your needs. If you think you need gnome-disk-utility, emerge it with USE="-gnome" in order to prevent systemd-related stuff.

3.) emerge -q @mate-extras

@kajzer: thanks for the hint to galculator!

Cheers
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Sat Apr 16, 2016 10:41 am    Post subject: Reply with quote

Is any news in that topic, sommebody tried mate-1.14 ???
I read it here on github
https://github.com/mate-desktop/mate-desktop/blob/master/NEWS
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4809
Location: The Peanut Gallery

PostPosted: Sat Apr 16, 2016 12:09 pm    Post subject: Reply with quote

TigerJr wrote:
Anybody tried mate-1.14?

It could be you. ;-)

ie: do the usual "drop it into local overlay with a later version, and get it to compile" fandango, discussing in #gentoo-mate and #gentoo-desktop, and here.

edit: "Drop MateConf migration script and ancient mate-conf-import tool" may make things more interesting (perhaps easier.)

@TigerJr: can you edit your post further up; the one with the long "quote" of blockages, and turn that into a "code" tag, please?
(subject: "Trying to update from mate-1.8.0 to mate-1.10.0-r2")
It will stop the page looking like crap. Ta.
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 390
Location: /dev/x0

PostPosted: Tue Apr 19, 2016 12:00 pm    Post subject: Reply with quote

steveL wrote:
TigerJr wrote:
Anybody tried mate-1.14?

It could be you. ;-)

ie: do the usual "drop it into local overlay with a later version, and get it to compile" fandango, discussing in #gentoo-mate and #gentoo-desktop, and here.

edit: "Drop MateConf migration script and ancient mate-conf-import tool" may make things more interesting (perhaps easier.)

@TigerJr: can you edit your post further up; the one with the long "quote" of blockages, and turn that into a "code" tag, please?
(subject: "Trying to update from mate-1.8.0 to mate-1.10.0-r2")
It will stop the page looking like crap. Ta.


I'm already had a problem with mate update, but updated to 1.10.0 by delete blocking dependency, than ~amd64 install Berkeley DB6.0 with DB4.8, after that stoped working subversion(svnserve) and anjuta, but maybe not only them ^) or this maybe not berkeley db compability problem...

I can install mate-1.14 from github. But i didn't did it and wanted to ask here gentoo mate users.
But how i can install /usr/bin/ebuild mate-1.14.ebuild install from portage emerge script, or try to test all conflicts and resolve it? Cause mate-1.14 is not in portage repository...

P.S

After glib-2.44.1-r2 update to glib-2.46-r1 i couldn't emerge back to tested glib-2.44.1-r2 (configure script stoped on autoconfig phase) maybe this error brakes anjuta and subversion

AND
steveL wrote:
USE="-gnome" in order to prevent systemd-related stuff.


if was any way to preven systemd related stuff cause mate is only choise to do that.
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
kajzer
Apprentice
Apprentice


Joined: 27 Nov 2014
Posts: 163

PostPosted: Fri Apr 29, 2016 1:26 am    Post subject: Reply with quote

Anyone tried to emerge Mate from git ?
I saw a couple of 9999 ebuilds....
Back to top
View user's profile Send private message
davetk
n00b
n00b


Joined: 31 Jul 2015
Posts: 3

PostPosted: Sun May 08, 2016 12:42 am    Post subject: Reply with quote

kajzer wrote:
Anyone tried to emerge Mate from git ?
I saw a couple of 9999 ebuilds....


Those didn't work for me.. so heres what I did to get 1.14 installed:

(Install layman) : --emerge --ask layman

layman -a rinaldus-overlay

edit /etc/portage/make.conf and set ACCEPT_KEYWORDS="~amd64" -- unset this after emerging mate;

Code:
emerge --ask mate-settings-daemon mate-session-manager mate-panel mate-menus mate-desktop mate-control-center mate-common mate-applets libmatekbd caja engrampa pluma atril libmateweather python-caja mate-utils mate-user-share mate-user-guide mate-system-monitor mate-sensors-applet mate-scrreensaver mate-power-manager mate-polkit mate-netbook mate-media mate-indicator-applet caja-extensions caja-dropbox eom libmatemixer mate-terminal marco mate-backgrounds mate-icon-theme-faenza mate-icon-theme --exclude ncurses


mate 1.14 should now be installed

Going to test this release for a while..

#Edit:

Here is what I added to /etc/portage/package.accept_keywords:

Code:
# mate 1.14 rinaldus-overlay:

=mate-base/mate-settings-daemon-1.14.0 ~amd64
=mate-base/mate-session-manager-1.14.0 ~amd64
=mate-base/mate-panel-1.14.0 ~amd64
=mate-base/mate-desktop-1.14.0 ~amd64
=mate-base/mate-menus-1.14.0 ~amd64
=mate-base/mate-control-center-1.14.0 ~amd64
=mate-base/mate-common-1.14.0 ~amd64
=mate-base/mate-applets-1.14.0 ~amd64
=mate-base/libmatekbd-1.14.0 ~amd64
=mate-base/caja-1.14.0 ~amd64
=app-arch/engrampa-1.14.0 ~amd64
=app-editors/pluma-1.14.0 ~amd64
=app-text/atril-1.14.0 ~amd64
=dev-libs/libmateweather-1.14.0 ~amd64
=dev-python/python-caja-1.14.0 ~amd64
=mate-extra/mate-utils-1.14.0 ~amd64
=mate-extra/mate-user-share-1.14.0 ~amd64
=mate-extra/mate-user-guide-1.14.0 ~amd64
=mate-extra/mate-system-monitor-1.14.0 ~amd64
=mate-extra/mate-sensors-applet-1.14.0 ~amd64
=mate-extra/mate-screensaver-1.14.0 ~amd64
=mate-extra/mate-power-manager-1.14.0 ~amd64
=mate-extra/mate-polkit-1.14.0 ~amd64
=mate-extra/mate-netbook-1.14.0 ~amd64
=mate-extra/mate-media-1.14.0 ~amd64
=mate-extra/mate-indicator-applet-1.14.0 ~amd64
=mate-extra/caja-extensions-1.14.0 ~amd64
=mate-extra/caja-dropbox-1.14.0 ~amd64
=media-gfx/eom-1.14.0 ~amd64
=media-libs/libmatemixer-1.14.0 ~amd64
=x11-terms/mate-terminal-1.14.0 ~amd64
=x11-wm/marco-1.14.0 ~amd64
=x11-themes/mate-backgrounds-1.14.0 ~amd64
=x11-themes/mate-icon-theme-faenza-1.14.0 ~amd64
=x11-themes/mate-icon-theme-1.14.0 ~amd64
Back to top
View user's profile Send private message
kajzer
Apprentice
Apprentice


Joined: 27 Nov 2014
Posts: 163

PostPosted: Sun May 08, 2016 1:41 pm    Post subject: Reply with quote

Thanks for the information.
I'll give it a go.

btw I need Gentoo MATE but Gentoo MATE doesn't need me 8O
there are 3 people in #gentoo-mate , nobody saying a word for months.
I guess 1.12 will hit gentoo tree when Mate 1.20 comes out :twisted:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum