Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome/gdm can't type key "s"?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gjz010
n00b
n00b


Joined: 25 May 2013
Posts: 10

PostPosted: Sun Nov 29, 2015 5:08 am    Post subject: Gnome/gdm can't type key "s"? Reply with quote

I inStalled X.org and gnome deSktop environment.Everything worked well until I found that when I tried to type letter "s" in Gnome Terminal,it won't work.It's the Same everywhere.
However,thiS problem doeSn't occur when I uSe twm+xterm/firefox/gedit/...+Startx.What'S more,Ctrl+S,even Shift+S workS well.(That'S why all my "s"s are uppercaSe. :D )
I think the problem haS Something to do with gnome/gdm,but I don't know what iS the problem.

I'd appreciate it if you could help. :D

I noticed a Similar problem here
Quote:

can you try with gnome-base/gdm-3.18.2 from the main gentoo repository (not from the overlay)

eg
emerge -1 --ask gnome-base/gdm::gentoo

Unfortunately it won't work for me.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 525
Location: Earth

PostPosted: Sun Nov 29, 2015 7:41 am    Post subject: Re: Gnome/gdm can't type key "s"? Reply with quote

gjz010 wrote:
I inStalled X.org and gnome deSktop environment.Everything worked well until I found that when I tried to type letter "s" in Gnome Terminal,it won't work.It's the Same everywhere.
However,thiS problem doeSn't occur when I uSe twm+xterm/firefox/gedit/...+Startx.What'S more,Ctrl+S,even Shift+S workS well.(That'S why all my "s"s are uppercaSe. :D )
I think the problem haS Something to do with gnome/gdm,but I don't know what iS the problem.

I'd appreciate it if you could help. :D

I noticed a Similar problem here
Quote:

can you try with gnome-base/gdm-3.18.2 from the main gentoo repository (not from the overlay)

eg
emerge -1 --ask gnome-base/gdm::gentoo

Unfortunately it won't work for me.

This is a strange issue that I have heard of before and looked into but have never been able to figure out. Your particular situation, if I understand it correctly, is further complicated by startx working but not GDM. You can try (in no particular order):
  • Swapping your keyboard to rule out a hardware problem
  • Checking your .bashrc, .inputrc and any other relevant dot files to see if anything is binding your keys
  • Checking GNOME Control Panel -> Keyboard Shortcuts to see if anything is binding your keys
  • Opening xev in a terminal, pressing the malfunctioning key and comparing it with working keys
  • Checking /etc/locale.gen
  • Checking eselect locale list
  • Logging in as a different user (preferably one with only skeleton files)
  • Using a different keymap
  • Downgrading GDM
  • Disabling the accessibility USE flag on gdm (if you use it)
  • Disabling wayland (if you use it)
P.S. I think you meant to link #7847354.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1633
Location: United Kingdom

PostPosted: Sun Nov 29, 2015 10:25 am    Post subject: Reply with quote

I wonder if you are experiencing the same phenomenon as described in the following Ubuntu Forums thread:

'r' key not working in terminal

That user used the wrong method of blacklisting the pcspkr module, and it stopped his 'r' key from working in Terminal (but not the 'R' key). Looks suspiciously similar to what you are seeing.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
gjz010
n00b
n00b


Joined: 25 May 2013
Posts: 10

PostPosted: Sun Nov 29, 2015 3:08 pm    Post subject: Re: Gnome/gdm can't type key "s"? Reply with quote

dantrell wrote:
gjz010 wrote:
I inStalled X.org and gnome deSktop environment.Everything worked well until I found that when I tried to type letter "s" in Gnome Terminal,it won't work.It's the Same everywhere.
However,thiS problem doeSn't occur when I uSe twm+xterm/firefox/gedit/...+Startx.What'S more,Ctrl+S,even Shift+S workS well.(That'S why all my "s"s are uppercaSe. :D )
I think the problem haS Something to do with gnome/gdm,but I don't know what iS the problem.

I'd appreciate it if you could help. :D

I noticed a Similar problem here
Quote:

can you try with gnome-base/gdm-3.18.2 from the main gentoo repository (not from the overlay)

eg
emerge -1 --ask gnome-base/gdm::gentoo

Unfortunately it won't work for me.

This is a strange issue that I have heard of before and looked into but have never been able to figure out. Your particular situation, if I understand it correctly, is further complicated by startx working but not GDM. You can try (in no particular order):
  • Swapping your keyboard to rule out a hardware problem
  • Checking your .bashrc, .inputrc and any other relevant dot files to see if anything is binding your keys
  • Checking GNOME Control Panel -> Keyboard Shortcuts to see if anything is binding your keys
  • Opening xev in a terminal, pressing the malfunctioning key and comparing it with working keys
  • Checking /etc/locale.gen
  • Checking eselect locale list
  • Logging in as a different user (preferably one with only skeleton files)
  • Using a different keymap
  • Downgrading GDM
  • Disabling the accessibility USE flag on gdm (if you use it)
  • Disabling wayland (if you use it)
P.S. I think you meant to link #7847354.


I tried xev and found that it didn't even catch the KeyPreSSEvent:
Quote:

//When I preSS a:
KeyPress event, serial 68, synthetic NO, window 0x1600001,
root 0x2bd, subw 0x0, time 2177856, (303,31), root:(915,125),
state 0x10, keycode 38 (keysym 0x61, a), same_screen YES,
XLookupString gives 1 bytes: (61) "a"
XmbLookupString gives 1 bytes: (61) "a"
XFilterEvent returns: False

KeyRelease event, serial 68, synthetic NO, window 0x1600001,
root 0x2bd, subw 0x0, time 2178066, (303,31), root:(915,125),
state 0x10, keycode 38 (keysym 0x61, a), same_screen YES,
XLookupString gives 1 bytes: (61) "a"
XFilterEvent returns: False
//But when I preSS s:
FocusOut event, serial 68, synthetic NO, window 0x1600001,
mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 68, synthetic NO, window 0x1600001,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 68, synthetic NO, window 0x0,
keys: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1633
Location: United Kingdom

PostPosted: Wed Dec 30, 2015 12:10 pm    Post subject: Reply with quote

Just noticed the thread 's' key not working with new Gentoo install. Could that be the same issue?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
sedorox
Apprentice
Apprentice


Joined: 13 Feb 2004
Posts: 203

PostPosted: Thu Dec 31, 2015 3:41 am    Post subject: Reply with quote

I've run into this same thing, however for me, it's the 7 key on the top row above the letters. Number pad (obviously) works fine. Also, at least in terminal, if I do Super+7 it works.

Here's the xev output of 6, then 7, then super+7, then 8.
Code:

KeyPress event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1860965, (761,818), root:(798,892),
    state 0x10, keycode 15 (keysym 0x36, 6), same_screen YES,
    XLookupString gives 1 bytes: (36) "6"
    XmbLookupString gives 1 bytes: (36) "6"
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1861126, (761,818), root:(798,892),
    state 0x10, keycode 15 (keysym 0x36, 6), same_screen YES,
    XLookupString gives 1 bytes: (36) "6"
    XFilterEvent returns: False

FocusOut event, serial 36, synthetic NO, window 0xe00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0xe00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys:  64  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

FocusOut event, serial 36, synthetic NO, window 0xe00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0xe00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys:  2   0   1   0   0   0   0   0   0   0   0   0   0   0   0   0   
           32  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyPress event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1863798, (761,818), root:(798,892),
    state 0x50, keycode 16 (keysym 0x37, 7), same_screen YES,
    XLookupString gives 1 bytes: (37) "7"
    XmbLookupString gives 1 bytes: (37) "7"
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1863910, (761,818), root:(798,892),
    state 0x50, keycode 16 (keysym 0x37, 7), same_screen YES,
    XLookupString gives 1 bytes: (37) "7"
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1864446, (761,818), root:(798,892),
    state 0x50, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1865886, (761,818), root:(798,892),
    state 0x10, keycode 17 (keysym 0x38, 8), same_screen YES,
    XLookupString gives 1 bytes: (38) "8"
    XmbLookupString gives 1 bytes: (38) "8"
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0xe00001,
    root 0x1e1, subw 0x0, time 1865982, (761,818), root:(798,892),
    state 0x10, keycode 17 (keysym 0x38, 8), same_screen YES,
    XLookupString gives 1 bytes: (38) "8"
    XFilterEvent returns: False



This actually switched keys on me, as it was another, but recently settled on 7. I've done through the Keyboard center in settings, and there are not shortcuts bindings involving that key.
There also seems to be a bug submitted about this.
_________________
Home Desktop: Intel i5-2400 3.10ghz | 16G Ram | 1x 60G SSD, 1x 1TB HDD
Back to top
View user's profile Send private message
just-paja
n00b
n00b


Joined: 25 Nov 2009
Posts: 13

PostPosted: Sun Jan 17, 2016 2:10 pm    Post subject: Reply with quote

I have the same problem. Can't type "s" (lowercase S) letter in gdm/Gnome 3. It starts working when I turn off media-keys plugin using dconf-editor.

Code:
org/gnome/settings-daemon/plugins/media-keys/active false
B
Back to top
View user's profile Send private message
doug_ca
n00b
n00b


Joined: 18 Feb 2016
Posts: 4

PostPosted: Sat Feb 27, 2016 3:11 am    Post subject: Reply with quote

Thanks for the suggestion just-paja, that change allows me to use the "s" key in Gnome as well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum