Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Login crash after update @world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fragment
n00b
n00b


Joined: 08 Mar 2013
Posts: 24

PostPosted: Sat Nov 14, 2015 5:15 pm    Post subject: Login crash after update @world Reply with quote

I did emerge -uDN @world (updated packages: http://pastebin.com/qk11v0jr) and SDDM can't launch Plasma 5 desktop now. Instead the desktop I see black screen 2-3 seconds and SDDM again. This is fragment of system journal:

Code:

Nov 14 01:18:41 locus sddm-helper[434]: Starting: "/usr/share/sddm/scripts/Xsession" "/usr/bin/startkde"
Nov 14 01:18:41 locus sddm-helper[439]: Adding cookie to "/home/fragment/.Xauthority"
Nov 14 01:18:41 locus sddm[379]: Session started
Nov 14 01:18:41 locus sddm-helper[388]: [PAM] Ended.
Nov 14 01:18:41 locus sddm[379]: Auth: sddm-helper exited successfully
Nov 14 01:18:41 locus sddm[379]: Greeter stopped.
Nov 14 01:18:41 locus dhcpcd[357]: enp3s0: leased 192.168.1.193 for 86400 seconds
Nov 14 01:18:41 locus dhcpcd[357]: enp3s0: adding route to 192.168.1.0/24
Nov 14 01:18:41 locus dhcpcd[357]: enp3s0: adding default route via 192.168.1.1
Nov 14 01:18:41 locus systemd-timesyncd[336]: Network configuration changed, trying to establish connection.
Nov 14 01:18:41 locus org.a11y.Bus[452]: Activating service name='org.a11y.atspi.Registry'
Nov 14 01:18:41 locus org.a11y.Bus[452]: Successfully activated service 'org.a11y.atspi.Registry'
Nov 14 01:18:41 locus org.a11y.atspi.Registry[458]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Nov 14 01:18:41 locus sddm-helper[434]: [PAM] Ended.
Nov 14 01:18:41 locus sddm[379]: Auth: sddm-helper exited successfully
Nov 14 01:18:41 locus sddm[379]: Socket server stopping...
Nov 14 01:18:41 locus sddm[379]: Socket server stopped.
Nov 14 01:18:41 locus sddm[379]: Display server stopping...
Nov 14 01:18:41 locus org.a11y.Bus[452]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Nov 14 01:18:41 locus org.a11y.atspi.Registry[458]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Nov 14 01:18:42 locus kernel: nvidia-modeset: Freed GPU:0 (GPU-724a1712-15da-dee2-b007-ecb27c0affe9) @ PCI:0000:01:00.0
Nov 14 01:18:42 locus sddm[379]: Display server stopped.
Nov 14 01:18:42 locus sddm[379]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
Nov 14 01:18:42 locus sddm[379]: Removing display ":0" ...
Nov 14 01:18:42 locus sddm[379]: Adding new display on vt 1 ...
Nov 14 01:18:42 locus sddm[379]: Display server starting...
Nov 14 01:18:42 locus sddm[379]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{85b24de3-e2f2-41b9-aa51-7e4b69e4b365} -background none -noreset -displayfd 18 vt1


~/.xsession-errors is void (0 byte).
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Sun Nov 15, 2015 12:41 am    Post subject: Reply with quote

Hi fragment
this reminded me why I switched to LightDM :lol:

Anyway, from your journalctl extraction it seems that SDDM stops and starts the X server after login:
Code:
Nov 14 01:18:41 locus sddm-helper[434]: [PAM] Ended.
Nov 14 01:18:41 locus sddm[379]: Auth: sddm-helper exited successfully
Nov 14 01:18:42 locus sddm[379]: Display server stopped.
Nov 14 01:18:42 locus sddm[379]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
Nov 14 01:18:42 locus sddm[379]: Removing display ":0" ...
Nov 14 01:18:42 locus sddm[379]: Adding new display on vt 1 ...
Nov 14 01:18:42 locus sddm[379]: Display server starting...
Nov 14 01:18:42 locus sddm[379]: Running: /usr/bin/X
since I sincerely have no idea on how this DM works, can you recover some entries from journal in order to see if this is the correct behavior?

Regards
Back to top
View user's profile Send private message
fragment
n00b
n00b


Joined: 08 Mar 2013
Posts: 24

PostPosted: Sun Nov 15, 2015 4:30 am    Post subject: Reply with quote

Desktop successfully launched from root user! Probably, that's any problem with permissions.

I see strange access rights of .Xauthority file: http://storage4.static.itmages.ru/i/15/1115/h_1447560860_2372105_489abba216.png After every try to login access rights of this file are reseted to 700, whereas all files in home directory having 770.

So, I created file ~/.xinitrc:

Code:

exec dbus-launch --exit-with-session startkde


and then stopped SDDM, logined as user at tty and ran startx. Desktop didn't launch, xorg-server was terminated. In system journal was same error lines.
Back to top
View user's profile Send private message
fragment
n00b
n00b


Joined: 08 Mar 2013
Posts: 24

PostPosted: Sun Nov 15, 2015 4:47 am    Post subject: Reply with quote

Hi, kikko!

This is journal of my current working system (with kde-frameworks 5.15, kde-plasma 5.4.2, kde-apps 15.08.2, etc): http://pastebin.com/THsVqpG7

This is journal of updated system: http://pastebin.com/wxVK2vQm
Back to top
View user's profile Send private message
fragment
n00b
n00b


Joined: 08 Mar 2013
Posts: 24

PostPosted: Sun Nov 15, 2015 7:13 am    Post subject: Reply with quote

Desktop launched successfully from new user.

But I need normal launch session from my account.
Back to top
View user's profile Send private message
fragment
n00b
n00b


Joined: 08 Mar 2013
Posts: 24

PostPosted: Sun Nov 15, 2015 9:47 am    Post subject: Reply with quote

Problem solved:

Code:
rm -r ~/.config/plasma-workspace
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum