Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME 3 & pulseaudio : sound volume issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Mr.P4T4TE
n00b
n00b


Joined: 15 Jul 2011
Posts: 36

PostPosted: Thu Nov 12, 2015 1:26 pm    Post subject: GNOME 3 & pulseaudio : sound volume issue Reply with quote

Hi,

I'm trying GNOME 3 (with systemd) and everything works fine except the sound volume : it can be randomly muted or lowered without action.

I tryed to get some help on IRC (#gnome #gnome-hackers and #pulseaudio), I did some modification on pulseaudio configuration ("flat-volumes = no" in ~/.config/pulse/daemon.conf and "autospawn = no" in ~/.config/pulse/client.conf) without success : pulseaudio get a changed volume order but i dont know what process do that (The reference volume of sink alsa_output.pci-0000_00_1b.0.analog-stereo changed 100% / 0.00 dB to 9% / -64.00 dB).
I can found 1 error in log but i think is not the same problem ( E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.bluez.service failed to load: No such file or directory.)

Do you have some suggestion ?

Log :
Pulseaudio : https://bpaste.net/show/71076a0f65b8
portage : https://bpaste.net/show/38c070d5a492
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1362
Location: Montréal

PostPosted: Thu Nov 12, 2015 1:46 pm    Post subject: Reply with quote

Hi,

the autospawn variable concern the capability of Pulseaudio to launch itself if it's down when a sound client request Pulseaudio. It is not suppose to change the mixer setup.

You can try to block the mixer to a certain volume in Pulseaudio utility Pavucontrol. One thing I see who can change volume is if you do not have an /etc/asound.conf and/or an ~/.asoundrc file(s) who redirect Alsa clients to Pulseaudio. If some sound clients use Alsa instead of Pulseaudio, this can change the mixer setup.
Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}

_________________
Paul
Back to top
View user's profile Send private message
Mr.P4T4TE
n00b
n00b


Joined: 15 Jul 2011
Posts: 36

PostPosted: Thu Nov 12, 2015 2:04 pm    Post subject: Reply with quote

Yes, but disable autospawn variable is require to create a pulseaudio log.

I have not /etc/asound or ~/.asoudrc or ~/.config/asoundrc
I tried to emerge pavucontrol but issue is still here.

I'm just trying to create .asoundrc to paste your config but it dont work.

I think that it is a problem between gnome process and pulseaudio but i dont know how find this process.
Back to top
View user's profile Send private message
Mr.P4T4TE
n00b
n00b


Joined: 15 Jul 2011
Posts: 36

PostPosted: Fri Nov 13, 2015 9:00 am    Post subject: Reply with quote

In systemd log i found this when i start pulseaudio daemon :
Quote:
nov. 13 09:06:30 Fractal gnome-session[2087]: (gnome-settings-daemon:2133): media-keys-plugin-WARNING **: Unable to get default source
nov. 13 09:07:04 Fractal gnome-session[2087]: (gnome-settings-daemon:2133): media-keys-plugin-WARNING **: Unable to get default sink


After some time sound volume is lowered to 9% because module-alsa-card detects a strange connection to front headphone jack : (full log : https://bpaste.net/show/55c9255c18cc)
Quote:
module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in

Of course i have not jack on front headphone ... Probably a bad sensor contact...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum