Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome key binding
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
photonic
n00b
n00b


Joined: 09 Feb 2014
Posts: 10

PostPosted: Mon Nov 09, 2015 2:15 pm    Post subject: gnome key binding Reply with quote

Hey

My problem is I can not type 's' or 'l' under gnome-3.16 (those keys used to function properly).

's' key now suddenly became the trigger of gnome-screen-keyboard and 'l' key seems to be the same problem (but I don't know what function it triggers).

I tried to disable gnome-caribou by modifying the file in /usr/share/dbus-1/services, but it didn't work.

Could anyone here help me to solve this, thank you.
Back to top
View user's profile Send private message
mrpdaemon
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2004
Posts: 134

PostPosted: Tue Nov 10, 2015 9:24 am    Post subject: Reply with quote

I'm on the same boat - I'm sure that the offending package was installed on Nov 8th. I had rebooted after a full update on Nov 4th so I think everything up until then was fine. My initial suspect was xkbcomp but downgrading it didn't help :(
Back to top
View user's profile Send private message
mrpdaemon
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2004
Posts: 134

PostPosted: Wed Nov 11, 2015 3:13 am    Post subject: Reply with quote

I found a workaround:

Go to Settings -> Keyboard -> Shortcuts

In "Launchers" click to change the launcher for "Launch Help Browser" (previously in "Disabled" state). I used a dummy binding I won't accidentally use like <Ctrl><Shift><Alt>L

In "Universal Access" click to change the launcher for "Turn on-screen keyboard on or off", assign a similar useless binding.

This fixed 's' and 'l' for me. Note that after a reboot I had more trouble with other accessibility key bindings when hitting 's', so I needed to fix all the Disabled entries under "Universal Access" to have some sort of key binding. After that everything is good even through reboot.
Back to top
View user's profile Send private message
photonic
n00b
n00b


Joined: 09 Feb 2014
Posts: 10

PostPosted: Wed Nov 11, 2015 5:13 pm    Post subject: Reply with quote

mrpdaemon wrote:
I found a workaround:

Go to Settings -> Keyboard -> Shortcuts

In "Launchers" click to change the launcher for "Launch Help Browser" (previously in "Disabled" state). I used a dummy binding I won't accidentally use like <Ctrl><Shift><Alt>L

In "Universal Access" click to change the launcher for "Turn on-screen keyboard on or off", assign a similar useless binding.

This fixed 's' and 'l' for me. Note that after a reboot I had more trouble with other accessibility key bindings when hitting 's', so I needed to fix all the Disabled entries under "Universal Access" to have some sort of key binding. After that everything is good even through reboot.


Thank you very much mrpdeamon, I've tried that one. Didn't work for me. 's' would become the trigger of 'Large text'
Back to top
View user's profile Send private message
mrpdaemon
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2004
Posts: 134

PostPosted: Fri Nov 13, 2015 3:08 am    Post subject: Reply with quote

photonic wrote:
mrpdaemon wrote:
I found a workaround:

Go to Settings -> Keyboard -> Shortcuts

In "Launchers" click to change the launcher for "Launch Help Browser" (previously in "Disabled" state). I used a dummy binding I won't accidentally use like <Ctrl><Shift><Alt>L

In "Universal Access" click to change the launcher for "Turn on-screen keyboard on or off", assign a similar useless binding.

This fixed 's' and 'l' for me. Note that after a reboot I had more trouble with other accessibility key bindings when hitting 's', so I needed to fix all the Disabled entries under "Universal Access" to have some sort of key binding. After that everything is good even through reboot.


Thank you very much mrpdeamon, I've tried that one. Didn't work for me. 's' would become the trigger of 'Large text'


That happened to me, see the rest of my post, I also had to map Large Text and a bunch of other bindings under Universal Access for s to finally not do anything other than output the letter s.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum