Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfce4-terminal opens the wrong browser [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Tue Nov 03, 2015 7:49 pm    Post subject: xfce4-terminal opens the wrong browser [SOLVED] Reply with quote

I use xfce4 and I have a problem where xfce4-terminal opens the wrong bowser. In my preferred applications settings I have my web browser set to Google Chrome. However, when I middle click on a link in xfce4-terminal it uses the links browser instead.

The strange thing is if I use the helper apps:-
Code:

xdg-open https://forums.gentoo.org
exo-open https://forums.gentoo.org


It open up the links correctly using Google Chrome.

For some reason xfce4-terminal isn't picking up my default browser setting above? How to solve please?


Last edited by systemshq on Wed Nov 04, 2015 8:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Tue Nov 03, 2015 8:13 pm    Post subject: Reply with quote

Unfortunately, I can't get rid of links as its pulled in by the mono package which I need for keepass. However, removing the following file,
Code:

/usr/share/applications/links_-g_%u-links-2.desktop

Seems to have cured the problem for the time being. However, I've got no idea where xfce4-terminal is picking up its default browser setting from so I would be very grateful for any more clues please.
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 521
Location: Germany

PostPosted: Wed Nov 04, 2015 7:42 am    Post subject: Reply with quote

How about this document http://docs.xfce.org/xfce/exo/preferred-applications ?
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 10:17 am    Post subject: Reply with quote

Did all that and no joy with xfce4-terminal.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Wed Nov 04, 2015 10:37 am    Post subject: Reply with quote

i got the problem here.
i deleted xfce config files. it didn't help too.
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 10:49 am    Post subject: Reply with quote

xfce4-terminal is definitely NOT picking the default browser up from http://docs.xfce.org/xfce/exo/preferred-applications

I've got rid of all my browsers now except Google Chrome so that's one work around but I would l like to know where xfce4-terminal gets its default browser from?:):)
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Wed Nov 04, 2015 11:08 am    Post subject: Reply with quote

check default application in ~/.config/mimeapps.list
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 11:10 am    Post subject: Reply with quote

I don't have a ~/.config/mimeapps.list. What should it contain please?
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Wed Nov 04, 2015 11:23 am    Post subject: Reply with quote

i think you should have one of these
https://wiki.archlinux.org/index.php/Default_applications
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 11:29 am    Post subject: Reply with quote

It mentions loads of config files in that article. Any chance you can narrow down that file list to one and tell me what it should contain to make xfce4-terminal pick the correct default browser please?:)
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Wed Nov 04, 2015 11:36 am    Post subject: Reply with quote

there are only 4 you should check
$HOME/.config/$desktop-mimeapps.list user overrides, desktop-specific
$HOME/.config/mimeapps.list user overrides
$HOME/.local/share/applications/$desktop-mimeapps.list for compatibility but now deprecated, desktop-specific
$HOME/.local/share/applications/mimeapps.list
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 12:03 pm    Post subject: Reply with quote

What should those files contain please?
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Wed Nov 04, 2015 12:19 pm    Post subject: Reply with quote

RTFM
https://wiki.gentoo.org/wiki/DefaultApplication
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Wed Nov 04, 2015 8:19 pm    Post subject: Reply with quote

Definitive solution now:) xfce4-terminal picks up the default browser app via the various mime type list files and not the preferred applications set-up. So for example to set google chrome as the default browser for xfce4-terminal edit the following file:-
Code:

~/.config/mimeapps.list

[Default Applications]
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop


And also many thanks to my very able colleague, Perfect Gentleman for the above references:-

https://wiki.gentoo.org/wiki/DefaultApplication#Setting_the_default_application_via_mimeapps.list_fils
http://standards.freedesktop.org/mime-apps-spec/mime-apps-spec-1.0.html
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 758

PostPosted: Thu Nov 05, 2015 3:40 am    Post subject: Reply with quote

you can do the following also
Code:

x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop
Back to top
View user's profile Send private message
systemshq
n00b
n00b


Joined: 28 Mar 2011
Posts: 53

PostPosted: Thu Nov 05, 2015 2:11 pm    Post subject: Reply with quote

The above solution by PG is the best as it picks up the default browser from xfce4 preferred application settings panel. You need to have the [Default Applications] heading though, so the ~/.config/mimeapps.list file should contain a section which has:-
Code:

[Default Applications]
x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop
Back to top
View user's profile Send private message
bornmw
n00b
n00b


Joined: 13 Apr 2009
Posts: 45

PostPosted: Mon Dec 12, 2016 3:36 pm    Post subject: Reply with quote

Go to Settings -> MIME Type Editor and replace all types that have browser assigned to your taste
Back to top
View user's profile Send private message
FreakNigh
n00b
n00b


Joined: 20 Aug 2006
Posts: 38

PostPosted: Wed Oct 31, 2018 10:58 pm    Post subject: Reply with quote

When I went to the default settings from -

https://docs.xfce.org/xfce/exo/preferred-applications (Applications->Settings->Preferred Applications)

It auto set this in ~/.config/mimeapps.list when I changed the preferred browser -

x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop

And the links from Terminal started using the preferred browser.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum