Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Keyboard/Mouse in X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
maruru
n00b
n00b


Joined: 22 Sep 2015
Posts: 11

PostPosted: Sun Nov 01, 2015 10:59 pm    Post subject: No Keyboard/Mouse in X Reply with quote

I am working on a more or less fresh installation of Gentoo 4.0.5 (and never used Linux on this computer before).
I use a USB keyboard (Razer Deathstalker Ultimate) and a USB mouse (Razer Naga 2012).
Until now I have been using the terminal to play around, but now I want to install KDE 5 Plasma. So I followed the Wiki on how to install X.
At the moment, I have X installed and a xconfig file generated by nvidia programs.
When I `startx`, I can see the basic GUI, but neither my keyboard nor my mouse work.
I can use CTRL+ALT+F1 to go back to the terminal.
How can I fix this problem?

Code:
# rc-status
Runlevel: default
  dbus        [ started ]
  net.eno5s0  [ started ]
  netmount    [ started ]
  metalog     [ started ]
  consolekit  [ started ]
  fcron       [ started ]
  local       [ started ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed
Dynamic Runlevel: manual


Part of the X config:
Code:

Section "InputDevice"
  # generated from data in "/etc/conf.d/gpm"
  Identifier "Mouse0"
  Driver     "mouse"
  Option     "Protocol"
  Option     "Device" "/dev/input/mice"
  Option     "Emulate3Buttons" "no"
  Option     "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
  # generated from default
  Identifier "Keyboard0"
  Driver     "kbd"
EndSection


I have `INPUT_DEVICES="evdev"` in ^/etc/make.conf^
Something strange I found in the Xorg.0.log:
Code:

[  2495.882] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled
[  2495.882] (WW) Disabling Keyboard0
[  2495.882] (WW) Disabling Mouse0

_________________
Vote for better password security on Gentoo Forums!
Unsalted MD5 and sent as plaintext via mail is just the worst :/
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Nov 02, 2015 12:31 am    Post subject: Reply with quote

You have INPUT_DEVICES="evdev", this means no keyboard or mouse driver will be built. However, in xorg.conf you want to load these drivers. Try without InputDevice sections first, then add the configuration options you need. If it still doesn't work make sure you have evdev enabled in kernel.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2886
Location: Illinois, USA

PostPosted: Mon Nov 02, 2015 3:08 am    Post subject: Re: No Keyboard/Mouse in X Reply with quote

maruru wrote:

Something strange I found in the Xorg.0.log:
Code:

[  2495.882] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled
[  2495.882] (WW) Disabling Keyboard0
[  2495.882] (WW) Disabling Mouse0


I had that problem and message when switching from eudev to mdev. Is Xorg built with the "udev" flag? If you are running without udev or eudev, you must enable INPUT_DEVICES="keyboard mouse" and eliminate evdev. Also rebuild Xorg with USE="-udev".

If you are using udev/eudev, then hotplugging should be disabled and something else is wrong with your installation.

What is the result of:
emerge -pv virtual/udev
and
emerge -pv Xorg (or Xorg-server in my case)
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 618

PostPosted: Mon Nov 02, 2015 3:54 am    Post subject: Reply with quote

I seem to get away with not using xorg.conf at all nowadays in my desktop box, but then again I stopped fighting systemd on there.

In your case however, I agree with others suggesting to add keyboard and mouse in make.conf INPUT_DEVICES, and possibly also add AutoAddDevices" "false" in xorg.conf ServerLayout section.
Back to top
View user's profile Send private message
maruru
n00b
n00b


Joined: 22 Sep 2015
Posts: 11

PostPosted: Mon Nov 02, 2015 10:28 am    Post subject: Reply with quote

Thank you a lot for your quick answers!
- evdev is enabled in the kernel
- I am using eudev, hence I have `udev` in my USE flags (I rebuilt everything after configuring my USE flags)
- How do I disable hotplugging? Why should it be disabled (does eudev manage hotplugging for xorg)? Why is it enabled even though I use eudev (If I understand you corrctly, hotplugging should be disabled for me)?
I will test all other suggestions tonight (I am at work right now) :)
_________________
Vote for better password security on Gentoo Forums!
Unsalted MD5 and sent as plaintext via mail is just the worst :/
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2886
Location: Illinois, USA

PostPosted: Mon Nov 02, 2015 2:51 pm    Post subject: Reply with quote

maruru wrote:
Thank you a lot for your quick answers!
- evdev is enabled in the kernel
- I am using eudev, hence I have `udev` in my USE flags (I rebuilt everything after configuring my USE flags)
- How do I disable hotplugging? Why should it be disabled (does eudev manage hotplugging for xorg)? Why is it enabled even though I use eudev (If I understand you corrctly, hotplugging should be disabled for me)?
I will test all other suggestions tonight (I am at work right now) :)


Is udev running? udev turns of hot plugging yet X says it's on. See the line " echo "" >/proc/sys/kernel/hotplug" in /etc/init.d/udev.

Try "rc-update | grep udev" to see if it is scheduled by openrc. If it is try "/etc/init.d/udev start" If it is already running then it should come back with "already started".
Back to top
View user's profile Send private message
maruru
n00b
n00b


Joined: 22 Sep 2015
Posts: 11

PostPosted: Mon Nov 02, 2015 5:54 pm    Post subject: Reply with quote


  • I removed the InputDevice sections -> still no keyboard/mouse.
  • INPUT_DEVICES="keyboard mouse" didn't change anything (so I put back evdev
  • emerge -pv virtual/udev
    Code:

    [ebuild   R    ] virtual/udev-215::gentoo  USE="-systemd" 0 KiB

  • emerge -pv xorg-x11
    Code:

    [ebuild   R    ] x11-base/xorg-x11-7.4-r2::gentoo  0 KiB

  • emerge -pv xorg-server
    Code:

    [ebuild   R    ] x11-base/xorg-server-1.16.4:0/1.16.1::gentoo  USE="glamor ipv6 nptl static-libs suid udev wayland xorg -dmx -doc -kdrive -minimal (-selinux) -systemd -tslib -unwind -xnest -xvfb" 0 KiB

  • `AutoAddDevices "false"` results in a `(EE) no screens found(EE)` error.
  • udev is scheduled by openrc and running.

_________________
Vote for better password security on Gentoo Forums!
Unsalted MD5 and sent as plaintext via mail is just the worst :/
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Nov 02, 2015 8:00 pm    Post subject: Reply with quote

Once again, x11-base/xorg-x11 is a useless metapackage, so that part proves nothing.

Yet, going by useflags on xorg-server, even with eudev things should work.

So, check if input devices are correctly marked by udev, xf86-input-evdev is installed and the content of xorg log once it is.
Back to top
View user's profile Send private message
maruru
n00b
n00b


Joined: 22 Sep 2015
Posts: 11

PostPosted: Mon Nov 02, 2015 8:19 pm    Post subject: Reply with quote

well.. just found out something very interesting!
I have 2 monitors connected at the moment (the second one being an Apple Cinematic; this one has already caused me some BIOS trouble a few years ago).
When I disconnect the second one, keyboard and mouse work!


btw, cat /dev/input/mice` and then CTRL+C kinda breaks the terminal by replacing all sorts of characters with (random?) ascii chars. Is that normal?
_________________
Vote for better password security on Gentoo Forums!
Unsalted MD5 and sent as plaintext via mail is just the worst :/
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Mon Nov 02, 2015 8:27 pm    Post subject: Reply with quote

maruru,

maruru wrote:
btw, cat /dev/input/mice` and then CTRL+C kinda breaks the terminal by replacing all sorts of characters with (random?) ascii chars. Is that normal?


Yes. Do not look at the display. Type reset in the affected terminal and press return.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 618

PostPosted: Tue Nov 03, 2015 5:05 am    Post subject: Reply with quote

sounds like you are making progress, but I'm not sure if it was clear, after changing INPUT_DEVICES, you should:

Code:
emerge --update --deep --changed-use --with-bdeps y @world


or, more directly

Code:
emerge -1 x11-base/xorg-drivers
Back to top
View user's profile Send private message
maruru
n00b
n00b


Joined: 22 Sep 2015
Posts: 11

PostPosted: Tue Nov 03, 2015 8:12 pm    Post subject: Reply with quote

russK wrote:
sounds like you are making progress, but I'm not sure if it was clear, after changing INPUT_DEVICES, you should:

Code:
emerge --update --deep --changed-use --with-bdeps y @world


or, more directly

Code:
emerge -1 x11-base/xorg-drivers

Yeah, did just that. But it still does not work when both monitors are attached. Do I have to add the second screen to the xorg.conf somehow?
_________________
Vote for better password security on Gentoo Forums!
Unsalted MD5 and sent as plaintext via mail is just the worst :/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum