Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfce 4.12 Alt<F2> keyboard shortcut not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 237

PostPosted: Wed Apr 15, 2015 12:35 pm    Post subject: xfce 4.12 Alt<F2> keyboard shortcut not working Reply with quote

well, the title is pretty self explanatory.
some keyboard shortcuts working, some don't. Alt<F2> is binded to "xfce4-appfinder --collapsed" <- this is the default yet it doesn't work...

Have tried to delete /home/USER/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml had no effect, also tried deleting /home/USER/.cache/sessions again to no avail...

can someone help please?
Back to top
View user's profile Send private message
ferrelas
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2008
Posts: 107

PostPosted: Thu Apr 16, 2015 2:01 am    Post subject: Reply with quote

This may sound stupid, but have you checked that you can run the command from a console?

Even if it fails it may give you a hint on what's wrong.
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 237

PostPosted: Thu Apr 16, 2015 6:38 am    Post subject: Reply with quote

ferrelas wrote:
This may sound stupid, but have you checked that you can run the command from a console?

Even if it fails it may give you a hint on what's wrong.

Ain't stupid at all IMO, actually it was the first thing I checked... (it works with no errors)
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 237

PostPosted: Sun Apr 26, 2015 3:14 pm    Post subject: Reply with quote

OK, I got much closer at resolving the problem now, I have emerged xfconf with debug use-flag and now I see the many errors I actually have, for instance:

Code:
(xfce4-appearance-settings:1304): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():442: Property "/Xft/DPI" does not exist on channel "xsettings"


though this property is present at ~/.config/xfce4/xfconf/xsettings.xml for some reason when listing xfconf via command line it actually doesn't show:

Code:
$ xfconf-query -c xsettings -l
/Gtk/ButtonImages
/Gtk/CanChangeAccels
/Gtk/ColorPalette
/Gtk/CursorThemeName
/Gtk/CursorThemeSize
/Gtk/DecorationLayout
/Gtk/FontName
/Gtk/IconSizes
/Gtk/KeyThemeName
/Gtk/MenuBarAccel
/Gtk/MenuImages
/Gtk/ToolbarIconSize
/Gtk/ToolbarStyle
/Net/CursorBlink
/Net/CursorBlinkTime
/Net/DndDragThreshold
/Net/DoubleClickDistance
/Net/DoubleClickTime
/Net/EnableEventSounds
/Net/EnableInputFeedbackSounds
/Net/SoundThemeName
/Net/ThemeName
/Xft/Antialias
/Xft/Hinting
/Xft/HintStyle
/Xft/RGBA
l


Now does anyone knows what's the best way to resolve this issue?
Back to top
View user's profile Send private message
jhon987
Apprentice
Apprentice


Joined: 18 Nov 2013
Posts: 237

PostPosted: Sun Nov 01, 2015 6:16 pm    Post subject: Solved Reply with quote

The culprit was Nvidia configuration I added in /etc/profile.d: export __GL_THREADED_OPTIMIZATIONS=1
Removed it and now things are back to normal
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum