Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Samba doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
fourth
n00b
n00b


Joined: 26 Nov 2004
Posts: 48

PostPosted: Mon Oct 26, 2015 5:07 am    Post subject: [SOLVED] Samba doesn't work Reply with quote

Two problems I just had in setting up samba, where I had to do something different to the guide


Code:
mount error: cifs filesystem not supported by the system


To get past this problem after days of mucking around I was browsing the kernel and saw 'FUSE' scroll past. I recalled someone saying something about userspace filesystems, so enabled it just to see what happens, and it worked.

Code:
mount error(121): Remote I/O error


This one was easier, as it was over on linuxquestions, but an odd fix:

http://www.linuxquestions.org/questions/linux-server-73/mount-cifs-cannot-allocate-memory-or-remote-i-o-error-after-data-transfer-4175508385/
Quote:
If anyone is experiencing similar problem then here is solution:
http://boinst.wordpress.com/2012/03/...windows-share/

This is Windows problem and following registry values need to be changed:
Code:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache - set it to 1
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size - set it to 3

Restart service "Server"


I had to modify the windows server end. Hope this helps someone.
Back to top
View user's profile Send private message
gordonb3
Apprentice
Apprentice


Joined: 01 Jul 2015
Posts: 185

PostPosted: Mon Oct 26, 2015 8:10 am    Post subject: Reply with quote

That sounds like a very bad advice.

The LargeSystemCache parameter in Windows is not about providing sufficient cache for big files, but for allowing file cache to allocate a significant amount of memory. On 32 bit systems this is limited to 2G, like any other process, but on 64 bit systems this can eventually grab just about all of the internal memory. As this is a high priority process that does not release memory at any time this means that every other process on the machine will gradually come to a stall.

Enabling LargeSystemCache is strictly for servers (and is in fact the default) and should not be used on desktop systems. That said, investigating my (virtual) win7 machine here I found an undocumented combination of the LargeSystemCache and Size settings, with Size being set to "1" which indicates the "Minimize memory" configuration if LargeSystemCache is set to "0". If the problem is in fact with the Windows file sharing service, although I suspect it will be more of a timing issue in the CIFS client, changing Size to "2" (which is the "Balance" configuration) will likely fix the issue as well without turning the Windows PC into a brick.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum