Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
postfix ignoring communication when using FQDN[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Oct 25, 2015 1:58 am    Post subject: postfix ignoring communication when using FQDN[solved] Reply with quote

problems with mail server
I have setup postfix as an MDA, I'm using bind as my name server for the mx entry, here's my zone file:
$TTL 2d
@ IN SOA ns.example.com. root.example.com. (
2015102501 ; serial
3h ; refresh
1h ; retry
1w ; expiry
1d ) ; minimum

example.com. IN NS ns.example.com.
example. IN TXT "v=spf1 mx ptr mx:mail.example.com ~all"
example.com. IN MX 0 mail.example.com.
www.example.com. IN A 192.168.1.3
ns.example.com. IN A 192.168.1.3
mail.example.com. IN A 192.168.1.3


I can successfully ping mail.example.com (which I'm trying to send an email to)
I get a connection refused though when I try to send the email:
9BF8CC20D5A5: to=<root@mail.example.com>, relay=none, delay=6989, delays=6989/0.02/0/0, dsn=4.4.1, status=deferred (connect to mail.example.com[192.168.1.3]:25: Connection refused)


If I telnet to the machine using the mail.example.com name I get a connection refused, If I telnet to port 25 using the IP or a hostname in the /etc/hosts I can connect to the port just fine


here's my postfix config:
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost, example.com

mynetworks = 0.0.0.0/0


I'm using mutt to send the emails


thanks


Last edited by Adel Ahmed on Sun Oct 25, 2015 11:57 am; edited 1 time in total
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Sun Oct 25, 2015 9:26 am    Post subject: Re: postfix ignoring communication when using FQDN Reply with quote

Adel Ahmed wrote:
If I telnet to the machine using the mail.example.com name I get a connection refused, If I telnet to port 25 using the IP or a hostname in the /etc/hosts I can connect to the port just fine


I believe it when I see it.
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Oct 25, 2015 11:55 am    Post subject: Reply with quote

and you shouldn't, I was copying the output and I've noticed in the zone file a mostyped ip address which mistfortinately did exist in the external network(I use natting), so yeah
I was hallucinating for a bit there
nevermind this post
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum