Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE & Compiz, no window borders
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Oct 22, 2015 5:09 pm    Post subject: XFCE & Compiz, no window borders Reply with quote

Good afternoon all!

I've recently installed gentoo onto an office computer (I've been away from Gentoo for a very long time) with XFCE4, I installed Compiz from the wiki, started Compiz and I have no window borders. I had this issue before and I just can't remember how to fix this issue. Any help is very much appreciated!
Back to top
View user's profile Send private message
Myu
Apprentice
Apprentice


Joined: 22 Oct 2014
Posts: 162
Location: Belgium

PostPosted: Thu Oct 22, 2015 5:32 pm    Post subject: Reply with quote

Good afternoon,

You need to emerge emerald in order to get the windows borders right.

Code:
x11-wm/emerald
     Available versions:  ~0.8.8
     Homepage:            http://www.compiz.org/
     Description:         Emerald Window Decorator


and then

Code:

emerald --replace
should do the trick.

If it doesn't work, check on ccsm that emerald is well set as the window decorator command.

Hope this helps :)
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Oct 22, 2015 5:53 pm    Post subject: Reply with quote

Like I said previously, I used the gentoo wiki
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Oct 22, 2015 6:12 pm    Post subject: Reply with quote

So I did get the window borders, but now my panel is gone :-(
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Oct 22, 2015 6:23 pm    Post subject: Reply with quote

Got the panel back (seems when I start conky, which is just a black background, my panel disappears), but now I have no borders
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Oct 22, 2015 7:11 pm    Post subject: Reply with quote

So it seems that I needed to add compiz and emerald commands in the autostart tab in settings manager. No idea why that worked over terminal, or what I was doing different but *shrugs.* My next issue is that it doesn't want to work with conky.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum