Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KMail stopped sending messages: Host not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kkrizka
n00b
n00b


Joined: 30 Jul 2007
Posts: 30

PostPosted: Thu Oct 22, 2015 11:42 am    Post subject: KMail stopped sending messages: Host not found Reply with quote

Dear all,

All of a sudden, kmail decided to stop sending messages. Every email I try to send with the following error:

Code:
Failed to transport message. smtp.googlemail.com: Host not found


I cannot send through other smtp servers either, so I don't think it is problem with GMail. Also I have not changed the configuration for a long time, so I don't think I set something wrong. Receiving messages via IMAP and rest of internet still works.

Any idea what could be wrong?

I am using KMail 4.14.10.

--
Karol Krizka
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Fri Oct 23, 2015 2:12 am    Post subject: Reply with quote

Open a console and check it with dig.
Code:
dig smtp.googlemail.com


and check your /etc/resolv.conf and be sure it is correct.

George
Back to top
View user's profile Send private message
kkrizka
n00b
n00b


Joined: 30 Jul 2007
Posts: 30

PostPosted: Fri Oct 23, 2015 10:41 am    Post subject: Reply with quote

I am not sure what I should look for in the output of dig, but it seems reasonable. Also my /etc/resolv.conf is set the same as other machines on the network.

Code:

kkrizka@tiny101 ~ $ dig smtp.googlemail.com

; <<>> DiG 9.10.3 <<>> smtp.googlemail.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11979
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 4, ADDITIONAL: 5

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;smtp.googlemail.com.           IN      A

;; ANSWER SECTION:
smtp.googlemail.com.    600     IN      CNAME   googlemail-smtp.l.google.com.
googlemail-smtp.l.google.com. 300 IN    A       173.194.67.16

;; AUTHORITY SECTION:
google.com.             5699    IN      NS      ns2.google.com.
google.com.             5699    IN      NS      ns4.google.com.
google.com.             5699    IN      NS      ns1.google.com.
google.com.             5699    IN      NS      ns3.google.com.

;; ADDITIONAL SECTION:
ns1.google.com.         21780   IN      A       216.239.32.10
ns2.google.com.         54266   IN      A       216.239.34.10
ns3.google.com.         17858   IN      A       216.239.36.10
ns4.google.com.         54266   IN      A       216.239.38.10

;; Query time: 36 msec
;; SERVER: 137.138.17.5#53(137.138.17.5)
;; WHEN: Fri Oct 23 12:40:19 CEST 2015
;; MSG SIZE  rcvd: 239
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Fri Oct 23, 2015 8:35 pm    Post subject: Reply with quote

Well that is different, you might try removing and resetting up the account in Kmail.

but it does not make sense.... 8O
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Fri Oct 23, 2015 10:33 pm    Post subject: Reply with quote

I did see the message in the last week or so, I assumed that my internet connection was flakey and did

File > Send Queued Messages

and all was good thereafter. Of course it may be unrelated?
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1717

PostPosted: Sat Oct 24, 2015 10:16 pm    Post subject: Reply with quote

Quote:
Failed to transport message. smtp.googlemail.com: Host not found
Smells like broken DNS. Happens. And sometimes even get fixed in a day or two, when cache is flushed and re-populated with up-to-date content.
Back to top
View user's profile Send private message
kkrizka
n00b
n00b


Joined: 30 Jul 2007
Posts: 30

PostPosted: Wed Oct 28, 2015 12:19 pm    Post subject: Reply with quote

File -> Send Queued Messages trick from baaann resulted in the same error.

Also when I setup my email accounts in Thunderbird, that client has no trouble sending messages.

Is it possible that some library kmail uses for network communication is broken?
Back to top
View user's profile Send private message
kkrizka
n00b
n00b


Joined: 30 Jul 2007
Posts: 30

PostPosted: Thu Oct 29, 2015 8:44 am    Post subject: Reply with quote

A reboot fixed this problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum