Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can not start fluxbox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Mon Oct 12, 2015 1:56 pm    Post subject: Can not start fluxbox Reply with quote

Hi,

When I startx, fluxbox give me something like these:

Code:

------------------------------------------
Log File: /root/.fluxbox/log
Fluxbox version: 1.3.7-gentoo-r2
GIT Revision: unknown
Compiled: Oct 11 2015 20:21:13
Compiler: GCC
Compiler version: 4.9.3

Defaults:
       menu: /usr/share/fluxbox/menu
 windowmenu: /usr/share/fluxbox/windowmenu
      style: /usr/share/fluxbox/styles/Emerge
       keys: /usr/share/fluxbox/keys
       init: /usr/share/fluxbox/init

Compiled options (- => disabled):
-BIDI
-DEBUG
EWMH
IMLIB2
-NLS
REMEMBER
RENDER
SHAPE
-SLIT
SYSTEMTRAY
TOOLBAR
RANDR
XFT
-XINERAMA
XMB
XPM

------------------------------------------
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.forcePseudoTransparency
Setting default value
Failed to read: session.colorsPerChannel
Setting default value
Failed to read: session.doubleClickInterval
Setting default value
Failed to read: session.tabPadding
Setting default value
Failed to read: session.styleOverlay
Setting default value
Failed to read: session.slitlistFile
Setting default value
Failed to read: session.appsFile
Setting default value
Failed to read: session.tabsAttachArea
Setting default value
Failed to read: session.menuSearch
Setting default value
Failed to read: session.cacheLife
Setting default value
Failed to read: session.cacheMax
Setting default value
Failed to read: session.autoRaiseDelay
Setting default value
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.forcePseudoTransparency
Setting default value
Failed to read: session.colorsPerChannel
Setting default value
Failed to read: session.doubleClickInterval
Setting default value
Failed to read: session.tabPadding
Setting default value
Failed to read: session.styleOverlay
Setting default value
Failed to read: session.slitlistFile
Setting default value
Failed to read: session.appsFile
Setting default value
Failed to read: session.tabsAttachArea
Setting default value
Failed to read: session.menuSearch
Setting default value
Failed to read: session.cacheLife
Setting default value
Failed to read: session.cacheMax
Setting default value
Failed to read: session.autoRaiseDelay
Setting default value
Failed to read: session.screen0.opaqueMove
Setting default value
Failed to read: session.screen0.fullMaximization
Setting default value
Failed to read: session.screen0.maxIgnoreIncrement
Setting default value
Failed to read: session.screen0.maxDisableMove
Setting default value
Failed to read: session.screen0.maxDisableResize
Setting default value
Failed to read: session.screen0.workspacewarping
Setting default value
Failed to read: session.screen0.showwindowposition
Setting default value
Failed to read: session.screen0.autoRaise
Setting default value
Failed to read: session.screen0.clickRaises
Setting default value
Failed to read: session.screen0.defaultDeco
Setting default value
Failed to read: session.screen0.tab.placement
Setting default value
Failed to read: session.screen0.windowMenu
Setting default value
Failed to read: session.screen0.noFocusWhileTypingDelay
Setting default value
Failed to read: session.screen0.workspaces
Setting default value
Failed to read: session.screen0.edgeSnapThreshold
Setting default value
Failed to read: session.screen0.window.focus.alpha
Setting default value
Failed to read: session.screen0.window.unfocus.alpha
Setting default value
Failed to read: session.screen0.menu.alpha
Setting default value
Failed to read: session.screen0.menuDelay
Setting default value
Failed to read: session.screen0.tab.width
Setting default value
Failed to read: session.screen0.tooltipDelay
Setting default value
Failed to read: session.screen0.allowRemoteActions
Setting default value
Failed to read: session.screen0.clientMenu.usePixmap
Setting default value
Failed to read: session.screen0.tabs.usePixmap
Setting default value
Failed to read: session.screen0.tabs.maxOver
Setting default value
Failed to read: session.screen0.tabs.intitlebar
Setting default value
Failed to read: session.screen0.focusModel
Setting default value
Failed to read: session.screen0.tabFocusModel
Setting default value
Failed to read: session.screen0.focusNewWindows
Setting default value
Failed to read: session.screen0.rowPlacementDirection
Setting default value
Failed to read: session.screen0.colPlacementDirection
Setting default value
Failed to read: session.screen0.windowPlacement
Setting default value
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.forcePseudoTransparency
Setting default value
Failed to read: session.colorsPerChannel
Setting default value
Failed to read: session.doubleClickInterval
Setting default value
Failed to read: session.tabPadding
Setting default value
Failed to read: session.styleOverlay
Setting default value
Failed to read: session.slitlistFile
Setting default value
Failed to read: session.appsFile
Setting default value
Failed to read: session.tabsAttachArea
Setting default value
Failed to read: session.menuSearch
Setting default value
Failed to read: session.cacheLife
Setting default value
Failed to read: session.cacheMax
Setting default value
Failed to read: session.autoRaiseDelay
Setting default value
Failed to read: session.screen0.opaqueMove
Setting default value
Failed to read: session.screen0.fullMaximization
Setting default value
Failed to read: session.screen0.maxIgnoreIncrement
Setting default value
Failed to read: session.screen0.maxDisableMove
Setting default value
Failed to read: session.screen0.maxDisableResize
Setting default value
Failed to read: session.screen0.workspacewarping
Setting default value
Failed to read: session.screen0.showwindowposition
Setting default value
Failed to read: session.screen0.autoRaise
Setting default value
Failed to read: session.screen0.clickRaises
Setting default value
Failed to read: session.screen0.defaultDeco
Setting default value
Failed to read: session.screen0.tab.placement
Setting default value
Failed to read: session.screen0.windowMenu
Setting default value
Failed to read: session.screen0.noFocusWhileTypingDelay
Setting default value
Failed to read: session.screen0.workspaces
Setting default value
Failed to read: session.screen0.edgeSnapThreshold
Setting default value
Failed to read: session.screen0.window.focus.alpha
Setting default value
Failed to read: session.screen0.window.unfocus.alpha
Setting default value
Failed to read: session.screen0.menu.alpha
Setting default value
Failed to read: session.screen0.menuDelay
Setting default value
Failed to read: session.screen0.tab.width
Setting default value
Failed to read: session.screen0.tooltipDelay
Setting default value
Failed to read: session.screen0.allowRemoteActions
Setting default value
Failed to read: session.screen0.clientMenu.usePixmap
Setting default value
Failed to read: session.screen0.tabs.usePixmap
Setting default value
Failed to read: session.screen0.tabs.maxOver
Setting default value
Failed to read: session.screen0.tabs.intitlebar
Setting default value
Failed to read: session.screen0.focusModel
Setting default value
Failed to read: session.screen0.tabFocusModel
Setting default value
Failed to read: session.screen0.focusNewWindows
Setting default value
Failed to read: session.screen0.rowPlacementDirection
Setting default value
Failed to read: session.screen0.colPlacementDirection
Setting default value
Failed to read: session.screen0.windowPlacement
Setting default value
Failed to read: session.screen0.toolbar.autoHide
Setting default value
Failed to read: session.screen0.toolbar.maxOver
Setting default value
Failed to read: session.screen0.toolbar.visible
Setting default value
Failed to read: session.screen0.toolbar.widthPercent
Setting default value
Failed to read: session.screen0.toolbar.alpha
Setting default value
Failed to read: session.screen0.toolbar.layer
Setting default value
Failed to read: session.screen0.toolbar.onhead
Setting default value
Failed to read: session.screen0.toolbar.placement
Setting default value
Failed to read: session.screen0.toolbar.height
Setting default value
Failed to read: session.screen0.toolbar.tools
Setting default value
Failed to read: session.screen0.iconbar.mode
Setting default value
Failed to read: session.screen0.iconbar.alignment
Setting default value
Failed to read: session.screen0.iconbar.iconWidth
Setting default value
Failed to read: session.screen0.iconbar.iconTextPadding
Setting default value
Failed to read: session.screen0.iconbar.usePixmap
Setting default value
Failed to read: session.screen0.strftimeFormat
Setting default value
Failed to read: session.screen0.titlebar.left
Setting default value
Failed to read: session.screen0.titlebar.right
Setting default value
Fluxbox: XIOError: lost connection to display.


And my xorg.conf(by nvidia-config, I just add BusId).
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 355.11  (buildmeister@swio-display-x64-rhel04-01)  Wed Aug 26 17:22:01 PDT 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
   BusId          "1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


use nouveau and dmesg about nvidia
Code:

[    5.391694] nvidia: module license 'NVIDIA' taints kernel.
[    5.391699] Disabling lock debugging due to kernel taint
[    5.400390] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    5.400462] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[    5.400683] NVLINK: Nvlink Core is being initialized, major device number 248
[    5.400864] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 1
[    5.400869] NVRM: loading NVIDIA UNIX x86 Kernel Module  355.11  Wed Aug 26 15:34:56 PDT 2015
[    5.646313] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646346] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646360] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646373] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646385] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646468] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.646481] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    5.700185] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    6.115068] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
[    6.116192] nvidia-smi (2490) used greatest stack depth: 5620 bytes left


Then I installed blackbox to see if X problem there. just black screen like fluxbox and give me something like these:
Code:

blockbox: managing screen 0 using TrueColor visual 0x21, depth 24
Warning: missing charset 'JISX0208.1983-0' in fontset
Warning: missing charset 'KSC5601.1987-0' in fontset
...


I tried to use nvidia-drivers instead of nouveau, show the same result.
I don't want to give up just when I open to talk with her.
So I post this topic, maybe an noise :-).

Thanks in advance and Best Regards

Thanks
tzhou
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Mon Oct 12, 2015 2:40 pm    Post subject: Reply with quote

Please pastebin your /var/log/Xorg.0.log
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Tue Oct 13, 2015 1:07 pm    Post subject: Reply with quote

charles17 wrote:
Please pastebin your /var/log/Xorg.0.log


Here is my /var/log/Xorg.0.log
https://bpaste.net/show/719b422c6043

Thanks for your reply!
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Sun Oct 18, 2015 12:17 pm    Post subject: Reply with quote

Hi,

I reinstalled gentoo on my box refer to handbook.
Followed gentoo NVidia/nvidia-drivers and Xorg/Guide wiki.

When startx, I get
Quote:
twm: warning: font for charset GB2312.1980-0 is lacking...

and follow https://forums.gentoo.org/viewtopic.php?p=3643250 to solve it.

Then I startx, get black screen.

/var/log/Xorg.0.log.
https://bpaste.net/show/83a91d39ba6a
lspci:
https://bpaste.net/show/371e5b05b516
kernel's .config
https://bpaste.net/show/2e0f8d887eea

I think maybe it is not fluxbox problem, so my subject is wrong here, sorry about that.
When I first post the topic, I mostly forget to use wgetpaste to paste it.
So, here it is. My box is lenovo E49.


Thanks and Regards
tzhou
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sun Oct 18, 2015 1:36 pm    Post subject: Reply with quote

tzhou wrote:
Hi,

I reinstalled gentoo on my box refer to handbook.
Followed gentoo NVidia/nvidia-drivers and Xorg/Guide wiki.

When startx, I get
Quote:
twm: warning: font for charset GB2312.1980-0 is lacking...

and follow https://forums.gentoo.org/viewtopic.php?p=3643250 to solve it.

Then I startx, get black screen.

How did you mean to start fluxbox? Global setting in /etc/env.d/90xsession or per-user setting in ~/.xinitrc ?
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Sun Oct 18, 2015 2:28 pm    Post subject: Reply with quote

charles17 wrote:
tzhou wrote:
Hi,

I reinstalled gentoo on my box refer to handbook.
Followed gentoo NVidia/nvidia-drivers and Xorg/Guide wiki.

When startx, I get
Quote:
twm: warning: font for charset GB2312.1980-0 is lacking...

and follow https://forums.gentoo.org/viewtopic.php?p=3643250 to solve it.

Then I startx, get black screen.

How did you mean to start fluxbox? Global setting in /etc/env.d/90xsession or per-user setting in ~/.xinitrc ?


Hi, charles17

I start fluxbox in ~/.xinitrc.

Today, I reinstalled gentoo and didn't install fluxbox and used /etc/X11/xinit/xinitrc to exec twm.
I got black screen.
twm quoted here is about what happened when startx.
After I followed that link to resolve twm problem and startx, get black screen.

*Now*, I'm starting to install fluxbox(start fluxbox in ~/.xinitrc) and get the same result: black screen.
fluxbox log:
https://bpaste.net/show/467141f20c4e

Thanks
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2867
Location: Illinois, USA

PostPosted: Sun Oct 18, 2015 6:08 pm    Post subject: Reply with quote

I run fluxbox from xdm with no problem.

Quote:
[ebuild R ] x11-wm/fluxbox-1.3.7-r2::gentoo USE="imlib truetype -bidi -nls -slit -systray -toolbar -vim-syntax -xinerama"
[ebuild R ] x11-apps/xdm-1.1.11-r3::gentoo USE="ipv6 pam -consolekit -xdm-auth"
[ebuild R ] x11-base/xorg-x11-7.4-r2::gentoo

X3 ~ # uname -r
4.0.5-gentoo


Can you use startx to start xterm? If not, the problem is in your X setup.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2867
Location: Illinois, USA

PostPosted: Sun Oct 18, 2015 6:12 pm    Post subject: Reply with quote

tzhou wrote:
Hi,

I reinstalled gentoo on my box refer to handbook.


Generally a waste of time if you can boot into the system.

Are you using systemd, by any chance?
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Mon Oct 19, 2015 1:23 am    Post subject: Reply with quote

Quote:

Can you use startx to start xterm? If not, the problem is in your X setup.


Hi.

I can't use startx to start xterm.
So, it is X problem.
I followed nvidia-driver and Xorg wiki.
Sorry for my confusion.

Thanks.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Mon Oct 19, 2015 1:33 am    Post subject: Reply with quote

Quote:


Generally a waste of time if you can boot into the system.

Are you using systemd, by any chance?


If I get you right, I use openRC.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2867
Location: Illinois, USA

PostPosted: Mon Oct 19, 2015 1:35 am    Post subject: Reply with quote

Check your kernel to make sure nvidia is a module and you have not enabled both nvidia AND nouveau.

Try:
zcat /proc/config.gz | grep -i nvidia
and
zcat /proc/config.gz | grep -i nouveau

This is contingent on the config being in the kernel which I hope is the gentoo default. If it's not, you will probably get a message like "/proc/config.gz no such file".

Also rename your xorg.conf to xorg.conf.bak to let xorg figure out the config itself. That's counter-intuitive but usually results in a working configuration.

EDIT: It's zcat not cat. I must be too tired.

Example (from an ati system):
tony@X3 ~ $ zcat /proc/config.gz |grep -i nvidia
# CONFIG_NET_VENDOR_NVIDIA is not set
# CONFIG_FB_NVIDIA is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i nouveau
# CONFIG_DRM_NOUVEAU is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i radeon
CONFIG_EXTRA_FIRMWARE="v4l-cx23418-enc.fw radeon/R600_rlc.bin radeon/RS780_uvd.bin"
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_USERPTR is not set
# CONFIG_DRM_RADEON_UMS is not set
# CONFIG_FB_RADEON is not set

Another example (from an nvidia system):
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nvidia
CONFIG_NET_VENDOR_NVIDIA=y
# CONFIG_FB_NVIDIA is not set
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nouveau
CONFIG_DRM_NOUVEAU=m
CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=3
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
In this case CONFIG_NET_VENDOR_NVIDIA refers to the on-board ethernet not the video.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Mon Oct 19, 2015 2:11 am    Post subject: Reply with quote

Tony0945 wrote:
Check your kernel to make sure nvidia is a module and you have not enabled both nvidia AND nouveau.

Try:
zcat /proc/config.gz | grep -i nvidia
and
zcat /proc/config.gz | grep -i nouveau

This is contingent on the config being in the kernel which I hope is the gentoo default. If it's not, you will probably get a message like "/proc/config.gz no such file".

Also rename your xorg.conf to xorg.conf.bak to let xorg figure out the config itself. That's counter-intuitive but usually results in a working configuration.

EDIT: It's zcat not cat. I must be too tired.

Example (from an ati system):
tony@X3 ~ $ zcat /proc/config.gz |grep -i nvidia
# CONFIG_NET_VENDOR_NVIDIA is not set
# CONFIG_FB_NVIDIA is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i nouveau
# CONFIG_DRM_NOUVEAU is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i radeon
CONFIG_EXTRA_FIRMWARE="v4l-cx23418-enc.fw radeon/R600_rlc.bin radeon/RS780_uvd.bin"
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_USERPTR is not set
# CONFIG_DRM_RADEON_UMS is not set
# CONFIG_FB_RADEON is not set

Another example (from an nvidia system):
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nvidia
CONFIG_NET_VENDOR_NVIDIA=y
# CONFIG_FB_NVIDIA is not set
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nouveau
CONFIG_DRM_NOUVEAU=m
CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=3
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
In this case CONFIG_NET_VENDOR_NVIDIA refers to the on-board ethernet not the video.


Thanks for your quick and detailed reply. have a good rest.
The box is not in hand, I will check all these.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Mon Oct 19, 2015 1:52 pm    Post subject: Reply with quote

Tony0945 wrote:
Check your kernel to make sure nvidia is a module and you have not enabled both nvidia AND nouveau.

Try:
zcat /proc/config.gz | grep -i nvidia
and
zcat /proc/config.gz | grep -i nouveau

This is contingent on the config being in the kernel which I hope is the gentoo default. If it's not, you will probably get a message like "/proc/config.gz no such file".

Also rename your xorg.conf to xorg.conf.bak to let xorg figure out the config itself. That's counter-intuitive but usually results in a working configuration.

EDIT: It's zcat not cat. I must be too tired.

Example (from an ati system):
tony@X3 ~ $ zcat /proc/config.gz |grep -i nvidia
# CONFIG_NET_VENDOR_NVIDIA is not set
# CONFIG_FB_NVIDIA is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i nouveau
# CONFIG_DRM_NOUVEAU is not set
tony@X3 ~ $ zcat /proc/config.gz |grep -i radeon
CONFIG_EXTRA_FIRMWARE="v4l-cx23418-enc.fw radeon/R600_rlc.bin radeon/RS780_uvd.bin"
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_USERPTR is not set
# CONFIG_DRM_RADEON_UMS is not set
# CONFIG_FB_RADEON is not set

Another example (from an nvidia system):
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nvidia
CONFIG_NET_VENDOR_NVIDIA=y
# CONFIG_FB_NVIDIA is not set
guest@gentoo ~ $ zcat /proc/config.gz | grep -i nouveau
CONFIG_DRM_NOUVEAU=m
CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=3
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
In this case CONFIG_NET_VENDOR_NVIDIA refers to the on-board ethernet not the video.


Hi,

I emerged sys-kernel/gentoo-sources and manually config kernel.
I checked that the kernel does not enable access to config.gz by default.
Enable this and use cat /proc/config.gz | grep -i nvidia:
Code:

CONFIG_NET_VENDOR_NVIDIA=y
# CONFIG_AGP_NVIDIA is not set
# CONFIG_FB_NVIDIA is not set

cat /proc/config.gz | grep -i nouveau
Code:

# CONFIG_DRM_NOUVEAU is not set

lsmod
Code:

Module                  Size  Used by
nvidia               7763037  0
x86_pkg_temp_thermal     3759  0


The xorg.conf is created by nvidia-xconfig that is suggested in the Xorg guide.
Rename this xorg.conf to xorg.conf.bak and startx. I got the /var/log/Xorg.0.log:

https://bpaste.net/show/c64c5782a0fc

No new xorg.conf figured out by Xorg.

If my understand is wrong, please let me know. Thanks so much.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2867
Location: Illinois, USA

PostPosted: Mon Oct 19, 2015 4:34 pm    Post subject: Reply with quote

Quote:
[ 3749.548] (II) LoadModule: "nouveau"
[ 3749.549] (WW) Warning, couldn't open module nouveau
[ 3749.549] (II) UnloadModule: "nouveau"
[ 3749.549] (II) Unloading nouveau
[ 3749.549] (EE) Failed to load module "nouveau" (module does not exist, 0)


You have no module configured in your kernel, neither nvidia nor nouveau. Don't know where lsmod is finding one.

You need:
CONFIG_DRM_NOUVEAU=m

Rebuild the kernel with nouveau as a module. Reboot into the new kernel and try startx.

Quote:
No new xorg.conf figured out by Xorg.

That's because Xorg is trying every possible module for your hardware but can't find any of them.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Tue Oct 20, 2015 3:49 pm    Post subject: Reply with quote

Tony0945 wrote:
Quote:
[ 3749.548] (II) LoadModule: "nouveau"
[ 3749.549] (WW) Warning, couldn't open module nouveau
[ 3749.549] (II) UnloadModule: "nouveau"
[ 3749.549] (II) Unloading nouveau
[ 3749.549] (EE) Failed to load module "nouveau" (module does not exist, 0)


You have no module configured in your kernel, neither nvidia nor nouveau. Don't know where lsmod is finding one.

You need:
CONFIG_DRM_NOUVEAU=m

Rebuild the kernel with nouveau as a module. Reboot into the new kernel and try startx.

Quote:
No new xorg.conf figured out by Xorg.

That's because Xorg is trying every possible module for your hardware but can't find any of them.


Hi,

I followed this wiki
https://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching
to do switching between nvidia kernel and nouveau kernel(the first method only)

1, nouveau kernel:

zcat /proc/config.gz | grep -i nouveau:
Code:

CONFIG_DRM_NOUVEAU=m
CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=3
CONFIG_DRM_NOUVEAU_BACKLIGHT=y


lsmod:
Code:

Module                  Size  Used by
nouveau              1144021  0
ttm                    50276  1 nouveau
x86_pkg_temp_thermal     3759  0
wmi                     6771  1 nouveau


no xorg.conf there and startx. the /var/log/Xorg.0.log:
https://bpaste.net/show/c516cd45ea1f

2, nvidia kernel

zcat /proc/config.gz | grep -i nouveau:
Code:

CONFIG_LOCALVERSION="-nvidia"
CONFIG_NET_VENDOR_NVIDIA=y
# CONFIG_AGP_NVIDIA is not set
# CONFIG_FB_NVIDIA is not set


lsmod:
Code:

Module                  Size  Used by
nvidia               7763069  0
x86_pkg_temp_thermal     3759  0
wmi                     6771  0


no xorg.conf, use nvidia-xconfig to create one.
startx and black screen.
/var/log/Xorg.0.log:
https://bpaste.net/show/5af1097b72ff
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2867
Location: Illinois, USA

PostPosted: Tue Oct 20, 2015 4:05 pm    Post subject: Reply with quote

With the nvidia kernel, what happens when you run "startx xterm"?

BTW to keep from rebuilding when switching between kernels, on the menuconfig screen under "General Setup", there is a menu item "Local version - append to kernel release", you can use this two maintain two versions of the kernel with differing options and choose which to run at boot time. You can use whatever name you want, in this case I'd suggest "nvidia" and nouveau".

What video card or motherboard built in are you using? I have a GeForce 8400GS but I run nouveau because nvidia-drivers no longer supports this old board.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Tue Oct 20, 2015 4:27 pm    Post subject: Reply with quote

tzhou wrote:
no xorg.conf, use nvidia-xconfig to create one.
startx and black screen.

Black screen is the default for fluxbox, but you should also have the mouse cursor in the centre.
Does it stay in X or do you have to end X using ctrl+c?

tzhou wrote:
/var/log/Xorg.0.log:
https://bpaste.net/show/5af1097b72ff

What's confusing me here is
Quote:
[ 492.698] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 492.698] (WW) Disabling Keyboard0
[ 492.698] (WW) Disabling Mouse0

No mouse, no cursor. Does a touchpad right click affect something?
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Wed Oct 21, 2015 12:17 pm    Post subject: Reply with quote

Tony0945 wrote:
With the nvidia kernel, what happens when you run "startx xterm"?

Oh, my mistake, I start fluxbox in ~/.initrc. If don't start fluxbox and startx xterm, X is not successful and exit.

Quote:
BTW to keep from rebuilding when switching between kernels, on the menuconfig screen under "General Setup", there is a menu item "Local version - append to kernel release", you can use this two maintain two versions of the kernel with differing options and choose which to run at boot time. You can use whatever name you want, in this case I'd suggest "nvidia" and nouveau".

Yes, you are right. I did it in this way.

Quote:
What video card or motherboard built in are you using? I have a GeForce 8400GS but I run
nouveau because nvidia-drivers no longer supports this old board.

lspci and things about video card:

Code:
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev a1)


I can sucessfully install X and fluxbox on this box before, even though I am still a newer:(.
I REALLY don't know where I make a mistake.
Anyway, thanks.


Last edited by tzhou on Wed Oct 21, 2015 12:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Wed Oct 21, 2015 12:46 pm    Post subject: Reply with quote

charles17 wrote:

Black screen is the default for fluxbox, but you should also have the mouse cursor in the centre.
Does it stay in X or do you have to end X using ctrl+c?

Oh, my mistake, I start fluxbox in ~/.initrc. If don't start fluxbox and startx, X is not successful and exit.

charles17 wrote:
What's confusing me here is
charles17 wrote:
[ 492.698] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 492.698] (WW) Disabling Keyboard0
[ 492.698] (WW) Disabling Mouse0

No mouse, no cursor. Does a touchpad right click affect something?

Thanks for checking and forgive me. If X is not ok, fluxbox is also. So, It's not fluxbox problem. Or something about X configure, I don't know.

When startx(not start fluxbox), get this message and exit:
Code:

hostname: Unknown host
xauth:  file /root/.serverauth.2425 does not exist


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.0.5-gentoo-nvidia i686 Gentoo
Current Operating System: Linux pure 4.0.5-gentoo-nvidia #8 SMP Tue Oct 20 23:33:02 CST 2015 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.0.5-gentoo-nvidia root=/dev/sda4 ro
Build Date: 20 October 2015  10:55:03PM
 
Current version of pixman: 0.32.8
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 21 20:37:08 2015
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: connection to X server lost

waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Wed Oct 21, 2015 2:32 pm    Post subject: Reply with quote

tzhou wrote:
charles17 wrote:

Black screen is the default for fluxbox, but you should also have the mouse cursor in the centre.
Does it stay in X or do you have to end X using ctrl+c?

Oh, my mistake, I start fluxbox in ~/.initrc. If don't start fluxbox and startx, X is not successful and exit.

startx and ~/.xinitrc is not a contradiction. One can use ~/.xinitrx with both a display manager or startx.
Are you having exec startfluxbox in ~/.xinitrc?

tzhou wrote:
When startx(not start fluxbox), get this message and exit:
Code:

hostname: Unknown host
xauth:  file /root/.serverauth.2425 does not exist

But you didn't try startx as root, did you?
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Thu Oct 22, 2015 12:21 pm    Post subject: Reply with quote

charles17 wrote:

Are you having exec startfluxbox in ~/.xinitrc?

yes, I have.


charles17 wrote:

hostname: Unknown host
xauth: file /root/.serverauth.2425 does not exist[/code]

But you didn't try startx as root, did you?[/quote]
Yes, I did.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Thu Oct 22, 2015 1:19 pm    Post subject: Reply with quote

charles17 wrote:

Are you having exec startfluxbox in ~/.xinitrc?

yes, I have.


charles17 wrote:

hostname: Unknown host
xauth: file /root/.serverauth.2425 does not exist
But you didn't try startx as root, did you?

Yes, I did.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Thu Oct 22, 2015 2:02 pm    Post subject: Reply with quote

tzhou wrote:
Yes, I did.

You should never startx (run X) as root.
Retry with your "normal" user.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Thu Oct 22, 2015 3:48 pm    Post subject: Reply with quote

charles17 wrote:

You should never startx (run X) as root.
Retry with your "normal" user.


Good advice. I retry this and show the same result as root.
Back to top
View user's profile Send private message
tzhou
n00b
n00b


Joined: 11 Oct 2015
Posts: 18

PostPosted: Sun Dec 13, 2015 8:30 am    Post subject: Reply with quote

Hi,

I do not use nvidia-xconfig to generate xorg.conf and it works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum