Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-terminal doesn't start after upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Mon Oct 05, 2015 3:46 pm    Post subject: gnome-terminal doesn't start after upgrade Reply with quote

it is really strange,
Code:
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8
is an old issue. however,
Code:
dbus-launch gnome-terminal
has no such error and starts correctly. seems cinnamon isn't starting dbus correctly? or do I need to add dbus-launch everywhere in my cinnamon-menus? journalctl said
Code:
org.fedoraproject.Config.Printing[6493]: (scp-dbus-service.py:6750): Gtk-WARNING **: Locale not supported by C library.
and no other mention of dbus is available. did it even get started? what's the sense of giving a keyboard-layout to dbus when I can switch it anytime with a hotkey in cinnamon? will gnome-terminal then switch locale settings too?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Tue Oct 06, 2015 4:33 am    Post subject: Reply with quote

Cinnamon itself needs to be launched inside a dbus user session as well. That's the common dbus-launch --exit-with-session ... idiom if you use some minimal WM launched via xinitrc or something. But cinnamon should be launched via proper session handling, with no .xinitrc present, and it ought to do this from the startup files correctly then, even if XSESSION=Cinnamon startx or some such instead of gdm.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Tue Oct 06, 2015 10:27 am    Post subject: Reply with quote

it's a mystery to me how dbus is supposed to get started. I have gdm set up to automatically log me in at system-boot. my /etc/gdm/custom.conf:
Code:
[daemon]

AutomaticLogin=p
AutomaticLoginEnable=true
Greeter=/usr/lib/gdmlogin
GtkModulesList=gail:atk-bridge:/usr/lib/gtk-2.0/modules/libkeymouselistener:/usr/lib/gtk-2.0/modules/libdwellmouselistener
is what I always used for that purpose. (no cinnamon is mentioned here.) previously this was enough to start cinnamon with dbus, although the localization never worked. and also back then logging out did put me to gdm for choosing whatever window management. now logging out of cinnamon throws me to console! previously I could go from console to gdm by "systemctl start gdm", now I need to start gdmflexiserver for that. I just did try it and got error 1
Code:
Message: Failed to get session bus
before gdm started. now when I log in, locale is suddenly correct, same as on commandline. however, even when starting gdm that way, neither in gnome nor in cinnamon gnome-terminal does launch -- unless I add dbus-launcher in front of it...

I noticed the cinnamon wiki-page tells me to start dbus server manually by adding it to the systemd list. since dbus-launch works, I suppose I already did do that in past. or has that changed in the half year I refused to upgrade?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Wed Oct 07, 2015 11:20 pm    Post subject: Reply with quote

I'm not sure about the autologin things. Do things work if you don't have that custom.conf?
Systemd should always have system dbus session running for its own purposes - there's a system bus and then session buses.
Though with systemd it might want to start some of those on its own, especially if we're talking the slow conversion to user buses, instead of session buses,
so that it's shared between multiple sessions of the same user (like one from console and another from X or something).
Do things work without custom configuration, so we can maybe narrow it down to there?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Thu Oct 08, 2015 6:12 am    Post subject: Reply with quote

nope. I commented out everything in custom.conf. gnome-terminal still doesn't start, except within dbus-launch.

I'm using ordinary gnome-base/gdm-3.16.2 with unmasked x11-base/xorg-server-1.17.2-r1

as for dbus being shared among sessions, wouldn't that mean that "dbus-launch gnome-terminal" should enable other gnome-terminal launched from cinnamon not requiring another dbus-launch? for me this isn't true: I can start it with "gnome-terminal" only within the terminal, but not from elsewhere. in the cinnamon-menu I still need dbus-launch everytime, no matter if a dbus-launch gnome-terminal is running or not! I can even dbus-launch gnome-terminal once, and then write "gnome-terminal" on that commandline, close the window where I wrote that, and do another "gnome-terminal" in the new window, even though the original window is closed.

in other words, it seems my problem is one of environment-variables. I stored DBUS_SESSION_BUS_ADDRESS from a running gnome-terminal, then after exporting that variable I can simply run gnome-terminal without problems. so the value of that variable provided by cinnamon is wrong? is there a possibility to list all possible values that variable could take? ps ux tells me there are multiple dbus sessions running on my user:
Code:
p         5734  0.1  0.1  28628  3552 tty2     S+   08:29   0:00 dbus-daemon --print-address 4 --session
p         5763  0.0  0.1  28144  2972 tty2     S+   08:29   0:00 /usr/bin/dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3
p         5960  0.5  2.2 481240 45200 tty2     Sl+  08:30   0:02 /usr/bin/python2.7 /usr/share/system-config-printer/scp-dbus-service.py
p         6195  0.0  0.1  12756  2272 pts/0    S+   08:37   0:00 grep --colour=auto dbus
I see right after reboot and login...
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Thu Oct 08, 2015 9:13 am    Post subject: Reply with quote

One normal one and one with atk is what I get on my more outdated gnome as well, with things working fine.
ps uxf shows:

Code:
leio       892  0.0  0.0 347188  6236 ?        Sl   10:21   0:00 /usr/libexec/at-spi-bus-launcher
leio       896  0.0  0.0  26360  3264 ?        S    10:21   0:02  \_ /usr/bin/dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3
leio       889  0.0  0.0  26996  3192 ?        Ss   10:21   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
leio       888  0.0  0.0  24432  1872 ?        S    10:21   0:00 /usr/bin/dbus-launch --exit-with-session gnome-session


dbus-launch --exit-with-session is what I had in mind from coming automatically from gdm usage. It's one PID before the main dbus-daemon one, so it was ran from that dbus-launch and daemonized or something.
And yeah, DBUS_SESSION_BUS_ADDRESS is important here, but I'm not sure if that's the only thing.
As for gnome-terminal, it's a singleton app within a session, running it again within the same session, just makes it spawn a new window. There's a /usr/libexec/gnome-terminal-server in the background, and so on. There used to be a --disable-factory option to do a fully separate process, but with the conversion to GApplication and co, it went away. Maybe something based on that affects what you observe.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Thu Oct 08, 2015 2:03 pm    Post subject: Reply with quote

well, I did do what you say, and it works: I changed /usr/bin/cinnamon-session-cinnamon to
Code:
#! /bin/sh
exec /usr/bin/dbus-launch --exit-with-session cinnamon-session --session cinnamon "$@"
and I guess with gnome I must do something similar. however, this change will go away next time I upgrade gnome-extra/cinnamon from 2.6.13 to whatever comes next...

so, should I file a bug to make that change permanent, or is there a better solution?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sun Oct 11, 2015 4:57 am    Post subject: Reply with quote

Something is wrong there. Do you have a ~/.xinitrc file or something? These things should be set up out of the box to work fine for those common desktops.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Mon Oct 12, 2015 10:30 am    Post subject: Reply with quote

I tried creating one, but gdm-3.16.2 ignores it. do I need to try the newer, masked version of gdm? as I said, the problem probably isn't gdm, otherwise there would be more problems than just with gnome-terminal. some kind of dbus gets launched by cinnamon, although no --exit-with-session is used. problem is just that this dbus cannot provide the required localization info for gnome-terminal. dbus-launch from commandline or the cinnamon-session-cinnamon script does. I do have "dbus-daemon" running with 2 addresses, one of them for accessibility and the other with --session obviously for cinnamon. do I really need dbus-launch to start up a 3rd dbus-daemon, in addition? maybe it's /etc/dbus-1/session.conf which needs to get changed to perform the same things as dbus-launch would?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Oct 24, 2015 2:08 pm    Post subject: Reply with quote

You must not have a .xinitrc or the automatic dbus starting might be overridden and not work. If you do have it, you'd have to dbus-launch inside it.
I think you said you tried an empty gdm custom configuration - how about going back to as shipped instead, where there isn't any configuration there, or whatever comes out of the box?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Nitro_146
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 221
Location: Digne les bains, France

PostPosted: Mon Jun 06, 2016 7:12 pm    Post subject: Reply with quote

Hello,

Sorry to raise this tread, but I have the same problem.

I do not have .xinitrc file.

Any hints ?

Thank you.
_________________
Linux, cause booting is for adding new hardware
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Thu Apr 13, 2017 10:21 am    Post subject: Reply with quote

somewhere I've read the problem might be caused by a crash in dbus, haven't looked into that yet.

my solution above stopped to work after an update since the changes got overwritten. another thing I noticed after an upgrade this very problem disappeared in gnome. also, inspired by some other users with the same problem, I created a new user and that empty user-directory isn't causing this behaviour either. guess I need to delete all config-files that this new user now has and try recreating them.

i.e. for now the solution is "rm -Rf ~/.??*" which naturally I haven't tried yet and don't recommend. ;-)
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Thu Apr 13, 2017 10:26 am    Post subject: Reply with quote

Actually just earlier today we were debugging a similar issue with feaderbliss for https://xyinn.org/ GNOME image, and it turned out to be due to the user locale being C or POSIX, instead of en_US.utf-8 or something like that. Maybe that's the same issue here?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Nitro_146
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 221
Location: Digne les bains, France

PostPosted: Thu Apr 13, 2017 8:46 pm    Post subject: Reply with quote

Thank for those answers, but I am not using Gentoo anymore (switched to Debian).
_________________
Linux, cause booting is for adding new hardware
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Fri Apr 14, 2017 5:40 am    Post subject: Reply with quote

in /etc/locale.conf I have LANG=de_AT.utf8 and this gets honoured by commandline utils and cinnamon, for both users!

you're saying there also is a local language setup hidden somewhere in my home-directory?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Fri Apr 14, 2017 7:47 am    Post subject: Reply with quote

piotr5 wrote:
in /etc/locale.conf I have LANG=de_AT.utf8 and this gets honoured by commandline utils and cinnamon, for both users!

you're saying there also is a local language setup hidden somewhere in my home-directory?


If the "locale" command in some other terminal launched inside the DE shows LANG=de_AT.utf8 and no C or POSIX for the other stuff, then you are suffering something else, not the thing I thought as a possibility here. At the very start the error definitely seemed like it would be this, but maybe now, well over a year later, the error is something different? Can you try launching gnome-terminal from inside some other working terminal inside your desktop environment and see what it tells nowadays?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Fri Apr 14, 2017 2:49 pm    Post subject: Reply with quote

you're right, the message changed, it's exit status 9 instead of 8.

according to https://wiki.gnome.org/Apps/Terminal/FAQ:
Quote:
Reason: The locale settings in the environment that gnome-terminal-server is started with describe a nonexistent locale. Consult your distribution's documentation on how to fix this. Note that is it not relevant to check the locale settings from a different terminal (e.g. xterm); what counts is the environment that the session dbus-demon passes to the processes it starts.
so maybe the locale is now gibberish until I start the terminal with dbus-launch? so I suppose I need to change some dbus-variable to the correct value provided by dbus-launch! obviously this happened before, otherwise the message wouldn't have changed. :-)
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sun Apr 16, 2017 6:38 am    Post subject: Reply with quote

You have some more fundamental startup issues if this doesn't work right imho. How are you starting the desktop environment, etc, nowadays?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
piotr5
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2012
Posts: 100

PostPosted: Sat Apr 22, 2017 7:59 am    Post subject: Reply with quote

same as always, systemd starts gdm, and I have gdm set to autologin me right into cinnamon. at random times this setup fails and I get logged in into gnome automatically. (in gnome the gnome-terminal works as it should.) then I just restart the computer and get back into cinnamon without problems, always. errorously starting into gnome happens so rarely that it doesn't bother me. :-)

also during boot I don't seem to have any problems except for bluetooth. well, one problem I have but don't think it's related: systemd-vconsole-setup.service entered failed state because loadkeys complained of "unicode keysym out of range: U+FB01" and thereby I have us-keyboard on text-mode-commandline and in my newly created user-account...

to summarize: gdm does a good job in starting gnome and it does a mediocre job in starting cinnamon for newly created users (doesn't matter: with us-keyboard or whatever german type of keyboard). but my old account is getting into a broken cinnamon that is unable to start gnome-terminal without dbus-launch. when I type locale in either account, I don't see any difference, language is set up correctly. same if I grep for dbus in "ps ax". so the error I got from gnome-terminal is not very helpful, neither is the fact that I can start it with dbus-launch of any use for finding the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum