Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] system update requires kde-apps/*:5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Utsuho Reiuji
Apprentice
Apprentice


Joined: 03 Apr 2013
Posts: 157

PostPosted: Sat Oct 03, 2015 12:03 pm    Post subject: [solved] system update requires kde-apps/*:5 Reply with quote

Hi guys,
I'm having a bit of a problem regarding emerge and kde (hope this topic is in the correct place..). I don't want to use kde5 and/or plasma5 for now, so with the help of our community, I put these into my package.mask:
Code:
#block KDE5/ Plasma 5 (for now)
kde-apps/*:5
kde-apps/phonon-kde
kde-plasma/*
kde-frameworks/*

Those successfully mask all the packages, but now, if I want to run emerge -avuD @world, I get a mask change request:
Code:
~ # emerge -avuD @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following packages are causing rebuilds:

  (net-libs/miniupnpc-1.9.20150917-r1:0/14::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-p2p/transmission-2.84-r1:0/0::gentoo, ebuild scheduled for merge)
[ebuild     U  ] app-arch/xz-utils-5.2.2::gentoo [5.2.1-r1::gentoo] USE="nls threads -static-libs" ABI_X86="32 (64) (-x32)" 1,430 KiB
[ebuild     U  ] sys-libs/timezone-data-2015g::gentoo [2015f::gentoo] USE="nls -leaps_timezone" 471 KiB
[ebuild     U  ] sys-apps/systemd-226-r1:0/2::gentoo [226:0/2::gentoo] USE="acl kdbus kmod lz4 pam (policykit) seccomp ssl -apparmor -audit -cryptsetup -cur
l -elfutils -gcrypt -gnuefi -http -idn -importd -lzma -nat -qrcode (-selinux) -sysv-utils {-test} -vanilla -xkb" ABI_X86="32 (64) (-x32)" 0 KiB

~~snip~~

[ebuild     U  ] kde-apps/kcontrol-15.08.1:4/15.08::gentoo [15.08.0-r1:4/15.08::gentoo] USE="(-aqua) -debug -handbook" 0 KiB
[ebuild     U  ] dev-db/mariadb-10.1.7_rc:0/18::gentoo [10.0.21-r1:0/18::gentoo] USE="client-libs community cracklib%* embedded extraengine pam perl server ssl tools xml -bindist (-cluster) -debug -galera% -innodb-lz4% -innodb-lzo% -innodb-snappy% -jemalloc -latin1 -mroonga% -odbc -oqgraph -profiling (-selinux) -sphinx -sst-rsync% -sst-xtrabackup% -static -static-libs -systemtap -tcmalloc {-test} -tokudb" ABI_X86="(64) -32 (-x32)" 54,008 KiB
[ebuild     U  ] dev-perl/DBD-mysql-4.32.0::gentoo [4.31.0::gentoo] USE="-embedded {-test}" 144 KiB

Total: 96 packages (90 upgrades, 3 new, 2 in new slots, 1 reinstall), Size of downloads: 237,484 KiB
Conflict: 1 block

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-sound/amarok-2.8.0-r3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#block KDE5/ Plasma 5 (for now)
#>=kde-apps/kmix-15.08.0:5
#>=kde-apps/phonon-kde-15.08.0
=kde-apps/phonon-kde-15.08.1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]


I tried --autounmask-keep-masks but that results in no updates at all:
Code:
~ # emerge -avuD @world --autounmask-keep-masks

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=kde-apps/phonon-kde-4.14.3:4[aqua=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-apps/phonon-kde-15.08.1::gentoo (masked by: package.mask)
/etc/portage/package.mask:
#block KDE5/ Plasma 5 (for now)
#>=kde-apps/kmix-15.08.0:5
#>=kde-apps/phonon-kde-15.08.0

- kde-apps/phonon-kde-15.08.0::gentoo (masked by: package.mask)
- kde-apps/phonon-kde-4.14.3::gentoo (masked by: package.mask)

(dependency required by "kde-apps/kdebase-meta-4.14.3::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


This however cannot be, as there're ebuilds for systemd or transmission and so on. Emerging kde-apps/*:5 packages and removing them afterwards is also no option as some of them break my desktop (kmix, phonon-kde and konsole specifically).
Anyone knows who to prevent portage to pull those in?


Last edited by Utsuho Reiuji on Sun Oct 04, 2015 10:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 12:07 pm    Post subject: Reply with quote

Why did you mask any version of kde-apps/phonon-kde? It is required by amarok, which exactly what the portage message is about.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Utsuho Reiuji
Apprentice
Apprentice


Joined: 03 Apr 2013
Posts: 157

PostPosted: Sat Oct 03, 2015 12:12 pm    Post subject: Reply with quote

The new ones break sound in amarok though
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 12:15 pm    Post subject: Reply with quote

If the new ones break, why do you mask any version? Did you report a bug?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Utsuho Reiuji
Apprentice
Apprentice


Joined: 03 Apr 2013
Posts: 157

PostPosted: Sat Oct 03, 2015 12:20 pm    Post subject: Reply with quote

I did ask on the forums before and apparently, no one experienced this problem, so I thought this might be specific to my system setup.
Also, the new phonon package is part of kde-apps/*:5 which again is something I want to avoid for now. I simply do not have the time to setup a new desktop now, studies keep me extremely busy nowadays...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 12:35 pm    Post subject: Reply with quote

Utsuho Reiuji wrote:
Also, the new phonon package is part of kde-apps/*:5

No it's not:
Code:
$ eshowkw -O phonon-kde
Keywords for kde-apps/phonon-kde:
              |                                 | u         | 
              | a a   a         n   p r     s   | n         | 
              | l m   r h i m m i   p i s   p   | u s       | r
              | p d a m p a 6 i o p c s 3   a x | s l       | e
              | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | e o       | p
              | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | d t       | o
--------------+---------------------------------+-----------+-------
       4.14.3 | o + ~ o o o o o o + + o o o o + | o 4/4.14  | gentoo
--------------+---------------------------------+-----------+-------
      15.08.0 | o ~ o o o o o o o o o o o o o ~ | # 4/15.08 | gentoo
   [I]15.08.1 | o ~ o o o o o o o o o o o o o ~ | o         | gentoo


Again, you mask _any_ version of kde-apps/phonon-kde, not just the newer ones that seem to break your audio. Of course that won't work. Your mask of kde-apps/*:5 makes sure none of kf5-based versions can come up for emerge anyway, so the extra entry is redundant for that matter, and is too broad:

Code:
- kde-apps/phonon-kde-15.08.0::gentoo (masked by: package.mask)
- kde-apps/phonon-kde-4.14.3::gentoo (masked by: package.mask)


Something like >=kde-apps/phonon-kde-15.08 in your package.mask would work instead.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Utsuho Reiuji
Apprentice
Apprentice


Joined: 03 Apr 2013
Posts: 157

PostPosted: Sat Oct 03, 2015 1:11 pm    Post subject: Reply with quote

oh, I see what you mean..
My full package.mask looked like this:
Code:
#block KDE5/ Plasma 5 (for now)
#>=kde-apps/kmix-15.08.0:5
#>=kde-apps/phonon-kde-15.08.0
kde-apps/*:5
kde-apps/phonon-kde
kde-plasma/*
kde-frameworks/*


At some point I masked phonon-kde entirely, but I cannot remember why I did that @.@. Changed that now and will see what happens.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 1:27 pm    Post subject: Reply with quote

Hint: Add comments to the masks you make. Even weeks later you forget what you thought at the time. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Utsuho Reiuji
Apprentice
Apprentice


Joined: 03 Apr 2013
Posts: 157

PostPosted: Sat Oct 03, 2015 1:39 pm    Post subject: Reply with quote

genstorm wrote:
Hint: Add comments to the masks you make. Even weeks later you forget what you thought at the time. ;)

yeah, I really should do that more often. Thanks for the heads up.

Edit: the change in my package.mask fixed this problem, update ran mostly without issues ^.^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum