Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't have japanese input methods working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Cincinnatus
n00b
n00b


Joined: 18 Jul 2014
Posts: 12

PostPosted: Wed Sep 30, 2015 4:43 pm    Post subject: Can't have japanese input methods working Reply with quote

Hi everyone,

I have to write stuff in Japanese on my computer. I merged ibus and ibus-anthy, then unmerged and merged mozc, then unmerged and merged fcitx-anthy but none allow me to write any kana.

Actually I have the same problem than this fellow here : https://forums.gentoo.org/viewtopic-t-954488-highlight-ibus+anthy.html
but no solution proposed worked for me.

I almost always solve problems myself but here it happens nothing so I can't find the problem. Currently I can see the fcitx button on the notification zone, I can configure whatever I want, the "virtual keyboard" shows up, but when I type nothing happens. Since no error happens I'm not sure of what to post here so ask me if needed.

I'm under XFCE4, and kanjis and kanas are printing well in xfce4-terminal. Use with latex is fine too, but I still have to copy/paste them from somewhere else.
I don't take care of the input method in use so if anyone knows well any of them it's perfect for me.

Thank you by advance.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed Sep 30, 2015 5:52 pm    Post subject: Reply with quote

:sigh: you're basically saying "I've made a total mess.".

Let's go with scim-anthy, as that's the one I'm most familiar with (though though one I'm "using" now is a different scim method, but that one comes from my overlay).
Just about the only problem I have with scim is that it reacts poorly to restarts, going as far as making a permanent input grab (but works fine after restarting DE).

Post 'emerge -1pv scim scim-anthy' and your locale setings.

The vars that need to be set:
Code:
GTK_IM_MODULE="ibus"
QT_IM_MODULE="ibus"
XMODIFIERS="@im=ibus"
Back to top
View user's profile Send private message
Cincinnatus
n00b
n00b


Joined: 18 Jul 2014
Posts: 12

PostPosted: Wed Sep 30, 2015 9:32 pm    Post subject: Reply with quote

Thank you for your answer, because yes, actually, this is it...

So let's go with scim.

Code:
emerge -1pv scim scim-anthy
returned :

Code:
Calculating dependencies... done!
[ebuild  N     ] app-i18n/scim-1.4.14::gentoo  USE="gtk3 -doc" 1 484 KiB
[ebuild  N     ] app-i18n/scim-anthy-1.2.7-r1::gentoo  USE="gtk3 nls -kasumi" 676 KiB

Total: 2 packages (2 new), Size of downloads: 2 160 KiB


I merged them and set the variables as said.

My locale set in locale.gen are fr_FR.UTF-8 UTF-8, fr_FR ISO-8859-1, and ja_JP.UTF-8 UTF-8.
eselect locale is set on fr_FR.utf8.

After restarting my computer, loging, and launching X, I can see the scim icon in the notification zone but still not have kana conversion.

There is an option "Masquer la barre d'outils" (-> hide the toolbar) that I keep unchecked, but there is no toolbar over here...

I type here what was written on the terminal where X was launched :

Code:
Smart Common Input Method 1.4.14

Launching a SCIM daemon with Socket FrontEnd ...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11 ...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.14

(scim-panel-gtk:2540): GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a
future version.
(scim-panel-gtk:2540): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be
removed in a future
version.

Starting SCIM as daemon ...
SCIM has been successfully launched.


(I don't know if it is important here, but I am using a hardened system.)
Back to top
View user's profile Send private message
Cincinnatus
n00b
n00b


Joined: 18 Jul 2014
Posts: 12

PostPosted: Thu Oct 01, 2015 8:49 am    Post subject: Reply with quote

Someday, regarding informatics, confucius said "it's a kind of magic" (or it may be Freddie Mercury...)

Well actually I started my computer again this morning and I finally succeeded to launch scim ! Everything works well, but I still sure that scim won't have work if I haven't asked before.

(But I set the vars with scim instead of ibus)

ありがとうございました。⚵
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 521
Location: Germany

PostPosted: Fri Oct 02, 2015 8:06 am    Post subject: Reply with quote

Strange. In my case scim does not start until I hit 'Ctrl-Space'. Maybe you have it activated for all inputs, so that it starts together with X. Check scim-setup.

Also, a while ago I've discovered, that scim does not work well with QT libraries, as result it didn't want to work in skype. Searching in the internet indicated, that one should use scim-bridge for that. So, I've additionally installed this package and set environment variables like this

Code:

QT_IM_MODULE="scim-bridge"
GTK_IM_MODULE="scim-bridge"
XIM_PROGRAM="scim -d"
XMODIFIERS="@im=SCIM"


So far scim works in all places. Though maybe now one does not need such complexities, time goes, things change :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum