Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apache2 and cgi authz_core:error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
manywele
l33t
l33t


Joined: 12 Jul 2003
Posts: 726
Location: Basking in the Zen glow of Jerry

PostPosted: Sun Sep 27, 2015 2:34 am    Post subject: apache2 and cgi authz_core:error Reply with quote

I'm trying to get zoneminder set up. It's all working except the last piece, getting the cgi scripts the right permissions to run. I have tested php and know it's working. I can get to zoneminder's configuration page. It's just the cgi scripts that display images. The directories and executables are all 775. I can get the camera image directly through vlc and mplayer. What am I missing?

/etc/conf.d/apache
Code:
APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D SSL -D SSL_DEFAULT_VHOST -D LANGUAGE -D PHP5 -D PROXY"


Apache2 error
Code:
[authz_core:error] [pid 12884] [client ::1:49124] AH01630: client denied by server configuration: /var/www/localhost/cgi-bin, referer: http://localhost/zm/index.php?view=watch&mid=3


/etc/apache2/vhosts.d/10_zoneminder.conf
Code:
ScriptAlias /cgi-bin/zms "/usr/libexec/zoneminder/cgi-bin/zms"
ScriptAlias /cgi-bin/nph-zms "/usr/libexec/zoneminder/cgi-bin/nph-zms"

<Directory "/usr/libexec/zoneminder/cgi-bin">
  Options +ExecCGI +SymLinksIfOwnerMatch
  AllowOverride All
  Require all granted
</Directory>

Alias /zm "/usr/share/zoneminder/www"

<Directory "/usr/share/zoneminder/www">
  Options -Indexes +MultiViews +FollowSymLinks
  AllowOverride All
  Require all granted
</Directory>
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Sun Sep 27, 2015 1:28 pm    Post subject: Reply with quote

Hi manywele
denial error is for "/var/www/localhost/cgi-bin", while in your config "/zm" is mapped to "/usr/share/zoneminder/www"
there must be something else in your apache config, maybe outside the vhosts directives

Let me know
Regards
Back to top
View user's profile Send private message
manywele
l33t
l33t


Joined: 12 Jul 2003
Posts: 726
Location: Basking in the Zen glow of Jerry

PostPosted: Sun Sep 27, 2015 3:22 pm    Post subject: Reply with quote

Thank you kikko. I was just looking at the cgi-bin and hadn't noticed the wrong pathway. I had to change the cgi-bin settings in vhosts.d/default_vhost.include. Now it finally works. That software was a pain to set up.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum