Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs there are no ebuilds built with USE flags to satisfy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jkredd
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2007
Posts: 90

PostPosted: Mon Sep 21, 2015 3:14 am    Post subject: kdelibs there are no ebuilds built with USE flags to satisfy Reply with quote

Hi forum

I have a problem with upgrage

emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-libs/libattica-0.4.2[qt4]".
!!! One of the following packages is required to complete your request:
- dev-libs/libattica-0.4.2::gentoo (Missing IUSE: qt4)
(dependency required by "kde-base/kdelibs-4.14.49.9999::kde" [ebuild])
(dependency required by "kde-apps/kwalletd-15.08.1::gentoo" [ebuild])
(dependency required by "dev-vcs/subversion-1.9.1::gentoo[kde]" [ebuild])
(dependency required by "dev-vcs/git-2.5.3-r1::gentoo[subversion,perl]" [ebuild])
(dependency required by "sys-devel/gettext-0.19.6::gentoo[git]" [ebuild])
(dependency required by "sys-apps/acl-2.2.52-r1::gentoo[nls]" [ebuild])
(dependency required by "sys-auth/consolekit-1.0.0::gentoo[acl]" [ebuild])
(dependency required by "sys-auth/polkit-0.113::gentoo[-systemd]" [installed])
(dependency required by "net-misc/modemmanager-1.4.10::gentoo" [installed])
(dependency required by "app-misc/geoclue-2.2.0::gentoo[modemmanager]" [installed])
(dependency required by "net-libs/webkit-gtk-2.4.9-r200::gentoo[geoloc]" [installed])
(dependency required by "dev-java/swt-4.2-r2::gentoo[webkit]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


And try emerge dev-libs/libattica-0.4.2 with qt4, but nothig

[ebuild N ] dev-libs/libattica-0.4.2::gentoo USE="-debug {-test}"


Help
Regrads
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Mon Sep 21, 2015 1:16 pm    Post subject: Reply with quote

Hi jkredd
the only dev-libs/libattica available is 0.4.2
the ebuild doesn't have a qt4 USE flag

Question: where in the world have you found the kde-base/kdelibs-4.14.49.9999 ebuild? is that from kde overlay?
Regards
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Tue Sep 22, 2015 12:58 pm    Post subject: Reply with quote

kikko wrote:
Question: where in the world have you found the kde-base/kdelibs-4.14.49.9999 ebuild? is that from kde overlay?


Indeed it is. I guess the overlay wasn't synced lately - that particular ebuild version appears to have been removed late last year.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Tue Sep 22, 2015 3:20 pm    Post subject: Reply with quote

So the suggestion is to run "layman -S" and try again?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum