Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with mouse cursor in firefox (or gtk apps?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Mon Sep 14, 2015 9:08 am    Post subject: Problem with mouse cursor in firefox (or gtk apps?) Reply with quote

Hi guys,

I've recently upgraded my gentoo distro and now I'm facing a really strange issue with _at least_ firefox.
As soon as my mouse cursor is inside the firefox window, it automatically revert to a black one (X11 default cursor ?), as soon as it get out of the inside of firefox windows, it revert back to my kde oxygen cursor.
I'm not completely sure it's a firefox related, it might be related to a gtk issue, maybe related to GTK3 ?

Please note for now I didn't find any other software that is having the same behaviour (even thunderbird for ex).
Another extremely strange thing is that sometimes, the cursor in the firefox windows is the correct one, sometimes it isn't.


My configuration :
It's a dual head Kde 4.14.3.
I also have 2 firefox sessions, one each monitor, and the other one is really less impacted by this issue (>90% time the cursor is correct, while on my default profile it's something like < 40% time).

firefox --version :
Mozilla Firefox 40.0.3 (same issue with the latest stable release)

emerge --info
Code:

Portage 2.2.20.1 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.5, glibc-2.20-r2, 3.18.7-gentoo x86_64)
=================================================================
System uname: Linux-3.18.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    16392700 total,   2347828 free
KiB Swap:   20478972 total,  19451688 free
Timestamp of repository gentoo: Tue, 08 Sep 2015 01:00:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.2.5-r6::gentoo, 3.3.5-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.11.6::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.4.7::gentoo, 4.5.4::gentoo, 4.6.3::gentoo, 4.7.4::gentoo, 4.8.5::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:
...snaped...


ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -mtune=corei7-avx -O2 -pipe -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7-avx -mtune=corei7-avx -O2 -pipe -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mavx -msse4.2 -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi aiglx alsa amd64 apache2 apng berkdb bzip2 cairo cli consolekit cracklib crypt cups cxx dbus device-mapper dri exif extras ffmpeg firefox flac fontconfig fortran gd gd2 gdbm gif gimp glitz gnutls gtk gtk3 gudev hwdb iconv icu intl ipv6 jpeg jpeg2k kde keymap kipi matroska mmx mmxext mng modules mp3 mpeg multilib mysql mysqli ncurses nls nptl nsplugin ogg openal opengl openmp openssl pam pcntl pcre pdf perl png policykit ppds pulseaudio python qt qt3 qt3support qt4 readline sdl seccomp semantic-desktop session sql sse sse2 sse3 ssl svg tcltk tcpd tetex theora tidy tiff truetype unicode usb utf8 v4l v4l2 vaapi vdpau vorbis webkit x264 xml zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_FR en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nouveau intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.4"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



if you have any idea,

Thanks !
Back to top
View user's profile Send private message
Candelabrus
n00b
n00b


Joined: 26 Sep 2015
Posts: 5

PostPosted: Sun Sep 27, 2015 4:33 pm    Post subject: Reply with quote

My solution for this is

Creating one file called "index.theme" inside /home/youruser/.icons/default

Content of index.theme

Code:

[icon theme]
Inherits=mate


Here without this code is same problem yours, always back to "black" cursor mouse when put mouse inside firefox/chrome or steam.
Just adapt for your cursor mouse theme
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1373
Location: Montréal

PostPosted: Sun Sep 27, 2015 5:14 pm    Post subject: Reply with quote

In addition, there is an X variable call Xcursor.theme who can be set to the cursor theme you want. In the .Xresources file of the $USER you can set it
Code:
Xcursor.theme: cursor-theme-name

and force the load of it contain at any time with
Code:
xrdb -merge ~/.Xresources

In the same way, you cant set the variable XCURSOR_THEME=cursor-theme-name in ~/.xinitrc if you use startx or ~/.xsessionrc if you use a display manager. With these variables set to the cursor theme you want, in plus of the cursor theme you have set in your desktop environment, it should be always active.
_________________
Paul
Back to top
View user's profile Send private message
numlock
n00b
n00b


Joined: 17 Sep 2004
Posts: 58

PostPosted: Fri Jun 03, 2016 6:29 pm    Post subject: Possible solution Reply with quote

Hi MasterPrenium,

I've had the same issue with Firefox on KDE Plasma 5 until this morning!

I assume that you have already created the usual symlink at ~/.icons/default .

Well, here's the fix that worked for me:
Add the following line to ~/.config/gtk-3.0/settings.ini under the [Settings] section:
gtk-cursor-theme-name=default
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2414
Location: イタリアのロディで

PostPosted: Thu Jun 09, 2016 7:55 am    Post subject: Reply with quote

Candelabrus wrote:
My solution for this is

Creating one file called "index.theme" inside /home/youruser/.icons/default

Content of index.theme

Code:

[icon theme]
Inherits=mate


Here without this code is same problem yours, always back to "black" cursor mouse when put mouse inside firefox/chrome or steam.
Just adapt for your cursor mouse theme


THIS solution worked with me, but not with gentoo-xcursors.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum