Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg Segment fault at start up [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 996

PostPosted: Mon Sep 14, 2015 8:45 am    Post subject: Xorg Segment fault at start up [SOLVED] Reply with quote

While tweaking xorg-server and mesa for leaner integration, my X server doesn't start anymore.
Another trouble maker is my that wifi theetering only works via xorg-server networkmanager gnome keyring toolstack. No other internet access available.
gcc-4.8.5
xorg-server 1.16.4-r1
xf86-video-intel 2.99.917

It has been working for ages until now. latest msg in xorg.log before segfault is "intel (0) Default visual is TrueColor"

starting via xdm at boot.

I think I toogle suid USE flag back and forth
...
Basically i'm desparated, hoping I will finally avoid reinstall after 5 years of gentoo.

Thks


Last edited by CaptainBlood on Tue Sep 15, 2015 8:35 am; edited 2 times in total
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Mon Sep 14, 2015 11:05 am    Post subject: Reply with quote

Have u upgraded kernel to 4.x ? Its common issue xorg doesnt start there for intel, google solution.
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 996

PostPosted: Tue Sep 15, 2015 2:15 am    Post subject: Reply with quote

my log is almost like
Code:
[url]http://www.linuxquestions.org/questions/slackware-14/xorg-problem-after-upgrade-in-current-x86_64-a-4175551401/[/url][/url]
, still don't know how fix yet.
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 996

PostPosted: Tue Sep 15, 2015 8:34 am    Post subject: Reply with quote

Solved by unmasking xf86-video-intel-2.99.217-r2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum