Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot update to plasma
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Tue Sep 15, 2015 1:21 am    Post subject: Cannot update to plasma Reply with quote

I'm stumped

emerge --pretend --update --deep --newuse --backtrack=50 @system @world

These are the packages that would be merged, in order:

Calculating dependencies done!
[ebuild N ] dev-qt/qtchooser-0_p20150102 USE="qt5 {-test}"
[ebuild U ] dev-libs/xapian-1.3.3 [1.2.21]
[ebuild N ] dev-qt/qtcore-4.8.7 USE="exceptions glib iconv icu qt3support ssl (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qttranslations-4.8.7 ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtscript-4.8.7 USE="exceptions jit (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtgui-4.8.7 USE="accessibility cups exceptions glib mng nas qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nis -pch -trace" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtxmlpatterns-4.8.7 USE="(-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtsvg-4.8.7 USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] x11-libs/qscintilla-2.9 USE="doc -designer"
[ebuild R ] x11-apps/xdpyinfo-1.3.2 USE="xinerama*"
[ebuild N ] dev-qt/qtwebkit-4.8.7 USE="exceptions gstreamer icu jit (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtdbus-4.8.7 USE="exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtcore-5.4.2 USE="icu systemd -debug {-test}"
[ebuild N ] dev-qt/qtdbus-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtxml-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtnetwork-5.4.2 USE="ssl -bindist -connman -debug -networkmanager {-test}"
[ebuild N ] dev-qt/qtscript-5.4.2-r1 USE="jit -debug -scripttools {-test}"
[ebuild N ] dev-qt/qtopengl-4.8.7 USE="exceptions qt3support (-aqua) -debug -egl -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qttest-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtxmlpatterns-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtlockedfile-2.4.1_p20150629 USE="doc qt4 qt5"
[ebuild N ] dev-qt/qtconcurrent-5.4.2 USE="-debug {-test}"
[ebuild N ] virtual/notification-daemon-0 USE="gnome"
[ebuild N ] kde-frameworks/kf-env-3
[ebuild R ] x11-libs/gtk+-2.24.28-r1 USE="xinerama*"
[ebuild N ] dev-qt/qtgui-5.4.2-r1 USE="accessibility dbus gif harfbuzz jpeg png udev xcb -debug -egl -eglfs -evdev -gles2 -gtkstyle -ibus {-test}"
[ebuild N ] dev-qt/qtwidgets-5.4.2 USE="png xcb -debug -gles2 -gtkstyle {-test}"
[ebuild N ] dev-qt/qtx11extras-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtdeclarative-5.4.2-r1 USE="jit widgets xml -debug -gles2 -localstorage {-test}"
[ebuild N ] dev-qt/linguist-tools-5.4.2 USE="qml -debug {-test}"
[ebuild N ] dev-qt/qtprintsupport-5.4.2 USE="cups -debug -gles2 {-test}"
[ebuild N ] dev-qt/qtopengl-5.4.2 USE="-debug -gles2 {-test}"
[ebuild N ] dev-qt/qtsvg-5.4.2 USE="-debug {-test}"
[ebuild N ] dev-qt/qtsql-4.8.7 USE="exceptions mysql odbc postgres qt3support sqlite (-aqua) -debug -freetds -oci8 -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qt3support-4.8.7 USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtdeclarative-4.8.7 USE="accessibility exceptions qt3support webkit (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/qtsql-5.4.2 USE="mysql odbc postgres sqlite -debug -freetds -oci8 {-test}"
[ebuild N ] dev-qt/qtsingleapplication-2.6.1_p20150629 USE="X doc qt4 qt5"
[ebuild N ] dev-qt/qtquickcontrols-5.4.2 USE="widgets -debug {-test}"
[ebuild N ] dev-qt/qtwebkit-5.4.2 USE="gstreamer opengl qml udev -debug -gstreamer010 -multimedia -printsupport {-test} -webp"
[ebuild N ] dev-qt/designer-5.4.2 USE="declarative webkit -debug {-test}"
[ebuild N ] dev-qt/linguist-5.4.2 USE="-debug {-test}"
[ebuild N ] kde-frameworks/extra-cmake-modules-5.14.0 USE="-doc {-test}"
[ebuild N ] kde-frameworks/kapidox-5.14.0 PYTHON_TARGETS="python2_7"
[ebuild R ] x11-base/xorg-server-1.17.2-r1 USE="-kdrive*"
[ebuild N ] dev-libs/libnatspec-0.2.6-r1 USE="doc python" PYTHON_TARGETS="python2_7"
[ebuild N ] kde-frameworks/kcoreaddons-5.14.0 USE="doc nls -debug (-fam) {-test}"
[ebuild N ] kde-frameworks/kconfig-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kwidgetsaddons-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/ki18n-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/kwindowsystem-5.14.0 USE="X doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kdbusaddons-5.14.0 USE="X doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kcodecs-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kitemviews-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/karchive-5.14.0 USE="bzip2 doc lzma -debug {-test}"
[ebuild N ] kde-frameworks/solid-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/sonnet-5.14.0 USE="aspell doc nls -debug -hunspell {-test}"
[ebuild N ] kde-frameworks/kguiaddons-5.14.0 USE="doc -debug {-test}"
[ebuild R ] app-arch/unzip-6.0-r3 USE="natspec*"
[ebuild N ] kde-frameworks/kcrash-5.14.0 USE="X doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kdoctools-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/kcompletion-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kjobwidgets-5.14.0 USE="X doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kservice-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/kglobalaccel-5.14.0 USE="doc nls -debug {-test}"
[ebuild N ] kde-frameworks/kauth-5.14.0 USE="doc nls (policykit) -debug {-test}"
[ebuild N ] kde-frameworks/kconfigwidgets-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/kiconthemes-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/ktextwidgets-5.14.0 USE="doc -debug {-test}"
[ebuild N ] kde-frameworks/kxmlgui-5.14.0 USE="doc -attica -debug {-test}"
[ebuild N ] kde-frameworks/kbookmarks-5.14.0 USE="doc nls -debug {-test}"
[ebuild R ] media-libs/libsdl-1.2.15-r9 USE="xinerama*"
[ebuild R ] media-libs/libsdl2-2.0.3-r200 USE="xinerama*"
[ebuild N ] dev-qt/qtphonon-4.8.7 USE="dbus exceptions qt3support (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] dev-qt/designer-4.8.7 USE="declarative exceptions phonon qt3support webkit (-aqua) -debug -kde -pch" ABI_X86="32 (64) (-x32)"
[ebuild N ] media-libs/phonon-4.8.3-r1 USE="designer gstreamer pulseaudio qt4 qt5 (-aqua) -debug -vlc (-zeitgeist)" ABI_X86="32 (64) (-x32)"
[ebuild N ] media-libs/phonon-gstreamer-4.8.2 USE="alsa network qt4 qt5 -debug"
[ebuild N ] kde-frameworks/knotifications-5.14.0 USE="X dbus doc nls -debug"
[ebuild N ] kde-plasma/polkit-kde-agent-5.4.1 USE="-debug"
[ebuild N ] kde-frameworks/kwallet-5.14.0 USE="doc -debug (-gpg) {-test}"
[ebuild R ] media-video/mpv-0.9.2_p20150824 USE="xinerama*"
[ebuild N ] kde-frameworks/kio-5.14.0 USE="X acl doc kerberos -debug {-test}"
[ebuild N ] kde-frameworks/kinit-5.14.0 USE="caps doc -debug"
[ebuild N ] kde-frameworks/kded-5.14.0 USE="doc -debug"
[ebuild R ] x11-libs/gtk+-3.16.6 USE="xinerama*"
[ebuild R ] gnome-base/gdm-3.16.2 USE="xinerama*"
[blocks B ] media-libs/phonon-gstreamer ("media-libs/phonon-gstreamer" is blocking dev-qt/qtphonon-4.8.7)
[blocks B ] media-libs/phonon ("media-libs/phonon" is blocking dev-qt/qtphonon-4.8.7)
[blocks B ] dev-qt/qtphonon:4 ("dev-qt/qtphonon:4" is hard blocking media-libs/phonon-4.8.3-r1)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(dev-qt/qtphonon-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtphonon-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (~dev-qt/qtphonon-4.8.7[-aqua,-debug,abi_x86_32(-),abi_x86_64(-)]) required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)

(media-libs/phonon-4.8.3-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
media-libs/phonon[qt5] required by (kde-frameworks/knotifications-5.14.0:5/5.14::gentoo, ebuild scheduled for merge)
>=media-libs/phonon-4.7.80[qt4?,qt5?] (>=media-libs/phonon-4.7.80[qt4,qt5]) required by (media-libs/phonon-gstreamer-4.8.2:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Here is my emerge --info

emerge --info
Portage 2.2.20.1 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-4.9.3, glibc-2.21-r1, 4.1.6-gentoo x86_64)
=================================================================
System uname: Linux-4.1.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-3960X_CPU_@_3.30GHz-with-gentoo-2.2
KiB Mem: 65917796 total, 57336484 free
KiB Swap: 2096124 total, 2096124 free
Timestamp of repository gentoo: Mon, 14 Sep 2015 12:45:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash: 4.3_p42::gentoo
dev-java/java-config: 2.2.0::gentoo
dev-lang/perl: 5.22.0::gentoo
dev-lang/python: 2.7.10::gentoo, 3.4.3::gentoo
dev-util/cmake: 3.3.1-r1::gentoo
dev-util/pkgconfig: 0.28-r3::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.17::gentoo
sys-apps/sandbox: 2.7::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake: 1.6.3-r2::gentoo, 1.9.6-r4::gentoo, 1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 4.9.3::gentoo
sys-devel/gcc-config: 1.8::gentoo
sys-devel/libtool: 2.4.6-r1::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.2::gentoo (virtual/os-headers)
sys-libs/glibc: 2.21-r1::gentoo
Repositories:

gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.us.gentoo.org/gentoo-portage
priority: -1000

miscellaneous
location: /usr/portage/local/miscellaneous
masters: gentoo
priority: 0

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9 -l30"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow X a52 aac aalib accessibility acl acpi aften alsa amd64 animate archive ares artworkextra audio audiofile avahi bash-completion beep berkdb bidi bittorrent bluetooth bookmarks branding bzip2 cairo cdda cddb cdio cdr chm cli client clucene corefonts cpudetection cracklib crypt css cups curl cxx dbus declarative deprecated designer-plugin device-mapper dga directfb discouraged doc dri dts dv dvb dvd dvdnav dvdr ebook eds elisp emacs emboss emerald encode esd eselect examples exif expat extra-tools extras fam fat fax fbcon fbcondecor ffmpeg firefox flac flash fltk fontconfig foomaticdb fortran ftp fts3 fuse g3dvl gcj gd gdbm gdu ggi gif gimp glamor glep glib gnome gnutls gphoto2 gpm gstreamer gtk handbook hddtemp hfs hpijs html httpd hwdb hyperestraier iconv idn imagemagick imlib inkjar inotify ipv6 jack jadetex java jfs joystick jpeg jpeg2k kerberos kipi lame lcms ldap libav libcaca libnotify libsamplerate live lm_sensors mad mail matroska md5sum mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono mozilla mp3 mp4 mpeg mplayer multilib musepack musicbrainz mysql nas nautilus ncurses networking new-login nls npp nptl nsplugin ntfs objc odbc offensive ogg openal openexr opengl openmp osdmenu pam pango pcre pdf perl phonon plasma png policykit postgres ppds ps pulseaudio python qml qt3support qt4 qt5 quicktime raptor rar rdesktop readline real realmedia reflection regex reiser4 reiserfs reports samba sametime scanner script sdl seccomp secure-delete semantic-desktop servletapi session sip skins slang slp smp sndfile snmp sound speech speex spell sqlite sse sse2 ssl startup-notification static-ppds stream subversion svg swat sysfs syslog systemd tcpd templates themes theora threads thumbnail tidy tiff timidity tk tools truetype udev udisks unicode unsupported usb utils v4l2 vala vcd vdpau vdr video vlm vmware_guest_linux vorbis wav wavpack weather webkit widgets win32codecs wmf wxwidgets x264 xattr xcb xcomposite xfs xine xinerama xml xorg xpm xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.4"
Unset: CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
AlohaEh
n00b
n00b


Joined: 15 Sep 2015
Posts: 1

PostPosted: Tue Sep 15, 2015 4:25 pm    Post subject: Re: Cannot update to plasma Reply with quote

billydv wrote:
I'm stumped
emerge --pretend --update --deep --newuse --backtrack=50 @system @world
...snip...
[blocks B ] media-libs/phonon-gstreamer ("media-libs/phonon-gstreamer" is blocking dev-qt/qtphonon-4.8.7)
[blocks B ] media-libs/phonon ("media-libs/phonon" is blocking dev-qt/qtphonon-4.8.7)
[blocks B ] dev-qt/qtphonon:4 ("dev-qt/qtphonon:4" is hard blocking media-libs/phonon-4.8.3-r1)


Well, the cheater's way to deal with this is to just uninstall the blockers:
emerge -C media-libs/phonon-gstreamer media-libs/phonon dev-qt/qtphonon

Keep track of these in case you want to roll back.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7005
Location: Austria

PostPosted: Tue Sep 15, 2015 4:26 pm    Post subject: Reply with quote

Find out why dev-qt/qtphonon:4 is on your system. It shouldn't be there when you are coming from a KDE installation, and ultimately blocks emerge of media-libs/phonon.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Tue Sep 15, 2015 7:51 pm    Post subject: Reply with quote

qtphonon is not installed but something is calling for it.
equery d qtphonon shows nothing
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Tue Sep 15, 2015 10:50 pm    Post subject: Reply with quote

Got it going, I had to clean up my make.conf
here is the new one

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /usr/share/portage/config/make.conf.example for a more detailed example
#
### Use this to change to different Motherboard
#CHOST="x86_64-pc-linux-gnu"
#CFLAGS="-mtune=generic -O2 -pipe"
#CXXFLAGS="${CFLAGS}"
##
## Some experimental CFLAGS
#CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
#CFLAGS="-march=core2 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx -msse4.1 -msse4.2 -ftree-vectorize -O2 -ftracer -fweb -pipe -w -frecord-gcc-switches -mtune=generic"
##
### Safe C Flags For Intel I7
#CHOST="x86_64-pc-linux-gnu"
#CFLAGS="-march=core2 -msse4.1 -msse4.2 -mtune=generic -O2 -pipe"
#CXXFLAGS="${CFLAGS}"
##
### C Flags For Intel I7 2600k
#CFLAGS="-march=corei7-avx -mtune=corei7-avx -O2 -pipe"
#CHOST="x86_64-pc-linux-gnu"
#CXXFLAGS="${CFLAGS}"
##
### Use This if supported
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"


USE="3dnow a52 aac aalib abi_x86_32 acl accessibility acpi aften alsa amd64 archive avahi berkdb -bindist bookmarks bluetooth branding bzip2 cairo cdda cddb cdio chm cdr cli client corefonts cpudetection css cracklib crypt cups curl cxx dbus declarative device-mapper dga doc dri dts dv dvb dvd dvdr eds emacs emboss encode examples exif expat extras fam fat firefox flac fontconfig foomaticdb fortran fuse gcj gd gdbm gif gimp glamor glep glib gnome gnutls gphoto2 gpm gstreamer gtk gtkstyle handbook hfs iconv idn imagemagick inotify jack java jfs jpeg jpeg2k kde kerberos kipi lame lcms ldap libav libcaca libnotify libsamplerate lm_sensors mad mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng mono modules mp3 mp4 mpeg multilib musepack nas nautilus ncurses -networkmanager nls nptl nsplugin ntfs objc offensive ogg openal opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pulseaudio python qml qt3support qt4 qt5 quicktime readline regex reiser4 reiserfs samba scanner sdl seccomp semantic-desktop session slang sndfile snmp sound speex spell sqlite sse sse2 ssl startup-notification subversion svg syslog systemd tcpd theora threads tiff timidity tk tools truetype udev udisks unicode upower usb utils vala vcd vdpau vdr video vorbis wav wavpack weather webkit widgets wmf wxwidgets X x264 xattr xcb xcomposite xfs xinerama xml xorg xpm xscreensaver xv xvid xvmc zeroconf zlib"

ABI_X86="32 64"
ACCEPT_KEYWORDS="~amd64"
ACCEPT_LICENSE ="*"
APACHE2_MPMS="prefork"
CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=n"
#EMERGE_DEFAULT_OPTS="--keep-going --jobs=12 --load-average=24"
FEATURES="buildpkg fixlafiles -preserve-libs metadata-transfer"
FFMPEG_IMPL="libav"
INPUT_DEVICES="evdev joystick keyboard mouse"
MAKEOPTS="-j9 -l30"
#MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_ECLASS_WARNING_ENABLE="0"
PORTAGE_ELOG_CLASSES="warn error log info qa"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_NICENESS="-10"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous"
RUBY_TARGETS="ruby20 ruby21 ruby22"
USE_PYTHON="2.7 3.4"
PYTHON_TARGETS="python2_7 python3_4"
PYTHON_SINGLE_TARGET="python2_7"
VIDEO_CARDS="fbdev nvidia vesa"
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 780
Location: Arrakis

PostPosted: Wed Sep 16, 2015 10:19 pm    Post subject: Reply with quote

make sure your using the plasma 5 profile too
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 911
Location: Mount Vernon, NY

PostPosted: Wed Sep 16, 2015 10:42 pm    Post subject: Reply with quote

Turned out that I needed to do a cleanup of make.conf and package.use. Now all emerges fine
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum