Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NetworkManager 1.0.6 broken with openconnect MTU settings
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ppwaskie
n00b
n00b


Joined: 10 Sep 2015
Posts: 12

PostPosted: Fri Sep 11, 2015 1:09 am    Post subject: NetworkManager 1.0.6 broken with openconnect MTU settings Reply with quote

I recently updated my networkmanager install from 1.0.2-r1 to 1.0.6 in portage. Once that happened, my openconnect VPN adapter failed to set the MTU when connecting to what was negotiated with the gateway. I was getting these failures:

Code:

Sep 10 17:31:25 fawkes openconnect[12978]: SIOCSIFMTU: Operation not permitted


The MTU on the tun device, vpn0, would default to 1500 bytes, where it normally sits around 1406. This was causing ssh connections to fail, and other TCP traffic to be unpredictable. I could force the MTU with ifconfig back to 1406, and that would alleviate the issue until I reconnected the VPN.

Downgrading back to net-misc/networkmanager-1.0.2-r1 fixed the issue. My tun device, vpn0, now properly sets its VPN from what was negotiated with the VPN gateway.

Any additional info I can provide please let me know.
Back to top
View user's profile Send private message
poncho
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2011
Posts: 88

PostPosted: Fri Sep 11, 2015 8:37 am    Post subject: Reply with quote

this sounds like https://bugs.gentoo.org/show_bug.cgi?id=559908
Back to top
View user's profile Send private message
ppwaskie
n00b
n00b


Joined: 10 Sep 2015
Posts: 12

PostPosted: Fri Sep 11, 2015 9:46 pm    Post subject: Reply with quote

Yes, that is the bug. Thanks for posting that, I couldn't find it when poking around. Cheers.
Back to top
View user's profile Send private message
Pednick
n00b
n00b


Joined: 19 Nov 2014
Posts: 19

PostPosted: Sun Sep 13, 2015 3:06 am    Post subject: Reply with quote

I just installed gnome systemd and the networkmanager isn't appearing, the network seems to work but there's no icon on top.

Is this the same bug?
Back to top
View user's profile Send private message
ppwaskie
n00b
n00b


Joined: 10 Sep 2015
Posts: 12

PostPosted: Sun Sep 13, 2015 6:28 am    Post subject: Reply with quote

No, the bug is when connecting to a VPN, the MTU isn't getting set correctly based on what is negotiated with the VPN gateway.

It sounds like you might need to install gnome-extra/nm-applet if you haven't already.
Back to top
View user's profile Send private message
Pednick
n00b
n00b


Joined: 19 Nov 2014
Posts: 19

PostPosted: Sun Sep 13, 2015 12:23 pm    Post subject: Reply with quote

ppwaskie wrote:
No, the bug is when connecting to a VPN, the MTU isn't getting set correctly based on what is negotiated with the VPN gateway.

It sounds like you might need to install gnome-extra/nm-applet if you haven't already.


No, it's installed, networkmanager doesn't appear in the processes, I must have made some mistake
during the install, need to figure out what.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Sun Sep 13, 2015 5:18 pm    Post subject: Reply with quote

@Pednick: have you enabled the NetworkManager service at start time?
You can follow this wiki for reference: https://wiki.gentoo.org/wiki/NetworkManager#Starting_and_Enabling_the_Service

@ppwaskie: I've run in a similar problem using openconnect from NM... Have you already tried with openconnect from command line?

Regards
Back to top
View user's profile Send private message
ppwaskie
n00b
n00b


Joined: 10 Sep 2015
Posts: 12

PostPosted: Mon Sep 14, 2015 3:21 am    Post subject: Reply with quote

@kikko: yes, if I have NetworkManager 1.0.6 installed, but connect using the command line with openconnect (thus eliminating NetworkManager from the equation) then the VPN works fine.
Back to top
View user's profile Send private message
Pednick
n00b
n00b


Joined: 19 Nov 2014
Posts: 19

PostPosted: Tue Sep 15, 2015 12:14 am    Post subject: Reply with quote

Nevermind I found out I just had to add this:

root #systemctl enable NetworkManager

Thanks kikko, I just saw your reference after I posted, I found
it in that same place, thank you for your help. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum