Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kcontrol / kdebase-kioslaves / kio-extras block
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ch64
Apprentice
Apprentice


Joined: 09 Jun 2010
Posts: 297

PostPosted: Mon Aug 31, 2015 10:33 pm    Post subject: kcontrol / kdebase-kioslaves / kio-extras block Reply with quote

Hello. I do not know how to solve these Blocks: http://pastebin.com/w3USCLGH

I'm pretty sorry. :roll:
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Mon Aug 31, 2015 10:37 pm    Post subject: Reply with quote

Code:
You may want to try a larger value of the --backtrack option, such as --backtrack=30

...or higher.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ch64
Apprentice
Apprentice


Joined: 09 Jun 2010
Posts: 297

PostPosted: Tue Sep 01, 2015 1:26 am    Post subject: Reply with quote

It doesn't help to use backtrack=30 or backtrack=2600 ... :roll:
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Tue Sep 01, 2015 3:09 am    Post subject: Reply with quote

Code:
[blocks B      ] kde-apps/kcontrol:4 ("kde-apps/kcontrol:4" is blocking kde-apps/kio-extras-15.08.0)
[blocks B      ] kde-apps/kdebase-kioslaves:4[-minimal(-)] ("kde-apps/kdebase-kioslaves:4[-minimal(-)]" is blocking kde-apps/kio-extras-15.08.0)


I don't know why you haven't been looking at what it's saying... You need a newer version on kcontrol, most likly one for qt5 (not qt4); try kde-apps/kcontrol-15.08.0, the same thing for kdebase-kioslaves.
Ironically enough, both have the same version as kio-extras available...
Back to top
View user's profile Send private message
LubosD
Apprentice
Apprentice


Joined: 30 Jun 2005
Posts: 210
Location: Czech Republic

PostPosted: Tue Sep 01, 2015 7:42 am    Post subject: Reply with quote

ct85711 wrote:
Code:
[blocks B      ] kde-apps/kcontrol:4 ("kde-apps/kcontrol:4" is blocking kde-apps/kio-extras-15.08.0)
[blocks B      ] kde-apps/kdebase-kioslaves:4[-minimal(-)] ("kde-apps/kdebase-kioslaves:4[-minimal(-)]" is blocking kde-apps/kio-extras-15.08.0)


I don't know why you haven't been looking at what it's saying... You need a newer version on kcontrol, most likly one for qt5 (not qt4); try kde-apps/kcontrol-15.08.0, the same thing for kdebase-kioslaves.
Ironically enough, both have the same version as kio-extras available...


Because kcontrol and kdebase-kioslaves are in slot 4 (and the ebuilds itself look like KDE 4), even though the versions indicate KDE 5. Who knows why...
Back to top
View user's profile Send private message
ch64
Apprentice
Apprentice


Joined: 09 Jun 2010
Posts: 297

PostPosted: Tue Sep 01, 2015 7:51 am    Post subject: Reply with quote

I do have updated both packets. But the block remains.

Code:
[blocks B      ] kde-apps/kdebase-kioslaves:4[-minimal(-)] ("kde-apps/kdebase-kioslaves:4[-minimal(-)]" is blocking kde-apps/kio-extras-15.08.0)
[blocks B      ] kde-apps/kcontrol:4 ("kde-apps/kcontrol:4" is blocking kde-apps/kio-extras-15.08.0)

Total: 143 packages (107 upgrades, 1 downgrade, 25 new, 7 in new slots, 3 reinstalls, 5 uninstalls), Size of downloads: 308339 KiB
Conflict: 7 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/x264:0

  (media-libs/x264-0.0.20140308:0/142::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/x264-0.0.20090923:0/142= required by (media-video/vlc-2.2.1:0/5-8::gentoo, installed)
                                  ^^^^^^^                                                                                                 

  (media-libs/x264-0.0.20150820:0/148::gentoo, installed) pulled in by
    >=media-libs/x264-0.0.20100423:0/148= required by (media-video/mplayer-1.2_pre20150214:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                             
    (and 1 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kdebase-kioslaves-15.08.0:4/15.08::gentoo, installed) pulled in by
    >=kde-apps/kdebase-kioslaves-4.4:4[aqua=] (>=kde-apps/kdebase-kioslaves-4.4:4[-aqua]) required by (net-p2p/ktorrent-4.3.1-r1:4/4::gentoo, installed)
    kde-apps/kdebase-kioslaves required by @selected
    >=kde-apps/kdebase-kioslaves-4.14.3:4[aqua=] (>=kde-apps/kdebase-kioslaves-4.14.3:4[-aqua]) required by (kde-apps/kdebase-runtime-meta-4.14.3:4/4::gentoo, installed)
    >=kde-apps/kdebase-kioslaves-15.08.0 required by (kde-apps/kdebase-runtime-meta-15.08.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kio-extras-15.08.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kio-extras-15.08.0:5 required by (kde-apps/dolphin-15.08.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kcontrol-15.08.0:4/15.08::gentoo, installed) pulled in by
    >=kde-apps/kcontrol-15.08.0 required by (kde-apps/kdebase-runtime-meta-15.08.0:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/kcontrol-4.14.3:4[aqua=] (>=kde-apps/kcontrol-4.14.3:4[-aqua]) required by (kde-apps/kdebase-runtime-meta-4.14.3:4/4::gentoo, installed)
    kde-apps/kcontrol required by @selected
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Sep 01, 2015 8:19 am    Post subject: Reply with quote

I mean completely remove kcontrol. It is not slotted, and there seems to be a hard block on plasma. I don't know why there even exists a 15.08 version. Unusable together with the other 15.08 kde-apps because of missing slotting.
Back to top
View user's profile Send private message
LubosD
Apprentice
Apprentice


Joined: 30 Jun 2005
Posts: 210
Location: Czech Republic

PostPosted: Tue Sep 01, 2015 8:20 am    Post subject: Reply with quote

Apheus wrote:
I mean completely remove kcontrol. It is not slotted, and there seems to be a hard block on plasma. I don't know why there even exists a 15.08 version. Unusable together with the other 15.08 kde-apps because of missing slotting.

I did, but it's required by kdebase-runtime-meta. Should I get rid of that too?
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Sep 01, 2015 8:27 am    Post subject: Reply with quote

LubosD wrote:
Should I get rid of that too?


Try with the "minimal" use flag on kdebase-runtime-meta first.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Sep 01, 2015 9:57 am    Post subject: Reply with quote

Apheus: Your advice is good for a plasma-5 upgrade, this is not about plasma-5 though.

The problem is that dolphin:5 has kio-extras:5 as a runtime dependency, which blocks kcontrol/kdebase-kioslaves:4 from kde4 workspaces. Mask dolphin:5 to solve the conflict.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Tue Sep 01, 2015 12:13 pm; edited 2 times in total
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Sep 01, 2015 10:31 am    Post subject: Reply with quote

Sorry, I confused this thread with that one from the topic reply notification e-mails.
Back to top
View user's profile Send private message
ch64
Apprentice
Apprentice


Joined: 09 Jun 2010
Posts: 297

PostPosted: Tue Sep 01, 2015 12:15 pm    Post subject: Reply with quote

genstorm. masking the 5er dolphin works.
Back to top
View user's profile Send private message
LubosD
Apprentice
Apprentice


Joined: 30 Jun 2005
Posts: 210
Location: Czech Republic

PostPosted: Tue Sep 01, 2015 3:55 pm    Post subject: Reply with quote

Emerge worked, thanks for advice.

That being said, I already regret moving to KDE 5. Dolphin doesn't start, lockscreen doesn't show up (but the screen is blocked, so I have to reboot) and "The process for the file protocol died unexpectedly" all the time. So it's KDE 4.0 all over again. Jesus.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Tue Sep 01, 2015 4:29 pm    Post subject: Reply with quote

Thanks for your testing and feedback - I've committed some changes which should help address this issue. Specifically, the kde-apps/kdebase-kioslaves block has been removed as it's obsolete, and there's a new revision of kde-apps/kcontrol which should avoid the blocker.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Sep 01, 2015 4:36 pm    Post subject: Reply with quote

LubosD wrote:
That being said, I already regret moving to KDE 5.

Sorry I don't understand, what did you move to? Plasma-5, KDE Applications 15.08 or both?

LubosD wrote:
Dolphin doesn't start, lockscreen doesn't show up (but the screen is blocked, so I have to reboot)

What version of dolphin, init system, login manager?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Tue Sep 01, 2015 11:49 pm    Post subject: Reply with quote

LubosD wrote:
Emerge worked, thanks for advice.

That being said, I already regret moving to KDE 5. Dolphin doesn't start, lockscreen doesn't show up (but the screen is blocked, so I have to reboot) and "The process for the file protocol died unexpectedly" all the time. So it's KDE 4.0 all over again. Jesus.


It's been working here. Dolphin:5 ( 15.08 ) starts and my lockscreen with sddm (+systemd) is functional. I'm in the process of updating today though so I'm unsure if you got some kind of bad update I didn't. If what Kensington did doesn't help you should probably post the logs here or file a bug if you haven't done so. Two people who posted in this thread often commit changes to the kde packages including Kensington who I think is one of the leads if not the lead? Whatever is going on shouldn't be occurring and isn't for everyone using Plasma 5/qt5 packages. So don't worry it will be fixed soon I am sure. Gentoo has exceptional KDE support IMO. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum