Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X won't recognize nouveau [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2889
Location: Illinois, USA

PostPosted: Mon Aug 31, 2015 9:09 pm    Post subject: X won't recognize nouveau [SOLVED] Reply with quote

I'm trying to switch from nvidia-settings to nouveau on a very old system. Portage has been brought up to date (stable amd). I have re-emerged xorg-x11. /etc/make.conf contains the line VIDEO_CARDS="nouveau". The results of lsmod|grep nouveau are:

Code:
biostar log # lsmod | grep nouveau
nouveau              1102618  1
wmi                     7011  1 nouveau
video                  12541  1 nouveau
drm_kms_helper         66941  1 nouveau
ttm                    60334  1 nouveau
drm                   226648  4 ttm,drm_kms_helper,nouveau


Xorg.0.log says:
Quote:
[ 338.201] (EE) Failed to load module "nouveau" (module does not exist, 0)
[ 338.202] (EE) Failed to load module "nv" (module does not exist, 0)
[ 338.202] (EE) Failed to load module "modesetting" (module does not exist, 0)
[ 338.203] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 338.203] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 338.203] (EE) No drivers available.
[ 338.203] (EE)
[ 338.204] (EE) no screens found(EE)
[ 338.204] (EE)
The full log is here: https://bpaste.net/show/80980b41d019

After emerge -auUvD @world, emerge @preserved-libs wanted to re-emerge nvidia-settings which I had unmerged, so I ran revdep-rebuild instead which rebuilt pango, gtkmm and a few other things but not nvidia-settings.

Kind of at a loss here.


Last edited by Tony0945 on Mon Aug 31, 2015 11:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Aug 31, 2015 9:14 pm    Post subject: Reply with quote

You need to emerge xorg-drivers.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Mon Aug 31, 2015 9:20 pm    Post subject: Reply with quote

Tony0945,

nouveau is in two parts. You have the kernel part, so you should get the nouveau framebuffer console.

Xorg.0.log :
[ 338.201] (EE) Failed to load module "nouveau" (module does not exist, 0)

Did you overlook setting VIDEO_CARDS= ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2889
Location: Illinois, USA

PostPosted: Mon Aug 31, 2015 9:26 pm    Post subject: Reply with quote

Quote:
biostar ~ # emerge -a1v xorg-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-base/xorg-drivers-1.16::gentoo INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick (-libinput) -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nouveau -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Emerging now. BTW, when i ran with "nv" I also had "modesetting" in my VIDEO_CARDS, but I don't have it on any of my other three machines, so I took it out.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Mon Aug 31, 2015 9:58 pm    Post subject: Reply with quote

make sure x11-drivers/xf86-video-nouveau is merged...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2889
Location: Illinois, USA

PostPosted: Mon Aug 31, 2015 11:28 pm    Post subject: Reply with quote

The emerge didn't fix the problem but this did.
Quote:
emerge -1 --keep-going --autounmask-keep-masks $(qlist -IC x11-drivers)
. Looking at the verbose output of "emerge xorg-drivers", I see I need to put modesetting et al back into video cards. The output of "qlist -IC x11-drivers)" is:
Quote:
biostar log # qlist -IC x11-drivers
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-mouse
x11-drivers/xf86-video-fbdev
x11-drivers/xf86-video-modesetting
x11-drivers/xf86-video-nouveau
x11-drivers/xf86-video-v4l
x11-drivers/xf86-video-vesa
while :
Quote:
biostar log # emerge -pv xorg-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-base/xorg-drivers-1.16::gentoo INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick (-libinput) -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nouveau -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


But, X is running, Mate is running, palemoon and xrandr are running.

Many thanks, Buffoon, Neddyseagoon and eccerr0r. Don't know why i couldn't fix this. I must have let my brain out somewhere down the road.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum