Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]failed to emerge kde-plasma/plasma-workspace-5.4.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Guest08132015
n00b
n00b


Joined: 13 Aug 2015
Posts: 23

PostPosted: Sun Aug 30, 2015 2:53 pm    Post subject: [SOLVED]failed to emerge kde-plasma/plasma-workspace-5.4.0 Reply with quote

failed to emerge kde-plasma/plasma-workspace-5.4.0


Code:
emerge --info '=kde-plasma/plasma-workspace-5.4.0::gentoo'
Portage 2.2.20.1 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.8.4, glibc-2.20-r2, 4.0.5-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    16370140 total,  13169056 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 30 Aug 2015 15:00:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

Installed sets: @steam
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk gtk+ gtk3 iconv ipv6 jpeg kde kipi lcms ldap libnotify lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opencv opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wavpack widgets wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Code:
emerge -pqv '=kde-plasma/plasma-workspace-5.4.0::gentoo'
[ebuild  N    ] kde-plasma/plasma-workspace-5.4.0  USE="dbus drkonqi handbook systemmonitor -debug -gps (-prison) -qalculate {-test}"


Code:
 * Package:    kde-plasma/plasma-workspace-5.4.0
 * Repository: gentoo
 * Maintainer: kde@gentoo.org
 * USE:        abi_x86_64 amd64 dbus drkonqi elibc_glibc handbook kernel_linux systemmonitor userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking plasma-workspace-5.4.0.tar.xz to /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work
>>> Source unpacked in /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work
>>> Preparing source in /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0 ...
 * Applying plasma-workspace-tests-optional.patch ...
 [ ok ]
 * Applying plasma-workspace-5.4-startkde-script.patch ...
 [ ok ]
 * Applying plasma-workspace-5.4-consolekit2.patch ...
 [ ok ]
 * Applying user patches from /etc/portage/patches//kde-plasma/plasma-workspace ...
 * Done with patching
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_TESTING=OFF -DKDE_INSTALL_USE_QT_SYS_PATHS=ON -DCMAKE_DISABLE_FIND_PACKAGE_dbusmenu-qt5=OFF -DCMAKE_DISABLE_FIND_PACKAGE_libgps=ON -DCMAKE_DISABLE_FIND_PACKAGE_prison=ON -DCMAKE_DISABLE_FIND_PACKAGE_PRISON=ON -DCMAKE_DISABLE_FIND_PACKAGE_Prison=ON -DCMAKE_DISABLE_FIND_PACKAGE_Qalculate=ON -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build/gentoo_rules.cmake -DCMAKE_TOOLCHAIN_FILE=/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build/gentoo_toolchain.cmake  /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build/gentoo_common_config.cmake
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is GNU 4.8.4
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found KF5Plasma: /usr/lib64/cmake/KF5Plasma/KF5PlasmaConfig.cmake (found version "5.13.0")
-- Found KF5DocTools: /usr/lib64/cmake/KF5DocTools/KF5DocToolsConfig.cmake (found version "5.13.0")
-- Found KF5Runner: /usr/lib64/cmake/KF5Runner/KF5RunnerConfig.cmake (found version "5.13.0")
-- Found Gettext: /usr/bin/msgmerge (found version "0.19.4")
-- Found PythonInterp: /usr/bin/python (found version "2.7.9")
-- Found KF5JsEmbed: /usr/lib64/cmake/KF5JsEmbed/KF5JsEmbedConfig.cmake (found version "5.13.0")
-- Found KF5NotifyConfig: /usr/lib64/cmake/KF5NotifyConfig/KF5NotifyConfigConfig.cmake (found version "5.13.0")
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
  Could not find a configuration file for package "KF5Su" that is compatible
  with requested version "5.13.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5Su/KF5SuConfig.cmake, version: 5.12.0
    /usr/lib/cmake/KF5Su/KF5SuConfig.cmake, version: 5.12.0

Call Stack (most recent call first):
  CMakeLists.txt:14 (find_package)


-- Could NOT find KF5Su , checked the following files:
    /usr/lib64/cmake/KF5Su/KF5SuConfig.cmake (version 5.12.0)
    /usr/lib/cmake/KF5Su/KF5SuConfig.cmake (version 5.12.0)

CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
  Could not find a configuration file for package "KF5NewStuff" that is
  compatible with requested version "5.13.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5NewStuff/KF5NewStuffConfig.cmake, version: 5.12.0
    /usr/lib/cmake/KF5NewStuff/KF5NewStuffConfig.cmake, version: 5.12.0

Call Stack (most recent call first):
  CMakeLists.txt:14 (find_package)


-- Could NOT find KF5NewStuff , checked the following files:
    /usr/lib64/cmake/KF5NewStuff/KF5NewStuffConfig.cmake (version 5.12.0)
    /usr/lib/cmake/KF5NewStuff/KF5NewStuffConfig.cmake (version 5.12.0)

-- Found KF5Wallet: /usr/lib64/cmake/KF5Wallet/KF5WalletConfig.cmake (found version "5.13.0")
-- Found KF5KCMUtils: /usr/lib64/cmake/KF5KCMUtils/KF5KCMUtilsConfig.cmake (found version "5.13.0")
-- Found KF5IdleTime: /usr/lib64/cmake/KF5IdleTime/KF5IdleTimeConfig.cmake (found version "5.13.0")
-- Found KF5Declarative: /usr/lib64/cmake/KF5Declarative/KF5DeclarativeConfig.cmake (found version "5.13.0")
-- Found KF5TextWidgets: /usr/lib64/cmake/KF5TextWidgets/KF5TextWidgetsConfig.cmake (found version "5.13.0")
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
  Could not find a configuration file for package "KF5KDELibs4Support" that
  is compatible with requested version "5.13.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5KDELibs4Support/KF5KDELibs4SupportConfig.cmake, version: 5.12.0
    /usr/lib/cmake/KF5KDELibs4Support/KF5KDELibs4SupportConfig.cmake, version: 5.12.0

Call Stack (most recent call first):
  CMakeLists.txt:14 (find_package)


-- Could NOT find KF5KDELibs4Support , checked the following files:
    /usr/lib64/cmake/KF5KDELibs4Support/KF5KDELibs4SupportConfig.cmake (version 5.12.0)
    /usr/lib/cmake/KF5KDELibs4Support/KF5KDELibs4SupportConfig.cmake (version 5.12.0)

-- Found KF5Crash: /usr/lib64/cmake/KF5Crash/KF5CrashConfig.cmake (found version "5.13.0")
-- Found KF5GlobalAccel: /usr/lib64/cmake/KF5GlobalAccel/KF5GlobalAccelConfig.cmake (found version "5.13.0")
-- Found KF5NetworkManagerQt: /usr/lib64/cmake/KF5NetworkManagerQt/KF5NetworkManagerQtConfig.cmake (found version "5.13.0")
-- Found KF5DBusAddons: /usr/lib64/cmake/KF5DBusAddons/KF5DBusAddonsConfig.cmake (found version "5.13.0")
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find KF5 (missing: Su NewStuff KDELibs4Support) (found suitable
  version "5.13.0", minimum required is "5.13.0")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args)
  CMakeLists.txt:14 (find_package)


-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build/CMakeFiles/CMakeOutput.log".
 * ERROR: kde-plasma/plasma-workspace-5.4.0::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3918:  Called kde5_src_configure
 *   environment, line 2852:  Called cmake-utils_src_configure
 *   environment, line 1177:  Called _execute_optionally 'src_configure'
 *   environment, line  676:  Called enable_cmake-utils_src_configure
 *   environment, line 1535:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=kde-plasma/plasma-workspace-5.4.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-plasma/plasma-workspace-5.4.0::gentoo'`.
 * !!! User patches were applied to this build!
 * The complete build log is located at '/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/temp/environment'.
 * Working directory: '/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0_build'
 * S: '/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/work/plasma-workspace-5.4.0'


Last edited by Guest08132015 on Sun Aug 30, 2015 5:10 pm; edited 6 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sun Aug 30, 2015 3:00 pm    Post subject: Reply with quote

That does not contain the error, however I spotted this:
Code:
!!! User patches were applied to this build!

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sun Aug 30, 2015 3:00 pm    Post subject: Reply with quote

It built fine here not too long ago. There was some weirdness in the tree which caused some problems so if you haven't sync'd before attempting to build or upgrade you should do so.

I also note this:

Code:

If you need support, post the output of `emerge --info '=kde-plasma/plasma-workspace-5.4.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-plasma/plasma-workspace-5.4.0::gentoo'`.
 * !!! User patches were applied to this build!
 * The complete build log is located at '/var/tmp/portage/kde-plasma/plasma-workspace-5.4.0/temp/build.log'.


You may want to follow that in order to get better help.
Back to top
View user's profile Send private message
Guest08132015
n00b
n00b


Joined: 13 Aug 2015
Posts: 23

PostPosted: Sun Aug 30, 2015 3:18 pm    Post subject: Reply with quote

genstorm wrote:
That does not contain the error, however I spotted this:
Code:
!!! User patches were applied to this build!


I'm tried to apply patches from /usr/portage/kde-plasma/plasma-workspace/files/ but it don't take any effect
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sun Aug 30, 2015 3:19 pm    Post subject: Reply with quote

Did you emerge --sync and update? It looks like you might not have KF 5.13 installed and it is needed. It looks like you have KF 5.12 installed.
Back to top
View user's profile Send private message
Guest08132015
n00b
n00b


Joined: 13 Aug 2015
Posts: 23

PostPosted: Sun Aug 30, 2015 3:19 pm    Post subject: Reply with quote

davidm wrote:

You may want to follow that in order to get better help.


done

i'm sync'd before compiling
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sun Aug 30, 2015 3:22 pm    Post subject: Reply with quote

Guest08132015 wrote:
davidm wrote:

You may want to follow that in order to get better help.


done

i'm sync'd before compiling


And updated? It looks like the problem is you have frameworks 5.12 where it needs frameworks 5.13

Code:

Could not find a configuration file for package "KF5Su" that is compatible
  with requested version "5.13.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5Su/KF5SuConfig.cmake, version: 5.12.0
    /usr/lib/cmake/KF5Su/KF5SuConfig.cmake, version: 5.12.0


Code:


CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
  Could not find a configuration file for package "KF5NewStuff" that is
  compatible with requested version "5.13.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5NewStuff/KF5NewStuffConfig.cmake, version: 5.12.0
    /usr/lib/cmake/KF5NewStuff/KF5NewStuffConfig.cmake, version: 5.12.0


etc.

It's complaining that it is finding versions other than what are needed.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4404

PostPosted: Sun Aug 30, 2015 3:25 pm    Post subject: Reply with quote

Of course the error is contained: You seem to have only old kf5-libs installed. It wants at least kdesu, kdelibs4support and knewstuff in version 5.13, but you only have installed 5.12
I suggest to run emerge -uDNavt --with-bdeps=y @world first, which most likely will update quite some packages. Probably reporting this issue to the gentoo bugtracker might be good, too, so Gentoo kde devs can pin the dependency version :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sun Aug 30, 2015 3:48 pm    Post subject: Reply with quote

Well, since only kde-frameworks-5.13 is in tree at this point it can only be a local config error.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4404

PostPosted: Sun Aug 30, 2015 4:12 pm    Post subject: Reply with quote

genstorm wrote:
Well, since only kde-frameworks-5.13 is in tree at this point it can only be a local config error.

Does portage automatically update packages when their corresponding ebuild gets removed from the tree? I think you need to do a --deep update even there, but I might be wrong (never tried without --deep :P)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sun Aug 30, 2015 4:26 pm    Post subject: Reply with quote

Actually I guess no, it won't be updated without --deep. Everyone should get the 5.13 update now though through an eclass change.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Guest08132015
n00b
n00b


Joined: 13 Aug 2015
Posts: 23

PostPosted: Sun Aug 30, 2015 5:01 pm    Post subject: Reply with quote

franzf wrote:
Of course the error is contained: You seem to have only old kf5-libs installed. It wants at least kdesu, kdelibs4support and knewstuff in version 5.13, but you only have installed 5.12
I suggest to run emerge -uDNavt --with-bdeps=y @world first, which most likely will update quite some packages. Probably reporting this issue to the gentoo bugtracker might be good, too, so Gentoo kde devs can pin the dependency version :)


I tried
Code:
emerge -uDNavt --with-bdeps=y @world[

but it didn't upgrade any kde-frameworks

than I manually upgrade
kde-frameworks/kdesu
kde-frameworks/kdelibs4support
kde-frameworks/knewstuff

and now it's work! Thanks for help :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum