Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] LXDE no shutdown and reboot buttons
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
branko
n00b
n00b


Joined: 25 Jun 2015
Posts: 8
Location: Serbia

PostPosted: Mon Aug 24, 2015 10:01 pm    Post subject: [SOLVED] LXDE no shutdown and reboot buttons Reply with quote

Hi Guys,

Fresh installed system with LXDE with LXDM does not show shutdown and reboot buttons. Here is what I expect:
http://www.ubuntugeek.com/images/lxde/7.png
And I only have buttons for Logout, Lock Screen and Cancel.

The same happens with root user and for my regular user, so I think there is no problem with permissions which came to my mind first.

LXDM is setup to run on boot with this:
Code:
more /etc/conf.d/xdm | grep lxdm
DISPLAYMANAGER="lxdm"

Code:
rc-update add xdm default

Code:
rc-update | grep xdm
                  xdm |      default


I believe the reason why I don't have shutdown and reboot buttons is because of how LXDE is started:
Code:
more /etc/X11/Sessions/lxde | grep startlxde
exec /usr/bin/startlxde


But I cannot find solution. Do you have any hint what could be the problem?

Thanks in advance.

Regards,
Branko
_________________
Neo: "You ever have that feeling where you're not sure if you're awake or still dreaming?"


Last edited by branko on Tue Aug 25, 2015 7:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 997

PostPosted: Mon Aug 24, 2015 10:42 pm    Post subject: Reply with quote

if you have xdm in rc-update, check and install lxdm (consolekit nls pam -debug -gtk3) if missing; then try to have:
Quote:
cat /etc/conf.d/xdm.conf
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ? [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="lxdm"
n ~ # less xdml.set
n ~ # more ~/templates//etc/conf.d/xdm.lxde
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ? [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="lxdm"
which should start your lxde at boot time.
Hopping I'm no missing anything, please then check about missing features.
Possibly login will remain in console #1, don't forget to try Ctrl/Alt/F7 to go to login screen.

Thks 4 ur attention.
Back to top
View user's profile Send private message
branko
n00b
n00b


Joined: 25 Jun 2015
Posts: 8
Location: Serbia

PostPosted: Tue Aug 25, 2015 5:17 pm    Post subject: Reply with quote

Hi CaptainBlood,

I already installed LXDM. I chose LXDM as my login manager. Here is my whole xdm:
Code:

more /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="lxdm"


CaptainBlood wrote:
which should start your lxde at boot time.

I already managed LXDM and LXDE to start at boot time.

My issue is that I don't have buttons for shutdown and restart as it is shown on above picture.

Thank you for looking into this post.
_________________
Neo: "You ever have that feeling where you're not sure if you're awake or still dreaming?"
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1717

PostPosted: Tue Aug 25, 2015 6:53 pm    Post subject: Reply with quote

AFAIR those buttons depend on polkit and dbus: Dbus must be running before you launch lxde
Back to top
View user's profile Send private message
branko
n00b
n00b


Joined: 25 Jun 2015
Posts: 8
Location: Serbia

PostPosted: Tue Aug 25, 2015 7:52 pm    Post subject: Reply with quote

It works!
Thank you szatox.

I had only to start D-Bus at boot time:
Code:
rc-update add dbus default

And to reboot my machine.
_________________
Neo: "You ever have that feeling where you're not sure if you're awake or still dreaming?"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum