Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg no inicia | Xorg doesn't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Paredes1516
n00b
n00b


Joined: 23 Aug 2015
Posts: 15

PostPosted: Sun Aug 23, 2015 10:12 pm    Post subject: Xorg no inicia | Xorg doesn't start Reply with quote

Hola gente, acabo de instalar Gentoo en mi pc, antes usaba ArchLinux, y no consigo que Xorg inicie, pese a que me parece que lo he instalado bien
dejo un poco de info

Hi guys, I've just finished to install Gentoo on my pc and I can't start Xorg, so this is my info, I hope you can guide me.
Sorry if I write something wrong, my lenguage is spanish.

El log que da Xorg al intentar que inicie

Xorg's log when I make startx

Code:

[   221.055]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[   221.055] X Protocol Version 11, Revision 0
[   221.055] Build Operating System: Linux 4.0.5-gentoo x86_64 Gentoo
[   221.055] Current Operating System: Linux Asus 4.0.5-gentoo #1 SMP Sun Aug 23 18:47:35 CEST 2015 x86_64
[   221.055] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.0.5-gentoo root=UUID=0af33681-bb51-49d3-b6a2-73c41e440bae ro
[   221.055] Build Date: 23 August 2015  10:25:06PM
[   221.055]
[   221.055] Current version of pixman: 0.32.6
[   221.055]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   221.055] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   221.055] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Aug 24 00:45:36 2015
[   221.057] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   221.057] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   221.058] (==) No Layout section.  Using the first Screen section.
[   221.058] (==) No screen section available. Using defaults.
[   221.058] (**) |-->Screen "Default Screen Section" (0)
[   221.058] (**) |   |-->Monitor "<default monitor>"
[   221.058] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[   221.058] (**) |   |-->Device "Device0"
[   221.058] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[   221.058] (==) Automatically adding devices
[   221.058] (==) Automatically enabling devices
[   221.058] (==) Automatically adding GPU devices
[   221.058] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   221.058]    Entry deleted from font path.
[   221.058] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   221.058]    Entry deleted from font path.
[   221.058] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   221.058]    Entry deleted from font path.
[   221.059] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   221.059]    Entry deleted from font path.
[   221.059]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   221.059] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   221.059]    Entry deleted from font path.
[   221.059]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   221.059] (==) FontPath set to:
        /usr/share/fonts/misc/
[   221.059] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   221.059] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   221.059] (II) Loader magic: 0x805c80
[   221.059] (II) Module ABI versions:
[   221.059]    X.Org ANSI C Emulation: 0.4
[   221.059]    X.Org Video Driver: 18.0
[   221.059]    X.Org XInput driver : 21.0
[   221.059]    X.Org Server Extension : 8.0
[   221.059] (--) PCI:*(0:0:2:0) 8086:0412:1043:8534 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[   221.059] (II) LoadModule: "glx"
[   221.065] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   221.076] (II) Module glx: vendor="X.Org Foundation"
[   221.076]    compiled for 1.16.4, module version = 1.0.0
[   221.076]    ABI class: X.Org Server Extension, version 8.0
[   221.076] (==) AIGLX enabled
[   221.076] (II) LoadModule: "intel"
[   221.076] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   221.079] (II) Module intel: vendor="X.Org Foundation"
[   221.079]    compiled for 1.16.4, module version = 2.99.917
[   221.079]    Module class: X.Org Video Driver
[   221.079]    ABI class: X.Org Video Driver, version 18.0
[   221.079] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   221.079] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   221.079] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   221.079] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   221.079] (--) using VT number 7

[   221.101] (EE) No devices detected.
[   221.101] (EE)
Fatal server error:
[   221.101] (EE) no screens found(EE)
[   221.101] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   221.101] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   221.101] (EE)


Lo que muestra lspci -k

lspci -k log

Code:

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
        Subsystem: ASUSTeK Computer Inc. 4th Gen Core Processor DRAM Controller
        Kernel driver in use: hsw_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
        Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
        DeviceName:  Onboard IGD
        Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family USB xHCI
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family MEI Controller
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family USB EHCI
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
        Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
        Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family USB EHCI
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci
00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
        Subsystem: ASUSTeK Computer Inc. C220 Series Chipset Family H81 Express LPC Controller
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode]
        Kernel driver in use: ahci
        Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
        Subsystem: ASUSTeK Computer Inc. 8 Series/C220 Series Chipset Family SMBus Controller
        Kernel modules: i2c_i801
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
        Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        Kernel driver in use: r8169
        Kernel modules: r8169


Lo que dice emerge --info

emerge --info log

Code:

Portage 2.2.20.1 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.4, glibc-2.20-r2, 4.0.5-gentoo x86_64)
=================================================================
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-4460_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:     8053816 total,   7863560 free
KiB Swap:    2160192 total,   2160192 free
Timestamp of repository gentoo: Sun, 23 Aug 2015 00:45:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="spanish"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds python qt3support qt4 readline sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Además de que he creado un fichero en /etc/X11/xorg.conf.d siguiendo la guia que ponen en Gentoo para Intel y lo he llamado 10-device_no_vesa.conf

I've created a file on /etc/X11/xorg.conf.d like handbook says and nothing

Code:

#
# Remove errors regarding modules "fbdev" and "vesa"
#

Section "Device"
        Identifier "Device0"
        Driver "intel"
        Option "Monitor-VGA" "External VGA Monitor"
EndSection


Espero que puedan ayudarme, he buscado ya en el foro pero no encuentro o no entiendo, imagino que ha de poderse por que en ArchLinux no tenía problema alguno con nada.

Hope you can guide me, I've been searching on this forum and Google but nothing. I think this have a solution because in ArchLinux I don't have any problem.


Last edited by Paredes1516 on Sun Aug 23, 2015 10:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Aug 23, 2015 10:25 pm    Post subject: Reply with quote

Your kernel is not configured properly, lspci -k is not showing the driver is loaded.
Back to top
View user's profile Send private message
Paredes1516
n00b
n00b


Joined: 23 Aug 2015
Posts: 15

PostPosted: Sun Aug 23, 2015 10:36 pm    Post subject: Reply with quote

Buffoon wrote:
Your kernel is not configured properly, lspci -k is not showing the driver is loaded.


I've used "genkernel all". I have to load a module or configure my kernel manually?
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Aug 23, 2015 11:21 pm    Post subject: Reply with quote

I am sure there is a Gentoo Wiki page about setting up KMS with Intel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum