Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xfce4-session-logout can't shutdown or other
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ElDavo
n00b
n00b


Joined: 23 Aug 2015
Posts: 12

PostPosted: Sun Aug 23, 2015 7:19 am    Post subject: [SOLVED] xfce4-session-logout can't shutdown or other Reply with quote

Hi guys,
I've a problem with xfce, exactly xfce4-session-logout, part of xfce4-session.
If I run it, i can't shutdown or restart or suspend or hibernate the system. I can only exit from xfce and return to shell.
After a system crash, I've formatted and reinstalled the entire system, but the problem is still here.
Suspend and hibernation support in the kernel are enabled (in fact echo disk or mem > /sys/power/state works).
Dbus daemon is OK.
Code:
dave@huigg ~ $ equery uses xfce4-session
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for xfce-base/xfce4-session-4.12.1:
 U I
 - - debug        : Enable extra debug codepaths, like asserts and extra
                    output. If you want to get meaningful backtraces see https:
                    //wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 + + nls          : Add Native Language Support (using gettext - GNU locale
                    utilities)
 + + policykit    : Enable PolicyKit authentication support
 - - systemd      : Enable use of systemd-specific libraries and features like
                    socket activation or session tracking
 + + upower       : Enable power management support
 + + xscreensaver : Add support for XScreenSaver extension

---
Polkit is working:
dave@huigg ~ $ pkexec
(Password requested with GUI)
huigg ~ #
---
Feel free to request other files or log. :wink:
Thanks in advance!
Edit: If I login as root and startxfce4, all works.
Edit2:
Code:
dave@huigg ~ $ ls -l /sbin/{shutdown,reboot,poweroff}
lrwxrwxrwx 1 root root     4 30 lug 10.30 /sbin/poweroff -> halt
lrwxrwxrwx 1 root root     4 30 lug 10.30 /sbin/reboot -> halt
-rwxr-xr-x 1 root root 23128 30 lug 10.30 /sbin/shutdown

Edit3: Solved myself
Back to top
View user's profile Send private message
ElDavo
n00b
n00b


Joined: 23 Aug 2015
Posts: 12

PostPosted: Sun Aug 23, 2015 8:13 am    Post subject: Polkit not set correctly Reply with quote

SOLVED! The solution was: Polkit is not set correctly.
you need to allow the programs to do root actions without requiring a password:
Taken from Arch Wiki
Code:
/etc/polkit-1/rules.d/49-nopasswd_global.rules

/* Allow members of the wheel group to execute any actions
 * without password authentication, similar to "sudo NOPASSWD:"
 */
polkit.addRule(function(action, subject) {
    if (subject.isInGroup("wheel")) {
        return polkit.Result.YES;
    }
});
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum